aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorJase Thew <jase@FreeBSD.org>2012-08-17 11:11:04 +0000
committerJase Thew <jase@FreeBSD.org>2012-08-17 11:11:04 +0000
commite650ead063d768035c45a0b0db6caf18a940777d (patch)
treeeaec9a0e0b958755134689c2404be195e0ec366a /irc
parent28d9ae65c1b7cc58ccfaf9940a3f70cf6dbbb502 (diff)
downloadports-e650ead063d768035c45a0b0db6caf18a940777d.tar.gz
ports-e650ead063d768035c45a0b0db6caf18a940777d.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/weechat/Makefile2
-rw-r--r--irc/weechat/files/patch-src-gui-curses-gui_curses_chat_c15
2 files changed, 16 insertions, 1 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 87b169167367..1a727a138cb8 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -7,7 +7,7 @@
PORTNAME= weechat
PORTVERSION= 0.3.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= irc
MASTER_SITES= http://weechat.org/files/src/
diff --git a/irc/weechat/files/patch-src-gui-curses-gui_curses_chat_c b/irc/weechat/files/patch-src-gui-curses-gui_curses_chat_c
new file mode 100644
index 000000000000..34c9014d45ac
--- /dev/null
+++ b/irc/weechat/files/patch-src-gui-curses-gui_curses_chat_c
@@ -0,0 +1,15 @@
+--- src/gui/curses/gui-curses-chat.c.orig 2012-05-21 08:52:17.000000000 +0100
++++ src/gui/curses/gui-curses-chat.c 2012-08-17 10:56:08.889994341 +0100
+@@ -484,6 +484,12 @@
+ if (!simulate)
+ {
+ wattr_set (GUI_WINDOW_OBJECTS(window)->win_chat, attrs, pair, NULL);
++ /*
++ * for unknown reason, the wattr_set function sometimes
++ * fails to set the color pair under FreeBSD, so we force
++ * it again with wcolor_set
++ */
++ wcolor_set (GUI_WINDOW_OBJECTS(window)->win_chat, pair, NULL);
+ gui_window_restore_style ();
+ }
+ }