aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-10-21 12:51:40 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-10-21 12:51:40 +0000
commiteabbfd75e30148b8f686899a638b93547ca83485 (patch)
tree5b70e6802d6d9dfe8b4564fc4f09f2d0a5156343 /irc
parentf51fe6e12cc1833af15f8086b22a92af9f8aa4b0 (diff)
downloadports-eabbfd75e30148b8f686899a638b93547ca83485.tar.gz
ports-eabbfd75e30148b8f686899a638b93547ca83485.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/atheme-services/Makefile2
-rw-r--r--irc/eggdrop-devel/Makefile2
-rw-r--r--irc/epic4/Makefile2
-rw-r--r--irc/gseen.mod/Makefile2
-rw-r--r--irc/irssi-dcc_send_limiter/Makefile2
-rw-r--r--irc/keitairc2/Makefile4
-rw-r--r--irc/py-supybot-plugins/Makefile2
-rw-r--r--irc/thales/Makefile2
-rw-r--r--irc/xchat-fish/Makefile2
9 files changed, 10 insertions, 10 deletions
diff --git a/irc/atheme-services/Makefile b/irc/atheme-services/Makefile
index 9b69708cb6fd..3f1072d0d249 100644
--- a/irc/atheme-services/Makefile
+++ b/irc/atheme-services/Makefile
@@ -90,7 +90,7 @@ post-install:
@${RMDIR} ${STAGEDIR}/var/log/atheme
@${RMDIR} ${STAGEDIR}/var/run/atheme
.if !${PORT_OPTIONS:MDOCS}
- @${RM} -Rf ${STAGEDIR}${PREFIX}/share/doc/atheme
+ @${RM} -R ${STAGEDIR}${PREFIX}/share/doc/atheme
.endif
.include <bsd.port.mk>
diff --git a/irc/eggdrop-devel/Makefile b/irc/eggdrop-devel/Makefile
index 6ffe432588f6..cba37c680c0d 100644
--- a/irc/eggdrop-devel/Makefile
+++ b/irc/eggdrop-devel/Makefile
@@ -118,7 +118,7 @@ do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html
cd ${WRKSRC}/doc/html && ${INSTALL_DATA} *.html ${STAGEDIR}${DOCSDIR}/html
@${MKDIR} ${STAGEDIR}${DOCSDIR}/settings
- cd ${WRKSRC}/doc/settings && ${RM} -rf CVS \
+ cd ${WRKSRC}/doc/settings && ${RM} -r CVS \
&& ${INSTALL_DATA} * ${STAGEDIR}${DOCSDIR}/settings
.include <bsd.port.mk>
diff --git a/irc/epic4/Makefile b/irc/epic4/Makefile
index e284382c9a1b..eea10ecbcfe8 100644
--- a/irc/epic4/Makefile
+++ b/irc/epic4/Makefile
@@ -67,7 +67,7 @@ CONFIGURE_ARGS+= --with-termcap
.endif
post-extract:
- @${FIND} ${WRKDIR} -type d -name CVS | ${XARGS} ${RM} -rf
+ @${FIND} ${WRKDIR} -type d -name CVS | ${XARGS} ${RM} -r
post-patch:
@${RM} ${WRKDIR}/help/Makefile
diff --git a/irc/gseen.mod/Makefile b/irc/gseen.mod/Makefile
index 317c9e773b38..963650c2fc31 100644
--- a/irc/gseen.mod/Makefile
+++ b/irc/gseen.mod/Makefile
@@ -27,7 +27,7 @@ MAKE_JOBS_UNSAFE= yes
SUB_FILES= pkg-message
do-extract:
- @${RM} -rf ${WRKDIR}
+ @${RM} -r ${WRKDIR}
@${MKDIR} ${WRKDIR}
@${CP} -R $$(${MAKE} -C ${PORTSDIR}/irc/eggdrop -V WRKSRC) ${WRKSRC}
cd ${WRKSRC}/src/mod && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${EXTRACT_ONLY} ${EXTRACT_AFTER_ARGS}
diff --git a/irc/irssi-dcc_send_limiter/Makefile b/irc/irssi-dcc_send_limiter/Makefile
index 9454bab92cc5..ce9846c6bfe2 100644
--- a/irc/irssi-dcc_send_limiter/Makefile
+++ b/irc/irssi-dcc_send_limiter/Makefile
@@ -29,7 +29,7 @@ PLIST_FILES= lib/irssi/modules/lib/${DISTNAME}.so
CFLAGS+= -shared -fPIC -I${LOCALBASE}/include/irssi -I${LOCALBASE}/include/irssi/src -I${LOCALBASE}/include/irssi/src/core -I${LOCALBASE}/include/irssi/src/irc/core -I${LOCALBASE}/include/irssi/src/irc/dcc `pkg-config --cflags glib-2.0`
do-extract:
- @${RM} -rf ${WRKSRC}
+ @${RM} -r ${WRKSRC}
@${MKDIR} ${WRKSRC}
@${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
diff --git a/irc/keitairc2/Makefile b/irc/keitairc2/Makefile
index 62fca32c64b0..3f50cc1fd67d 100644
--- a/irc/keitairc2/Makefile
+++ b/irc/keitairc2/Makefile
@@ -25,10 +25,10 @@ NO_BUILD= yes
SHEBANG_FILES= keitairc
post-extract:
- ${FIND} ${WRKSRC} -name .cvsignore | ${XARGS} ${RM} -rf
+ ${FIND} ${WRKSRC} -name .cvsignore | ${XARGS} ${RM} -r
post-patch:
- ${FIND} ${WRKSRC} -name '*.orig' | ${XARGS} ${RM} -rf
+ ${FIND} ${WRKSRC} -name '*.orig' | ${XARGS} ${RM} -r
${REINPLACE_CMD} -i '' -e "s,/usr/share/keitairc/lib,${DATADIR}/lib," \
${WRKSRC}/keitairc
${REINPLACE_CMD} -i '' -e "s,__KEITAIRC_DATA_DIR__,${DATADIR}/lib," \
diff --git a/irc/py-supybot-plugins/Makefile b/irc/py-supybot-plugins/Makefile
index 5cc792dadc55..148f5f7df9c2 100644
--- a/irc/py-supybot-plugins/Makefile
+++ b/irc/py-supybot-plugins/Makefile
@@ -19,7 +19,7 @@ USES= python tar:bzip2
post-extract:
# Delete, because it now included in irc/py-supybot
.for data in BadWords Dunno Success _darcs
- @${RM} -rf ${WRKSRC}/${data}
+ @${RM} -r ${WRKSRC}/${data}
.endfor
do-build:
diff --git a/irc/thales/Makefile b/irc/thales/Makefile
index a3b05217e021..05895ab75cc4 100644
--- a/irc/thales/Makefile
+++ b/irc/thales/Makefile
@@ -55,7 +55,7 @@ CONFIGURE_ARGS:= --with-ircd=${_IRCD} \
MODES_CONFIGURE_OFF= --enable-no-modes
post-patch: .SILENT
- ${FIND} -d ${WRKSRC} -type d -name CVS -exec ${RM} -rf {} \;
+ ${FIND} -d ${WRKSRC} -type d -name CVS -exec ${RM} -r {} \;
${REINPLACE_CMD} -e 's,thales.conf,${PREFIX}/etc/&,' \
${WRKSRC}/src/conf.h
diff --git a/irc/xchat-fish/Makefile b/irc/xchat-fish/Makefile
index 97869512f50d..3be609b92301 100644
--- a/irc/xchat-fish/Makefile
+++ b/irc/xchat-fish/Makefile
@@ -31,7 +31,7 @@ PORTDOCS= FiSH-xchat.txt \
OPTIONS_DEFINE= DOCS
post-patch:
- ${RM} -f ${WRKSRC}/mir*
+ ${RM} ${WRKSRC}/mir*
${CP} -pf ${FILESDIR}/Makefile ${WRKSRC}/
do-install: