aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-06-21 22:11:50 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-06-21 22:11:50 +0000
commit4cd9218473abd1b2ac8e714a2fc864bbea5d5c67 (patch)
tree739d677a11d2cd22d6463a6b43d1f69a67896abc /irc
parent7c4f427fb5e18e1f0a5462089f77f65f0d024979 (diff)
downloadports-4cd9218473abd1b2ac8e714a2fc864bbea5d5c67.tar.gz
ports-4cd9218473abd1b2ac8e714a2fc864bbea5d5c67.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/xchat-ruby/Makefile47
-rw-r--r--irc/xchat-ruby/distinfo3
-rw-r--r--irc/xchat-ruby/files/patch-Makefile11
-rw-r--r--irc/xchat-ruby/pkg-descr7
5 files changed, 69 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 6d0800ef3325..29a8d4876535 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -135,6 +135,7 @@
SUBDIR += xchat-fish
SUBDIR += xchat-gnome
SUBDIR += xchat-mircryption
+ SUBDIR += xchat-ruby
SUBDIR += xchat1
SUBDIR += zircon
SUBDIR += znc
diff --git a/irc/xchat-ruby/Makefile b/irc/xchat-ruby/Makefile
new file mode 100644
index 000000000000..d071217e6071
--- /dev/null
+++ b/irc/xchat-ruby/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: XChat ruby
+# Date created: 21 Jun 2008
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+
+PORTNAME= ruby
+PORTVERSION= 1.2
+CATEGORIES= irc ruby
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
+PKGNAMEPREFIX= xchat-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= An ruby-scripting plugin for XChat
+
+RUN_DEPENDS= xchat:${PORTSDIR}/irc/xchat
+
+USE_RUBY= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+DOCSRC= ${WRKDIR}/${DISTNAME}
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+PLIST_FILES= lib/xchat/plugins/xchat-ruby.so
+PORTDOCS= README ChangeLog
+PORTEXAMPLES= embedify.rb TimerSample.rb JFilter.rb JBanner.rb
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xchat-ruby.so \
+ ${PREFIX}/lib/xchat/plugins/
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${DOCSRC}/${doc} \
+ ${DOCSDIR}/
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+.for doc in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${DOCSRC}/*/${doc} \
+ ${EXAMPLESDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/irc/xchat-ruby/distinfo b/irc/xchat-ruby/distinfo
new file mode 100644
index 000000000000..0a92d10de74e
--- /dev/null
+++ b/irc/xchat-ruby/distinfo
@@ -0,0 +1,3 @@
+MD5 (xchat-ruby-1.2-src.tar.gz) = d9a8eafb03c88ac5d8c67b5373f10538
+SHA256 (xchat-ruby-1.2-src.tar.gz) = fc55f48bf72845a2e1750b76524d31813779e1dc8cc7638312a0e68a8efded85
+SIZE (xchat-ruby-1.2-src.tar.gz) = 31129
diff --git a/irc/xchat-ruby/files/patch-Makefile b/irc/xchat-ruby/files/patch-Makefile
new file mode 100644
index 000000000000..62eb06497f0f
--- /dev/null
+++ b/irc/xchat-ruby/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2007-04-26 13:16:32.000000000 +0200
++++ Makefile 2008-06-21 23:35:33.000000000 +0200
+@@ -21,7 +21,7 @@
+ all: $(SO_FILE)
+
+ $(SO_FILE): xchat-ruby.o xchat-ruby-plugin.h
+- $(CC) -L$(ARCHDIR) $(CFLAGS) -shared -o $(SO_FILE) xchat-ruby.o -lruby
++ $(CC) -L$(PREFIX)/lib $(CFLAGS) -shared -o $(SO_FILE) xchat-ruby.o -lruby18
+
+ install: $(SO_FILE)
+ mkdir -p $(XCHAT_DIR)
diff --git a/irc/xchat-ruby/pkg-descr b/irc/xchat-ruby/pkg-descr
new file mode 100644
index 000000000000..5a9c90f60f07
--- /dev/null
+++ b/irc/xchat-ruby/pkg-descr
@@ -0,0 +1,7 @@
+For those of us that prefer the Ruby programming language above all others,
+the XChat-Ruby Plugin now allows X-Chat plugins to written in Ruby,
+in addition to the other supported scripting interfaces. This means that,
+for the first time, you can use a purely object-oriented language
+in which to write X-Chat plugins.
+
+WWW: http://xchat-ruby.sourceforge.net/