aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2005-11-07 10:48:30 +0000
committerKoop Mast <kwm@FreeBSD.org>2005-11-07 10:48:30 +0000
commit9e16294e5d451436047cc00787a10753f129442f (patch)
tree4792fbed023138d4101955e229b1cb08e4b3631b /irc
parente4ef9f7b66f030fd2b592bb1b587d2f9a2647833 (diff)
downloadports-9e16294e5d451436047cc00787a10753f129442f.tar.gz
ports-9e16294e5d451436047cc00787a10753f129442f.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/xchat2/Makefile20
-rw-r--r--irc/xchat2/distinfo4
-rw-r--r--irc/xchat2/pkg-plist38
3 files changed, 20 insertions, 42 deletions
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index d345af3f7112..24536cc2186b 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= xchat2
-PORTVERSION= 2.4.5
-PORTREVISION= 1
+PORTVERSION= 2.6.0
CATEGORIES= irc gnome ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://xchat.org/files/source/2.4/
+ http://xchat.org/files/source/2.6/
MASTER_SITE_SUBDIR= ${PORTNAME:S|2||}
DISTNAME= xchat-${PORTVERSION}
@@ -59,6 +58,16 @@ CONFIGURE_ARGS+=--enable-tcl=no
PLIST_SUB+= TCL="@comment "
.endif
+.if !defined(WITHOUT_DBUS)
+LIB_DEPENDS+= dbus-1.1:${PORTSDIR}/devel/dbus
+CONFIGURE_ARGS+=--enable-dbus
+GCONF_SCHEMAS= apps_xchat_url_handler.schemas
+PLIST_SUB+= DBUS=""
+.else
+CONFIGURE_ARGS+=--disable-dbus
+PLIST_SUB+= DBUS="@comment "
+.endif
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600 || defined(WITHOUT_PERL)
@@ -71,7 +80,7 @@ PLIST_SUB+= PERL=""
.endif
pre-everything::
-.if !defined(WITH_PYTHON) || !defined(WITH_SOCKS) || !defined(WITH_TCL)
+.if !defined(WITH_PYTHON) || !defined(WITH_SOCKS) || !defined(WITH_TCL) || !defined(WITHOUT_PERL) || !defined(WITHOUT_DBUS)
@${ECHO_MSG} "You may specify the following on the command line:"
@${ECHO_MSG} ""
.endif
@@ -87,6 +96,9 @@ pre-everything::
.if !defined(WITHOUT_PERL)
@${ECHO_MSG} "WITHOUT_PERL=yes to disable Perl support"
.endif
+.if !defined(WITHOUT_DBUS)
+ @${ECHO_MSG} "WITHOUT_DBUS=yes to disable dbus support"
+.endif
post-patch:
@${REINPLACE_CMD} -E -e 's|PY_LIBS=.*|PY_LIBS="-L\$$PY_EXEC_PREFIX/lib/python\$$PY_VER/config -lpython\$$PY_VER ${PTHREAD_LIBS} -lutil"|' \
diff --git a/irc/xchat2/distinfo b/irc/xchat2/distinfo
index 100df0bcfb79..1b2605c5dec4 100644
--- a/irc/xchat2/distinfo
+++ b/irc/xchat2/distinfo
@@ -1,2 +1,2 @@
-MD5 (xchat-2.4.5.tar.bz2) = 9107a92693e6c62ff2008030e698b92b
-SIZE (xchat-2.4.5.tar.bz2) = 1324626
+MD5 (xchat-2.6.0.tar.bz2) = 0c827bf6df0572231cbbb1e25965fb61
+SIZE (xchat-2.6.0.tar.bz2) = 796768
diff --git a/irc/xchat2/pkg-plist b/irc/xchat2/pkg-plist
index 683c9342c760..14d7c55d1fdf 100644
--- a/irc/xchat2/pkg-plist
+++ b/irc/xchat2/pkg-plist
@@ -1,45 +1,11 @@
bin/xchat
+bin/xchat-remote
+%%DBUS%%lib/xchat/plugins/dbus.so
%%PERL%%lib/xchat/plugins/perl.so
%%PYTHON%%lib/xchat/plugins/python.so
%%TCL%%lib/xchat/plugins/tcl.so
share/applications/xchat.desktop
-share/locale/am/LC_MESSAGES/xchat.mo
-share/locale/az/LC_MESSAGES/xchat.mo
-share/locale/bg/LC_MESSAGES/xchat.mo
-share/locale/ca/LC_MESSAGES/xchat.mo
-share/locale/cs/LC_MESSAGES/xchat.mo
-share/locale/de/LC_MESSAGES/xchat.mo
-share/locale/el/LC_MESSAGES/xchat.mo
-share/locale/en_GB/LC_MESSAGES/xchat.mo
-share/locale/es/LC_MESSAGES/xchat.mo
-share/locale/et/LC_MESSAGES/xchat.mo
-share/locale/eu/LC_MESSAGES/xchat.mo
-share/locale/fi/LC_MESSAGES/xchat.mo
-share/locale/fr/LC_MESSAGES/xchat.mo
-share/locale/hi/LC_MESSAGES/xchat.mo
-share/locale/it/LC_MESSAGES/xchat.mo
-share/locale/ja/LC_MESSAGES/xchat.mo
-share/locale/ko/LC_MESSAGES/xchat.mo
-share/locale/lt/LC_MESSAGES/xchat.mo
-share/locale/lv/LC_MESSAGES/xchat.mo
-share/locale/mk/LC_MESSAGES/xchat.mo
-share/locale/ms/LC_MESSAGES/xchat.mo
-share/locale/nb/LC_MESSAGES/xchat.mo
share/locale/nl/LC_MESSAGES/xchat.mo
-share/locale/no/LC_MESSAGES/xchat.mo
-share/locale/pa/LC_MESSAGES/xchat.mo
-share/locale/pt/LC_MESSAGES/xchat.mo
-share/locale/pt_BR/LC_MESSAGES/xchat.mo
-share/locale/ru/LC_MESSAGES/xchat.mo
-share/locale/sk/LC_MESSAGES/xchat.mo
-share/locale/sl/LC_MESSAGES/xchat.mo
-share/locale/sq/LC_MESSAGES/xchat.mo
-share/locale/sr/LC_MESSAGES/xchat.mo
-share/locale/sv/LC_MESSAGES/xchat.mo
-share/locale/uk/LC_MESSAGES/xchat.mo
-share/locale/vi/LC_MESSAGES/xchat.mo
-share/locale/wa/LC_MESSAGES/xchat.mo
-share/locale/zh_CN/LC_MESSAGES/xchat.mo
share/locale/zh_TW/LC_MESSAGES/xchat.mo
share/pixmaps/xchat.png
@unexec rmdir %D/share/applications 2> /dev/null || true