aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-02-08 17:02:11 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-02-08 17:02:11 +0000
commitd549dd20de22088692a61f8152a60c9c8ded3166 (patch)
tree62f9f9e6d4e24c859941a2e3136cd78bdbd96a39 /irc
parent72f8e7c88136412161e0d242002728650a504f73 (diff)
downloadports-d549dd20de22088692a61f8152a60c9c8ded3166.tar.gz
ports-d549dd20de22088692a61f8152a60c9c8ded3166.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/irssi-devel/Makefile29
-rw-r--r--irc/irssi-devel/files/patch-eai_nodata11
-rw-r--r--irc/irssi/Makefile29
-rw-r--r--irc/irssi/files/patch-eai_nodata11
4 files changed, 48 insertions, 32 deletions
diff --git a/irc/irssi-devel/Makefile b/irc/irssi-devel/Makefile
index 18b0f573186e..710cabadd760 100644
--- a/irc/irssi-devel/Makefile
+++ b/irc/irssi-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= irssi
PORTVERSION= 0.8.9
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= irc
MASTER_SITES= http://irssi.org/files/
@@ -18,16 +18,23 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
WANT_GNOME= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= irssi.1
-.include <bsd.port.pre.mk>
+# Set option defaults.
-.if ${OSVERSION} >= 502000
-BROKEN= "Does not compile"
+.if ! defined(WITH_SSL)
+WITH_SSL= yes
.endif
-# Set option defaults.
+.if ${WITH_SSL:L} == "no"
+CONFIGURE_ARGS+= --disable-ssl
+.else
+USE_OPENSSL= yes
+.endif
+
+.include <bsd.port.pre.mk>
.if ! defined(WITH_GLIB)
.if exists(${LOCALBASE}/include/glib-2.0/glib.h)
@@ -53,10 +60,6 @@ WITH_SOCKS= no
WITH_IPV6= yes
.endif
-.if ! defined(WITH_SSL)
-WITH_SSL= yes
-.endif
-
.if ! defined(WITH_BOEHM_GC)
WITH_BOEHM_GC= no
.endif
@@ -105,12 +108,6 @@ CATEGORIES+= ipv6
.endif
.endif
-.if ${WITH_SSL:L} == "yes"
-USE_OPENSSL= yes
-.else
-CONFIGURE_ARGS+= --disable-ssl
-.endif
-
.if ${WITH_BOEHM_GC:L} == "yes"
LIB_DEPENDS+= gc.1:${PORTSDIR}/devel/boehm-gc
CONFIGURE_ENV+= CPPFLAGS=-I${PREFIX}/include
@@ -136,7 +133,7 @@ pre-extract:
@${ECHO} ""
pre-configure:
- @cd ${WRKSRC} && ${MV} irssi.conf irssi.conf.sample
+ @cd ${WRKSRC} && ${MV} irssi.conf irssi.conf.sample || ${TRUE}
post-install:
@if [ ! -f ${LOCALBASE}/etc/irssi.conf ]; then \
diff --git a/irc/irssi-devel/files/patch-eai_nodata b/irc/irssi-devel/files/patch-eai_nodata
new file mode 100644
index 000000000000..3d5d32db54fc
--- /dev/null
+++ b/irc/irssi-devel/files/patch-eai_nodata
@@ -0,0 +1,11 @@
+--- src/core/network.c.orig Sat Feb 7 12:48:34 2004
++++ src/core/network.c Sat Feb 7 12:49:40 2004
+@@ -607,7 +607,7 @@
+ int net_hosterror_notfound(int error)
+ {
+ #ifdef HAVE_IPV6
+- return error != 1 && (error == EAI_NONAME || error == EAI_NODATA);
++ return error != 1 && (error == EAI_NONAME);
+ #else
+ return error == HOST_NOT_FOUND || error == NO_ADDRESS;
+ #endif
diff --git a/irc/irssi/Makefile b/irc/irssi/Makefile
index 18b0f573186e..710cabadd760 100644
--- a/irc/irssi/Makefile
+++ b/irc/irssi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= irssi
PORTVERSION= 0.8.9
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= irc
MASTER_SITES= http://irssi.org/files/
@@ -18,16 +18,23 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
WANT_GNOME= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= irssi.1
-.include <bsd.port.pre.mk>
+# Set option defaults.
-.if ${OSVERSION} >= 502000
-BROKEN= "Does not compile"
+.if ! defined(WITH_SSL)
+WITH_SSL= yes
.endif
-# Set option defaults.
+.if ${WITH_SSL:L} == "no"
+CONFIGURE_ARGS+= --disable-ssl
+.else
+USE_OPENSSL= yes
+.endif
+
+.include <bsd.port.pre.mk>
.if ! defined(WITH_GLIB)
.if exists(${LOCALBASE}/include/glib-2.0/glib.h)
@@ -53,10 +60,6 @@ WITH_SOCKS= no
WITH_IPV6= yes
.endif
-.if ! defined(WITH_SSL)
-WITH_SSL= yes
-.endif
-
.if ! defined(WITH_BOEHM_GC)
WITH_BOEHM_GC= no
.endif
@@ -105,12 +108,6 @@ CATEGORIES+= ipv6
.endif
.endif
-.if ${WITH_SSL:L} == "yes"
-USE_OPENSSL= yes
-.else
-CONFIGURE_ARGS+= --disable-ssl
-.endif
-
.if ${WITH_BOEHM_GC:L} == "yes"
LIB_DEPENDS+= gc.1:${PORTSDIR}/devel/boehm-gc
CONFIGURE_ENV+= CPPFLAGS=-I${PREFIX}/include
@@ -136,7 +133,7 @@ pre-extract:
@${ECHO} ""
pre-configure:
- @cd ${WRKSRC} && ${MV} irssi.conf irssi.conf.sample
+ @cd ${WRKSRC} && ${MV} irssi.conf irssi.conf.sample || ${TRUE}
post-install:
@if [ ! -f ${LOCALBASE}/etc/irssi.conf ]; then \
diff --git a/irc/irssi/files/patch-eai_nodata b/irc/irssi/files/patch-eai_nodata
new file mode 100644
index 000000000000..3d5d32db54fc
--- /dev/null
+++ b/irc/irssi/files/patch-eai_nodata
@@ -0,0 +1,11 @@
+--- src/core/network.c.orig Sat Feb 7 12:48:34 2004
++++ src/core/network.c Sat Feb 7 12:49:40 2004
+@@ -607,7 +607,7 @@
+ int net_hosterror_notfound(int error)
+ {
+ #ifdef HAVE_IPV6
+- return error != 1 && (error == EAI_NONAME || error == EAI_NODATA);
++ return error != 1 && (error == EAI_NONAME);
+ #else
+ return error == HOST_NOT_FOUND || error == NO_ADDRESS;
+ #endif