aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-30 07:45:58 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-30 07:45:58 +0000
commit7a5be249a87f1e445018540215cafdafda45c6b8 (patch)
tree4a681a1d6ce9b4635d9dca9cf8d867492f50a042 /irc
parent691ec98874face48062f215e22fec6ad4260a0a1 (diff)
downloadports-7a5be249a87f1e445018540215cafdafda45c6b8.tar.gz
ports-7a5be249a87f1e445018540215cafdafda45c6b8.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/irssi-xmpp/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/irc/irssi-xmpp/Makefile b/irc/irssi-xmpp/Makefile
index a959fcf8c330..037d3270aa20 100644
--- a/irc/irssi-xmpp/Makefile
+++ b/irc/irssi-xmpp/Makefile
@@ -7,25 +7,32 @@ CATEGORIES= irc
MASTER_SITES= http://cybione.org/~irssi-xmpp/files/
MAINTAINER= jadawin@FreeBSD.org
-COMMENT= Irssi-xmpp is an irssi plugin to connect to the Jabber network
+COMMENT= Irssi plugin to connect to Jabber network
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= irssi:${PORTSDIR}/irc/irssi
-RUN_DEPENDS= irssi:${PORTSDIR}/irc/irssi
-LIB_DEPENDS= loudmouth:${PORTSDIR}/net-im/loudmouth
+LIB_DEPENDS= libloudmouth-1.so:${PORTSDIR}/net-im/loudmouth
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= pkgconfig
USE_LDCONFIG= yes
+MAKE_ARGS= CC="${CC}"
+DATADIR= ${PREFIX}/share/irssi
+DOCSDIR= ${PREFIX}/share/doc/irssi
-MAKE_JOBS_UNSAFE=yes
+OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-patch:
+# Try to unbreak parallel builds (-jX)
+ @${REINPLACE_CMD} -E 's|cd (.+) && (\$${MAKE})|\2 -C \1|' \
+ ${WRKSRC}/Makefile ${WRKSRC}/src/Makefile
+# Uphold CFLAGS
+ @${REINPLACE_CMD} -e 's|CFLAGS =|CFLAGS +=|' ${WRKSRC}/config.mk
.if ! ${PORT_OPTIONS:MDOCS}
- ${REINPLACE_CMD} -e 's/ doc-install / /g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|doc-install ||' ${WRKSRC}/Makefile
.endif
.include <bsd.port.mk>