aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2005-04-11 08:04:41 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2005-04-11 08:04:41 +0000
commitf2fc2d60ae226a1b8d5411fb4aab91ea92be6f91 (patch)
treee9a77f53d4fe679665594e718ad34b49668507cc /irc
parent063f8ca62467e4709e58c8bb6b67c85970fe28a1 (diff)
downloadports-f2fc2d60ae226a1b8d5411fb4aab91ea92be6f91.tar.gz
ports-f2fc2d60ae226a1b8d5411fb4aab91ea92be6f91.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/bitchx/Makefile2
-rw-r--r--irc/bopm/Makefile2
-rw-r--r--irc/eggdrop/Makefile2
-rw-r--r--irc/irc/Makefile4
-rw-r--r--irc/irssi-devel/Makefile2
-rw-r--r--irc/irssi/Makefile2
-rw-r--r--irc/miau/Makefile2
-rw-r--r--irc/ngircd/Makefile2
-rw-r--r--irc/quirc/Makefile2
-rw-r--r--irc/srvx/Makefile2
-rw-r--r--irc/undernet-ircu/Makefile2
-rw-r--r--irc/xaric/Makefile2
12 files changed, 13 insertions, 13 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 566a6d1b6f45..a5879a5a5da5 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_ARGS+=--exec-prefix="${PREFIX}/share" \
--bindir="${PREFIX}/bin" \
--datadir="${PREFIX}/share" \
--libdir="${PREFIX}/share" \
- --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+ --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/irc/bopm/Makefile b/irc/bopm/Makefile
index d94f88180110..7c58a62f544c 100644
--- a/irc/bopm/Makefile
+++ b/irc/bopm/Makefile
@@ -16,7 +16,7 @@ COMMENT= Open proxy monitor and blocker, designed for use with ircds
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc
INSTALLS_SHLIB= yes
diff --git a/irc/eggdrop/Makefile b/irc/eggdrop/Makefile
index 863f75301b90..384a5ff31f31 100644
--- a/irc/eggdrop/Makefile
+++ b/irc/eggdrop/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= q@uni.de
COMMENT= The most popular open source Internet Relay Chat bot
USE_BZIP2= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.if !defined(WITHOUT_TCL)
LIB_DEPENDS+= tcl84.1:${PORTSDIR}/lang/tcl84
diff --git a/irc/irc/Makefile b/irc/irc/Makefile
index 2f00bb1b7632..1138cb51e900 100644
--- a/irc/irc/Makefile
+++ b/irc/irc/Makefile
@@ -47,10 +47,10 @@ pre-build:
@${SED} -e "s;%%PREFIX%%;${PREFIX};g" ${FILESDIR}/ircd.sh > ${WRKDIR}/ircd.sh
do-build:
- @(cd ${WRKSRC}/${MACHINE_ARCH}-unknown-freebsd${OSREL}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+ @(cd ${WRKSRC}/${ARCH}-unknown-freebsd${OSREL}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
do-install:
- @(cd ${WRKSRC}/${MACHINE_ARCH}-unknown-freebsd${OSREL} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+ @(cd ${WRKSRC}/${ARCH}-unknown-freebsd${OSREL} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
post-install:
@if [ ! -f ${STARTUP_SCRIPT} ]; then \
diff --git a/irc/irssi-devel/Makefile b/irc/irssi-devel/Makefile
index 710cabadd760..0903c0044de0 100644
--- a/irc/irssi-devel/Makefile
+++ b/irc/irssi-devel/Makefile
@@ -18,7 +18,7 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
WANT_GNOME= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= irssi.1
diff --git a/irc/irssi/Makefile b/irc/irssi/Makefile
index 710cabadd760..0903c0044de0 100644
--- a/irc/irssi/Makefile
+++ b/irc/irssi/Makefile
@@ -18,7 +18,7 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
WANT_GNOME= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= irssi.1
diff --git a/irc/miau/Makefile b/irc/miau/Makefile
index 2540f51a5b23..ad9bbe4f0fad 100644
--- a/irc/miau/Makefile
+++ b/irc/miau/Makefile
@@ -33,7 +33,7 @@ CONFIGURE_ARGS= --enable-dccbounce \
--enable-empty-awaymsg \
--enable-dumpstatus \
--disable-dependency-tracking
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
LIBS="${LIBS}"
diff --git a/irc/ngircd/Makefile b/irc/ngircd/Makefile
index 244b14caa21f..c4c3a65b587f 100644
--- a/irc/ngircd/Makefile
+++ b/irc/ngircd/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= krion@FreeBSD.org
COMMENT= Free open source daemon for Internet Relay Chat (IRC)
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/irc/quirc/Makefile b/irc/quirc/Makefile
index 9a3def068069..bb67585e4968 100644
--- a/irc/quirc/Makefile
+++ b/irc/quirc/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
USE_XLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-wish=${LOCALBASE}/bin/wish8.4 \
--with-tcl-include-dir=${LOCALBASE}/include/tcl8.4 \
--with-tk-include-dir=${LOCALBASE}/include/tk8.4 \
diff --git a/irc/srvx/Makefile b/irc/srvx/Makefile
index 3293b97fcc6b..4f3782c56d1c 100644
--- a/irc/srvx/Makefile
+++ b/irc/srvx/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= weaseal@users.sourceforge.net
COMMENT= Srvx IRC services
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
diff --git a/irc/undernet-ircu/Makefile b/irc/undernet-ircu/Makefile
index 73d4e02baf1d..8d10283447b2 100644
--- a/irc/undernet-ircu/Makefile
+++ b/irc/undernet-ircu/Makefile
@@ -17,7 +17,7 @@ COMMENT= Undernet IRCU irc daemon
CONFLICTS= ircd-hybrid*
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-dpath=${PREFIX}/etc --with-symlink=no
PLIST_FILES= bin/chkconf bin/ircd etc/ircd.conf.example
diff --git a/irc/xaric/Makefile b/irc/xaric/Makefile
index 757470172e4c..4dcd126ef53d 100644
--- a/irc/xaric/Makefile
+++ b/irc/xaric/Makefile
@@ -16,7 +16,7 @@ COMMENT= IRC Client similer to BitchX or ircII
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= xaric.1