aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-01-10 14:20:12 +0000
committerStefan Eßer <se@FreeBSD.org>2022-01-10 15:15:39 +0000
commitbcaf25a8c8046b094f6b5ab5bc258333bc326ee1 (patch)
tree3930596b8cbea97540270b3d78ffb64373c89593 /irc
parentf1661bdbbac2d08cc535e38e41d2bbd3fec025c4 (diff)
downloadports-bcaf25a8c8046b094f6b5ab5bc258333bc326ee1.tar.gz
ports-bcaf25a8c8046b094f6b5ab5bc258333bc326ee1.zip
Fix CONFLICTS entries of multiple ports
There have been lots of missing CONFLICTS_INSTALL entries, either because conflicting ports were added without updating existing ports, due to name changes of generated packages, due to mis-understanding the format and semantics of the conflicts entries, or just due to typoes in package names. This patch is the result of a comparison of all files contained in the official packages with each other. This comparison was based on packages built with default options and may therefore have missed further conflicts with optionally installed files. Where possible, version numbers in conflicts entries have been generalized, some times taking advantage of the fact that a port cannot conflict with itself (due to logic in bsd.port.mk that supresses the pattern match result in that case). A few ports that set the conflicts variables depending on complex conditions (e.g. port options), have been left unmodified, despite probably containing outdated package names. These changes should only affect the installation of locally built ports, not the package building with poudriere. They should give an early indication of the install conflict in cases where currently the pkg command aborts an installation when it detects that an existing file would be overwritten, Approved by: portmgr (implicit)
Diffstat (limited to 'irc')
-rw-r--r--irc/atheme-services/Makefile2
-rw-r--r--irc/bitchx/Makefile2
-rw-r--r--irc/dancer/Makefile2
-rw-r--r--irc/ergo/Makefile2
-rw-r--r--irc/ircd-hybrid/Makefile2
-rw-r--r--irc/ircd-ratbox-devel/Makefile2
-rw-r--r--irc/ircd-ratbox/Makefile2
7 files changed, 12 insertions, 2 deletions
diff --git a/irc/atheme-services/Makefile b/irc/atheme-services/Makefile
index 5435da0432e7..22a1915eb819 100644
--- a/irc/atheme-services/Makefile
+++ b/irc/atheme-services/Makefile
@@ -27,6 +27,8 @@ CONFIGURE_ARGS= --enable-fhs-paths \
CPE_PRODUCT= atheme
+CONFLICTS_INSTALL= lifelines
+
USERS= ircservices
GROUPS= ircservices
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index a47841d00834..1f690b5d30a2 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -20,6 +20,8 @@ CONFIGURE_ARGS+=--exec-prefix="${PREFIX}/share" \
--datadir="${PREFIX}/share" \
--libdir="${PREFIX}/share"
+CONFLICTS_INSTALL= zh-bitchx
+
OPTIONS_SUB= yes
PLIST_SUB+= DISTVERSION=${DISTVERSION}
diff --git a/irc/dancer/Makefile b/irc/dancer/Makefile
index 03d77fd02504..63212fe45ff4 100644
--- a/irc/dancer/Makefile
+++ b/irc/dancer/Makefile
@@ -17,6 +17,8 @@ LDFLAGS+= -lm
CPP= #
USE_CSTD= gnu89
+CONFLICTS_INSTALL= p5-Dancer
+
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/../${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
diff --git a/irc/ergo/Makefile b/irc/ergo/Makefile
index 0d644f7d97ba..96fbd05c08d5 100644
--- a/irc/ergo/Makefile
+++ b/irc/ergo/Makefile
@@ -14,6 +14,8 @@ USES= go:modules
USE_GITHUB= yes
GH_ACCOUNT= ergochat
+CONFLICTS_INSTALL= ergo
+
GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
PLIST_FILES= bin/${PORTNAME}
diff --git a/irc/ircd-hybrid/Makefile b/irc/ircd-hybrid/Makefile
index 4052862cce8f..b5db0e9ddc5d 100644
--- a/irc/ircd-hybrid/Makefile
+++ b/irc/ircd-hybrid/Makefile
@@ -18,6 +18,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
LIB_DEPENDS+= libltdl.so:devel/libltdl
+CONFLICTS_INSTALL= ircd-ratbox ircd-ratbox-devel
+
USERS= ircd
GROUPS= ${USERS}
diff --git a/irc/ircd-ratbox-devel/Makefile b/irc/ircd-ratbox-devel/Makefile
index 5ae8b637e447..577d930d52ce 100644
--- a/irc/ircd-ratbox-devel/Makefile
+++ b/irc/ircd-ratbox-devel/Makefile
@@ -13,7 +13,7 @@ COMMENT= Advanced, stable IRC daemon, used widely on EFnet ('testing' release)
LICENSE= GPLv2
-CONFLICTS= ircd-ratbox charybdis
+CONFLICTS= ircd-hybrid ircd-ratbox
USES= libtool perl5 sqlite tar:bzip2
USE_RC_SUBR= ircd-ratbox
diff --git a/irc/ircd-ratbox/Makefile b/irc/ircd-ratbox/Makefile
index b4d51d127501..061fef4a1f2b 100644
--- a/irc/ircd-ratbox/Makefile
+++ b/irc/ircd-ratbox/Makefile
@@ -12,7 +12,7 @@ COMMENT= Advanced, stable IRC daemon, used widely on EFnet
LICENSE= GPLv2
-CONFLICTS= ircd-ratbox-devel charybdis
+CONFLICTS= ircd-hybrid ircd-ratbox-devel
USES= cpe libtool sqlite tar:bzip2
CPE_VENDOR= ratbox