aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-04-26 02:23:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-04-26 02:23:10 +0000
commit281eb274ecb2ce689e489d6adae5d460358528d6 (patch)
tree306d61a900e73995d51e51904d55a0489215cb38 /irc
parentd3fd1e414dc860f62856e0e2a35b02c050833e83 (diff)
downloadports-281eb274ecb2ce689e489d6adae5d460358528d6.tar.gz
ports-281eb274ecb2ce689e489d6adae5d460358528d6.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/ngircd/Makefile111
-rw-r--r--irc/ngircd/distinfo4
-rw-r--r--irc/ngircd/files/patch-doc-Makefile.in41
-rw-r--r--irc/ngircd/files/patch-man::Makefile.in10
-rw-r--r--irc/ngircd/files/patch-src::ngircd_Makefile.in10
-rw-r--r--irc/ngircd/pkg-descr11
-rw-r--r--irc/ngircd/pkg-plist29
7 files changed, 53 insertions, 163 deletions
diff --git a/irc/ngircd/Makefile b/irc/ngircd/Makefile
index 324e2ee24b16..a1035a1657fa 100644
--- a/irc/ngircd/Makefile
+++ b/irc/ngircd/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= ngircd
-PORTVERSION= 21
+PORTVERSION= 21.1
PORTEPOCH= 1
CATEGORIES= irc ipv6
-MASTER_SITES= ftp://ftp.berlios.de/pub/%SUBDIR%/ \
- http://arthur.barton.de/pub/%SUBDIR%/
+MASTER_SITES= http://arthur.barton.de/pub/%SUBDIR%/ \
+ http://ngircd.mirror.3rz.org/pub/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
@@ -14,69 +14,50 @@ COMMENT= Free open source daemon for Internet Relay Chat (IRC)
LICENSE= GPLv2
-USE_RC_SUBR= ngircd
+USES= tar:xz
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-CPPFLAGS+= -I${LOCALBASE}/include
-
-OPTIONS_DEFINE= DOCS TCP_WRAPPERS SYSLOG ZLIB IPV6 OPENSSL GNUTLS IRCPLUS IDENT SNIFFER DEBUG
-OPTIONS_DEFAULT=TCP_WRAPPERS SYSLOG ZLIB IPV6 IRCPLUS
-NO_OPTIONS_SORT=yes
-TCP_WRAPPERS_DESC= Enable TCP wrappers support
-SYSLOG_DESC= Enable syslog() support
-ZLIB_DESC= Enable ZLIB compression
-IRCPLUS_DESC= Enable IRC+ protocol
-IDENT_DESC= Enable IDENT (AUTH) protocol support
-SNIFFER_DESC= Enable IRC traffic sniffer
-DEBUG_DESC= Show additional debug output
-
-.include <bsd.port.options.mk>
-
-.if exists(/usr/include/tcpd.h) && !defined(WITHOUT_TCP_WRAPPERS)
-CONFIGURE_ARGS+= --with-tcp-wrappers
-.endif
-
-.if empty(PORT_OPTIONS:MSYSLOG)
-CONFIGURE_ARGS+= --without-syslog
-.endif
-
-.if empty(PORT_OPTIONS:MZLIB)
-CONFIGURE_ARGS+= --without-zlib
-.endif
-
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
-
-.if ${PORT_OPTIONS:MOPENSSL}
-CONFIGURE_ARGS+= --with-openssl
-USE_OPENSSL=yes
-.endif
-
-.if ${PORT_OPTIONS:MGNUTLS}
-CONFIGURE_ARGS+= --with-gnutls
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
-.endif
-
-.if empty(PORT_OPTIONS:MIRCPLUS)
-CONFIGURE_ARGS+= --disable-ircplus
-.endif
-
-.if ${PORT_OPTIONS:MIDENT}
-LIB_DEPENDS+= ident:${PORTSDIR}/security/libident
-CONFIGURE_ARGS+= --with-ident
-.endif
-
-.if ${PORT_OPTIONS:MSNIFFER}
-CONFIGURE_ARGS+= --enable-sniffer
-.endif
-
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug
-.endif
+CONFIGURE_ARGS= --disable-silent-rules # --docdir=${WRKDIR}/tmproot
+USE_RC_SUBR= ngircd
-.if ! ${PORT_OPTIONS:MDOCS}
-MAKE_ARGS+= NOPORTDOCS=yes
-.endif
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTDOCS= *
+PLIST_FILES= etc/ngircd.conf.sample \
+ man/man5/ngircd.conf.5.gz \
+ man/man8/ngircd.8.gz \
+ sbin/ngircd
+
+OPTIONS_DEFINE= DEBUG DOCS ICONV IDENT IPV6 IRCPLUS LIBWRAP \
+ SNIFFER SYSLOG ZLIB
+OPTIONS_RADIO= TLS
+OPTIONS_RADIO_TLS= GNUTLS OPENSSL
+OPTIONS_DEFAULT= ICONV IRCPLUS LIBWRAP OPENSSL SYSLOG ZLIB
+
+DEBUG_CONFIGURE_EBABLE= debug
+GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
+GNUTLS_CONFIGURE_WITH= gnutls
+ICONV_USES= iconv
+ICONV_CONFIGURE_WITH= iconv
+IDENT_DESC= IDENT (AUTH) protocol support
+IDENT_LIB_DEPENDS= libident.so:${PORTSDIR}/security/libident
+INDENT_CONFIGURE_WITH= dent
+IPV6_CONFIGURE_ENABLE= ipv6
+IRCPLUS_DESC= IRC+ protocol
+IRCPLUS_CONFIGURE_ENABLE= ircplus
+LIBWRAP_CONFIGURE_WITH= tcp-wrappers
+OPENSSL_USE= openssl=yes
+OPENSSL_CONFIGURE_WITH= openssl
+SNIFFER_DESC= IRC traffic sniffer
+SNIFFER_CONFIGURE_ENABLE= sniffer
+SYSLOG_CONFIGURE_WITH= syslog
+ZLIB_CONFIGURE_WITH= zlib
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/LIBS/s|-liconv|${ICONV_LIB}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ '/toplevel/s| \.\./COPYING|| ; \
+ /INSTALL/s|.conf$$|.conf.sample|' ${WRKSRC}/doc/Makefile.in
.include <bsd.port.mk>
diff --git a/irc/ngircd/distinfo b/irc/ngircd/distinfo
index 8386cc5cd8ce..a0bce696efd1 100644
--- a/irc/ngircd/distinfo
+++ b/irc/ngircd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ngircd-21.tar.gz) = 0edbd41304186e43f9d907a7017b40520cc90c2ce29b1339bdcd7622fffe19a0
-SIZE (ngircd-21.tar.gz) = 500668
+SHA256 (ngircd-21.1.tar.xz) = b5b04f559bb533efc6821f2e62d83af8d196f7aa29a3710ff1e898d4e3c28a6f
+SIZE (ngircd-21.1.tar.xz) = 339092
diff --git a/irc/ngircd/files/patch-doc-Makefile.in b/irc/ngircd/files/patch-doc-Makefile.in
deleted file mode 100644
index e8ecb0fb6797..000000000000
--- a/irc/ngircd/files/patch-doc-Makefile.in
+++ /dev/null
@@ -1,41 +0,0 @@
---- doc/Makefile.in.orig 2013-02-15 11:30:58.000000000 +0000
-+++ doc/Makefile.in 2013-03-07 12:19:53.000000000 +0000
-@@ -588,6 +588,7 @@
- @if [ ! -f $(DESTDIR)$(sysconfdir)/ngircd.conf ]; then \
- make install-config; \
- fi
-+.if !defined(NOPORTDOCS)
- $(mkinstalldirs) $(DESTDIR)$(docdir)
- for f in $(static_docs) $(toplevel_docs); do \
- $(INSTALL) -m 644 -c $(srcdir)/$$f $(DESTDIR)$(docdir)/; \
-@@ -595,12 +596,13 @@
- for f in $(generated_docs); do \
- $(INSTALL) -m 644 -c $$f $(DESTDIR)$(docdir)/; \
- done
-+.endif
-
- install-config:
-- $(INSTALL) -m 600 -c sample-ngircd.conf $(DESTDIR)$(sysconfdir)/ngircd.conf
-+ $(INSTALL) -m 600 -c sample-ngircd.conf $(DESTDIR)$(sysconfdir)/ngircd.conf.sample
- @echo; \
- echo " ** NOTE: Installed sample configuration file:"; \
-- echo " ** \"$(DESTDIR)$(sysconfdir)/ngircd.conf\""; \
-+ echo " ** \"$(DESTDIR)$(sysconfdir)/ngircd.conf.sample\""; \
- echo
-
- uninstall-hook:
-@@ -610,12 +612,12 @@
- else \
- echo; \
- echo " ** NOTE: Not uninstalling changed configuration file:"; \
-- echo " ** \"$(DESTDIR)$(sysconfdir)/ngircd.conf\""; \
-+ echo " ** \"$(DESTDIR)$(sysconfdir)/ngircd.conf.sample\""; \
- echo; \
- fi
-
- uninstall-config:
-- rm -f $(DESTDIR)$(sysconfdir)/ngircd.conf
-+ rm -f $(DESTDIR)$(sysconfdir)/ngircd.conf.sample
-
- srcdoc:
- make -C src srcdoc
diff --git a/irc/ngircd/files/patch-man::Makefile.in b/irc/ngircd/files/patch-man::Makefile.in
deleted file mode 100644
index ee3823f43df1..000000000000
--- a/irc/ngircd/files/patch-man::Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- man/Makefile.in.orig 2010-11-07 08:25:30.000000000 -0800
-+++ man/Makefile.in 2010-12-07 12:38:35.848917613 -0800
-@@ -36,7 +36,6 @@
- install_sh_PROGRAM = $(install_sh) -c
- install_sh_SCRIPT = $(install_sh) -c
- INSTALL_HEADER = $(INSTALL_DATA)
--transform = $(program_transform_name)
- NORMAL_INSTALL = :
- PRE_INSTALL = :
- POST_INSTALL = :
diff --git a/irc/ngircd/files/patch-src::ngircd_Makefile.in b/irc/ngircd/files/patch-src::ngircd_Makefile.in
deleted file mode 100644
index f251daec374f..000000000000
--- a/irc/ngircd/files/patch-src::ngircd_Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/ngircd/Makefile.in.orig 2010-11-07 08:25:30.000000000 -0800
-+++ src/ngircd/Makefile.in 2010-12-07 12:39:20.309256054 -0800
-@@ -35,7 +35,6 @@
- install_sh_PROGRAM = $(install_sh) -c
- install_sh_SCRIPT = $(install_sh) -c
- INSTALL_HEADER = $(INSTALL_DATA)
--transform = $(program_transform_name)
- NORMAL_INSTALL = :
- PRE_INSTALL = :
- POST_INSTALL = :
diff --git a/irc/ngircd/pkg-descr b/irc/ngircd/pkg-descr
index 3976483a56a3..968dddd2203e 100644
--- a/irc/ngircd/pkg-descr
+++ b/irc/ngircd/pkg-descr
@@ -1,8 +1,7 @@
-ngIRCd is an Open-Source server for the Internet Relay Chat (IRC), which is
-developed and published under the terms of the GNU General Public Licence.
-ngIRCd means "next generation IRC daemon", it's written from scratch and not
-deduced from the "grandfather of IRC daemons", the daemon of the IRCNet.
-
-LICENSE: GPL2 or later
+ngIRCd is a free, portable and lightweight Internet Relay Chat server
+for small or private networks, developed under the GNU General Public
+License. It is simple to configure, can cope with dynamic IP addresses,
+and supports IPv6 as well as SSL. It is written from scratch and not
+based on the original IRCd.
WWW: http://ngircd.barton.de/
diff --git a/irc/ngircd/pkg-plist b/irc/ngircd/pkg-plist
index f7beb6eb9ad2..e69de29bb2d1 100644
--- a/irc/ngircd/pkg-plist
+++ b/irc/ngircd/pkg-plist
@@ -1,29 +0,0 @@
-etc/ngircd.conf.sample
-sbin/ngircd
-man/man5/ngircd.conf.5.gz
-man/man8/ngircd.8.gz
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/Bopm.txt
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/Capabilities.txt
-%%PORTDOCS%%%%DOCSDIR%%/Commands.txt
-%%PORTDOCS%%%%DOCSDIR%%/Contributing.txt
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/FAQ.txt
-%%PORTDOCS%%%%DOCSDIR%%/GIT.txt
-%%PORTDOCS%%%%DOCSDIR%%/HowToRelease.txt
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/Modes.txt
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/PAM.txt
-%%PORTDOCS%%%%DOCSDIR%%/Platforms.txt
-%%PORTDOCS%%%%DOCSDIR%%/Protocol.txt
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README-AUX.txt
-%%PORTDOCS%%%%DOCSDIR%%/README-BeOS.txt
-%%PORTDOCS%%%%DOCSDIR%%/README-Interix.txt
-%%PORTDOCS%%%%DOCSDIR%%/RFC.txt
-%%PORTDOCS%%%%DOCSDIR%%/SSL.txt
-%%PORTDOCS%%%%DOCSDIR%%/Services.txt
-%%PORTDOCS%%%%DOCSDIR%%/sample-ngircd.conf
-%%PORTDOCS%%@dirrm %%DOCSDIR%%