aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-08-14 17:25:57 +0000
committerSteve Wills <swills@FreeBSD.org>2011-08-14 17:25:57 +0000
commitc55c427673ffc35ae953ab236159828f9992fefe (patch)
treed8c80938bc395feec29abd970408df8e3ac564df /irc
parent372b3482014a8d7e02853e661befc84876750e7e (diff)
downloadports-c55c427673ffc35ae953ab236159828f9992fefe.tar.gz
ports-c55c427673ffc35ae953ab236159828f9992fefe.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Hailo/Makefile34
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Hailo/distinfo2
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Hailo/pkg-descr3
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Hailo/pkg-plist12
5 files changed, 52 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index f1633bebaccd..2835f93a2afd 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -86,6 +86,7 @@
SUBDIR += p5-POE-Component-IRC-Plugin-Blowfish
SUBDIR += p5-POE-Component-IRC-Plugin-Bollocks
SUBDIR += p5-POE-Component-IRC-Plugin-CoreList
+ SUBDIR += p5-POE-Component-IRC-Plugin-Hailo
SUBDIR += p5-POE-Component-IRC-Plugin-POE-Knee
SUBDIR += p5-POE-Component-IRC-Plugin-QueryDNS
SUBDIR += p5-POE-Component-IRC-Plugin-QueryDNSBL
diff --git a/irc/p5-POE-Component-IRC-Plugin-Hailo/Makefile b/irc/p5-POE-Component-IRC-Plugin-Hailo/Makefile
new file mode 100644
index 000000000000..8e893f9f4111
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-Hailo/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: POE-Componenet-IRC-Plugin-Hailo
+# Date created: 2011-07-19
+# Whom: milki <milki@rescomp.berkeley.edu>
+#
+# $FreeBSD$
+
+PORTNAME= POE-Component-IRC-Plugin-Hailo
+PORTVERSION= 0.16
+CATEGORIES= irc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:HINRIK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= milki@rescomp.berkeley.edu
+COMMENT= A PoCo-IRC plugin for a Hailo conversation simulator
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-IRC-Utils>=0.05:${PORTSDIR}/irc/p5-IRC-Utils \
+ p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-POE-Component-Hailo>=0:${PORTSDIR}/devel/p5-POE-Component-Hailo \
+ p5-POE-Component-IRC>=6.22:${PORTSDIR}/irc/p5-POE-Component-IRC
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-Test-Script>=1.07:${PORTSDIR}/devel/p5-Test-Script
+
+PERL_CONFIGURE= yes
+
+MAN1= irchailo-seed.1
+
+MAN3= POE::Component::IRC::Plugin::Hailo.3
+
+.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Plugin-Hailo/distinfo b/irc/p5-POE-Component-IRC-Plugin-Hailo/distinfo
new file mode 100644
index 000000000000..06ca777b332e
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-Hailo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (POE-Component-IRC-Plugin-Hailo-0.16.tar.gz) = be021c7aa728f3889c367ea62e2f2ebeb2005f618ef009e9d2f77a22ae4e7214
+SIZE (POE-Component-IRC-Plugin-Hailo-0.16.tar.gz) = 16122
diff --git a/irc/p5-POE-Component-IRC-Plugin-Hailo/pkg-descr b/irc/p5-POE-Component-IRC-Plugin-Hailo/pkg-descr
new file mode 100644
index 000000000000..691cc169b320
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-Hailo/pkg-descr
@@ -0,0 +1,3 @@
+A PoCo-IRC plugin which provides access to a Hailo conversation simulator.
+
+WWW: http://search.cpan.org/dist/POE-Component-IRC-Plugin-Hailo/
diff --git a/irc/p5-POE-Component-IRC-Plugin-Hailo/pkg-plist b/irc/p5-POE-Component-IRC-Plugin-Hailo/pkg-plist
new file mode 100644
index 000000000000..7c60eafc5a3e
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-Hailo/pkg-plist
@@ -0,0 +1,12 @@
+bin/irchailo-seed
+%%SITE_PERL%%/POE/Component/IRC/Plugin/Hailo.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/Hailo/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/Hailo
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Component/IRC/Plugin
+@dirrmtry %%SITE_PERL%%/POE/Component/IRC
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE