aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-11-30 11:53:33 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-11-30 11:53:33 +0000
commit07a9459ade3f683cd269b7fb8e5d03ac007d43d6 (patch)
tree085f8473ac896f972baa7540c342f154cd050d45 /irc
parent16f108514d34ad4e1a6530199ed498efb19838d9 (diff)
downloadports-07a9459ade3f683cd269b7fb8e5d03ac007d43d6.tar.gz
ports-07a9459ade3f683cd269b7fb8e5d03ac007d43d6.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/epic4/Makefile32
-rw-r--r--irc/epic4/distinfo6
-rw-r--r--irc/epic4/pkg-plist2
3 files changed, 32 insertions, 8 deletions
diff --git a/irc/epic4/Makefile b/irc/epic4/Makefile
index 3435a018fe3f..df6cf1e9c024 100644
--- a/irc/epic4/Makefile
+++ b/irc/epic4/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= epic4
-PORTVERSION= 2.4
+PORTVERSION= 2.6
PORTREVISION= 1
CATEGORIES= irc ipv6
MASTER_SITES= ftp://ftp.prbh.org/pub/epic/EPIC4-PRODUCTION/ \
ftp://ftp.irc.org/irc/clients/unix/epic/EPIC4-PRODUCTION/ \
ftp://ftp.parodius.com/pub/epic/EPIC4-PRODUCTION/ \
http://ftp.freenet.de/pub/ftp.prbh.org/pub/epic/EPIC4-PRODUCTION/ \
- ftp://ftp.eu.uu.net/pub/unix/irc/epic/EPIC4-PRODUCTION/ \
- ftp://totem.fix.no/pub/mirrors/epic/EPIC4-PRODUCTION/
+ ftp://ftp.eu.uu.net/pub/unix/irc/epic/EPIC4-PRODUCTION/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${PORTNAME}-help-20050315.tar.gz
@@ -29,7 +28,10 @@ USE_OPENSSL= yes
OPTIONS= IPV6 "IPv6 support" on \
TCL "TCL support" on \
- PERL "Perl scripting support" off
+ PERL "Perl scripting support" off \
+ SOCKS5 "Enable SOCKS5 proxy support" off \
+ SSL "Enable SSL support" off \
+ TERMCAP "Refuse to use terminfo/ncurses" off
.include <bsd.port.pre.mk>
@@ -61,6 +63,28 @@ USE_PERL5= yes
CONFIGURE_ARGS+= --with-perl=${SITE_PERL}/../../${PERL_VER}/mach/CORE
.endif
+## WITH_SOCKS5: enable SOCKS5 support
+#
+.if defined(WITH_SOCKS5)
+.if exists(${LOCALBASE}/lib/libdsocks.so)
+BROKEN= Optional socks5 support will only build against net/socks5 which conflicts with net/dante
+.endif
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
+CONFIGURE_ARGS+= --with-socks5=${LOCALBASE}/include
+.endif
+
+## WITH_SSL enable SSL support
+#
+.if defined(WITH_SSL)
+CONFIGURE_ARGS+= --with-ssl
+.endif
+
+## WITH_TERMCAP forceably refuse to use terminfo/ncurses
+#
+.if defined(WITH_TERMCAP)
+CONFIGURE_ARGS+= --with-termcap
+.endif
+
post-extract:
@${FIND} ${WRKDIR} -type d -name CVS | ${XARGS} ${RM} -rf
diff --git a/irc/epic4/distinfo b/irc/epic4/distinfo
index 3686e00f2fc0..c053c91b3e23 100644
--- a/irc/epic4/distinfo
+++ b/irc/epic4/distinfo
@@ -1,6 +1,6 @@
-MD5 (epic4-2.4.tar.gz) = a26d50d3db4c7faa4b82b966ad4f4f25
-SHA256 (epic4-2.4.tar.gz) = 4d32e4555086bc1f28fe5f796d1652592f29a615f30a22977b438bc639b4df34
-SIZE (epic4-2.4.tar.gz) = 767678
+MD5 (epic4-2.6.tar.gz) = 3af76d22762b5015735bc9cb7f43d2c9
+SHA256 (epic4-2.6.tar.gz) = cabc3779b86afae7ddb1875c2cb641f3f1f825ee008315fd2735644d863af58c
+SIZE (epic4-2.6.tar.gz) = 769591
MD5 (epic4-help-20050315.tar.gz) = 9888d1af465ca72bf9a02487264071a5
SHA256 (epic4-help-20050315.tar.gz) = 714afd07348731e6ac82e1f6548acc12e84539b3106ab27fa5d00ed5696256f7
SIZE (epic4-help-20050315.tar.gz) = 332502
diff --git a/irc/epic4/pkg-plist b/irc/epic4/pkg-plist
index c39f5da80bf3..4abf7bd3e05a 100644
--- a/irc/epic4/pkg-plist
+++ b/irc/epic4/pkg-plist
@@ -1,5 +1,5 @@
bin/epic
-bin/epic-EPIC4-2.4
+bin/epic-EPIC4-2.6
libexec/wserv4
share/epic/help/1_General/1_General
share/epic/help/1_General/away