aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-13 05:13:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-13 05:13:04 +0000
commit8316e2eebad1ea037282cbd3af935bb82459f0b1 (patch)
treec520ff0ffdf873ba4804630b5ed0ab2407bed73b /irc
parente09f785ef79a1f96333493f68ce85a66d330b096 (diff)
Convert to new options framework
Notes
Notes: svn path=/head/; revision=299169
Diffstat (limited to 'irc')
-rw-r--r--irc/bobot++/Makefile18
-rw-r--r--irc/evangeline/Makefile17
-rw-r--r--irc/minbif/Makefile23
-rw-r--r--irc/srvx/Makefile15
4 files changed, 39 insertions, 34 deletions
diff --git a/irc/bobot++/Makefile b/irc/bobot++/Makefile
index 9bf6dcea42b3..8e3ddcff93b8 100644
--- a/irc/bobot++/Makefile
+++ b/irc/bobot++/Makefile
@@ -17,7 +17,9 @@ COMMENT= An IRC bot written in C++
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-OPTIONS= GUILE "Use Guile scripts" on
+OPTIONS_DEFINE= GUILE
+OPTIONS_DEFAULT= GUILE
+GUILE_DESC= Use Guile scripts
GNU_CONFIGURE= yes
@@ -29,11 +31,9 @@ PLIST_FILES= bin/${PORTNAME}
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_GUILE)
-CONFIGURE_ARGS+= --disable-scripting
-.else
+.if ${PORT_OPTIONS:MGUILE}
LIB_DEPENDS+= guile.21:${PORTSDIR}/lang/guile
CONFIGURE_ARGS+= --enable-scripting
PLIST_FILES+= share/guile/site/bobotpp/bot.scm \
@@ -42,6 +42,8 @@ PLIST_DIRS+= %%DATADIR%%/scripts \
%%DATADIR%% \
share/guile/site/bobotpp
PLIST_DIRSTRY+= share/guile/site
+.else
+CONFIGURE_ARGS+= --disable-scripting
.endif
post-patch:
@@ -49,13 +51,13 @@ post-patch:
@${REINPLACE_CMD} -e 's|std::snprintf|snprintf|g' ${WRKSRC}/source/Bot.C
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@(cd ${WRKSRC}/documentation && ${INSTALL_DATA} *.html ${DOCSDIR})
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/evangeline/Makefile b/irc/evangeline/Makefile
index 6a7e54d6e7b6..4e7dcc8ebe7a 100644
--- a/irc/evangeline/Makefile
+++ b/irc/evangeline/Makefile
@@ -22,23 +22,24 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
IS_INTERACTIVE= yes
-OPTIONS= IPV6 "Enable IPv6 support" off \
- CRYPT "Enable Encryption" on
+OPTIONS_DEFINe= IPV6 CRYPT
+OPTIONS_DEFAULT= CRYPT
+CRYPT_DESC= Enable Encryption
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
.endif
-.if defined(WITHOUT_CRYPT)
-CONFIGURE_ARGS+= --disable-crypt
-.else
+.if ${PORT_OPTIONS:MCRYPT}
CONFIGURE_ARGS+= --enable-crypt
+.else
+CONFIGURE_ARGS+= --disable-crypt
.endif
PLIST_FILES= bin/evangeline
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/minbif/Makefile b/irc/minbif/Makefile
index bb47cac35b16..6f5a1998f9e7 100644
--- a/irc/minbif/Makefile
+++ b/irc/minbif/Makefile
@@ -34,23 +34,24 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
PORTDOCS= *
# right now WITH_PLUGINS installs prpl-coincoin and prpl-gayattitude
-OPTIONS= CACA "Buddy icon display using libcaca" On \
- GNUTLS "Compile with GnuTLS support" Off \
- VIDEO "Webcam display using libcaca (depends on CACA)" Off \
- PLUGINS "Compile additional libpurple-plugins" Off
+OPTIONS_DEFINE= CACA GNUTLS VIDEO PLUGINS DOCS
+OPTIONS_DEFAULT= CACA
+CACA_DESC= Buddy icon display using libcaca
+VIDEO_DESC= Webcam display using libcaca (depends on CACA)
+PLUGINS_DESC= Compile additional libpurple-plugins
SUB_LIST+= USERS=${USERS}
.include <bsd.port.options.mk>
-.if defined(WITH_CACA)
+.if ${PORT_OPTIONS:MCACA}
LIB_DEPENDS+= caca.0:${PORTSDIR}/graphics/libcaca
CMAKE_ARGS+= -DENABLE_CACA:BOOL=ON
.else
CMAKE_ARGS+= -DENABLE_CACA:BOOL=OFF
.endif
-.if defined(WITH_VIDEO) && defined(WITH_CACA)
+.if ${PORT_OPTIONS:MVIDEO} && !empty(PORT_OPTIONS:MCACA)
USE_GSTREAMER+= core good
LIB_DEPENDS+= gstfarsight-0.10.0:${PORTSDIR}/net-im/farsight2
CMAKE_ARGS+= -DENABLE_VIDEO:BOOL=ON
@@ -58,12 +59,12 @@ CMAKE_ARGS+= -DENABLE_VIDEO:BOOL=ON
CMAKE_ARGS+= -DENABLE_VIDEO:BOOL=OFF
.endif
-.if defined(WITH_VIDEO) && !defined(WITH_CACA)
+.if ${PORT_OPTIONS:MVIDEO} && empty(PORT_OPTIONS:MCACA)
IGNORE= if you want to enable webcam support, you must \
also enable CACA.
.endif
-.if defined(WITH_PLUGINS)
+.if ${PORT_OPTIONS:MPLUGINS}
CMAKE_ARGS+= -DENABLE_PLUGIN:BOOL=ON
PLIST_FILES+= lib/purple-2/libcoincoin.so \
lib/purple-2/libgayattitude.so
@@ -71,7 +72,7 @@ PLIST_FILES+= lib/purple-2/libcoincoin.so \
CMAKE_ARGS+= -DENABLE_PLUGIN:BOOL=OFF
.endif
-.if defined(WITH_GNUTLS)
+.if ${PORT_OPTIONS:MGNUTLS}
LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
CMAKE_ARGS+= -DENABLE_GNUTLS:BOOL=ON
.endif
@@ -82,11 +83,11 @@ do-install:
${MKDIR} ${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/minbif.conf ${ETCDIR}/minbif.conf-dist
${INSTALL_DATA} ${WRKSRC}/minbif.motd ${ETCDIR}/minbif.motd-dist
-.if defined(WITH_PLUGINS)
+.if ${PORT_OPTIONS:MPLUGINS}
${INSTALL_PROGRAM} ${WRKSRC}/plugins/coincoin/libcoincoin.so ${PREFIX}/lib/purple-2
${INSTALL_PROGRAM} ${WRKSRC}/plugins/gayattitude/libgayattitude.so ${PREFIX}/lib/purple-2
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/COPYING ${DOCSDIR}
diff --git a/irc/srvx/Makefile b/irc/srvx/Makefile
index 2af995a39777..a095f61caa22 100644
--- a/irc/srvx/Makefile
+++ b/irc/srvx/Makefile
@@ -13,8 +13,9 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A set of services for ircu P10 protocol networks
-OPTIONS= PROTOCOL_BAHAMUT "Enables Bahamut protocol (P10 is default)" "on" \
- DEBUG "Enables debug mode" "off"
+OPTIONS_DEFINE= PROTOCOL_BAHAMUT DEBUG
+OPTIONS_DEFAULT= PROTOCOL_BAHAMUT
+PROTOCOL_BAHAMUT_DESC= Enables Bahamut protocol (P10 is default)
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-getopt
@@ -35,13 +36,13 @@ PLIST_FILES= bin/srvx \
etc/srvx.conf.example \
etc/sockcheck.conf.example
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug
.endif
-.if defined(WITH_PROTOCOL_BAHAMUT)
+.if ${PORT_OPTIONS:MPROTOCOL_BAHAMUT}
CONFIGURE_ARGS+= --with-protocol=bahamut
.endif
@@ -52,10 +53,10 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/srvx ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/*.conf.example ${PREFIX}/etc
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/src/*.help ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>