aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-04-17 00:18:05 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-04-17 00:18:05 +0000
commit877b8a533b44bb6324ebbaf65cd80a60d1572003 (patch)
treee1a018208ceade04ca56a70c5184978cac51853e /irc
parentd12f14432cc492205cefb505a3c1320dd0f4e31a (diff)
downloadports-877b8a533b44bb6324ebbaf65cd80a60d1572003.tar.gz
ports-877b8a533b44bb6324ebbaf65cd80a60d1572003.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/bitchx/Makefile10
-rw-r--r--irc/irssi-devel/Makefile8
-rw-r--r--irc/irssi/Makefile8
-rw-r--r--irc/xchat-devel/Makefile12
-rw-r--r--irc/xchat-gnome/Makefile12
-rw-r--r--irc/xchat/Makefile12
-rw-r--r--irc/xchat1/Makefile12
-rw-r--r--irc/xchat2/Makefile12
8 files changed, 43 insertions, 43 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 4a9645bffd4d..c8a59be60dea 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= ftp://ftp.bitchx.com/pub/BitchX/source/ \
MAINTAINER= calle.madestrand@norrgarden.se
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
LIB_DEPENDS= gnome.3:${PORTSDIR}/x11/gnomelibs
.endif
@@ -22,7 +22,7 @@ GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
WRKSRC= ${WRKDIR}/BitchX
USE_AUTOCONF= yes
USE_GMAKE= yes
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
CONFIGURE_ARGS+= --with-plugins --with-gtk --enable-sound
.else
CONFIGURE_ARGS+= --with-plugins --without-gtk
@@ -39,9 +39,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAKE_ENV+= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
INSTALL_DATA="${INSTALL_DATA}"
-.if !defined(USE_GNOME)
+.if !defined(WITH_GNOME)
pre-extract:
- @${ECHO} "You can add hooks for GNOME by defining USE_GNOME"
+ @${ECHO} "You can add hooks for GNOME by defining WITH_GNOME"
.endif
pre-patch:
@@ -54,7 +54,7 @@ post-install:
${CP} -r ${WRKSRC}/bitchx-docs/* ${PREFIX}/share/bx/help
${INSTALL_DATA} ${WRKSRC}/doc/bxfaq.html ${PREFIX}/share/doc/bitchx
.endif
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
@${ECHO} bin/gtkBitchX >> ${TMPPLIST}
@${ECHO} bin/gtkBitchX-1.0c16 >> ${TMPPLIST}
@${ECHO} share/bx/plugins/nicklist.so >> ${TMPPLIST}
diff --git a/irc/irssi-devel/Makefile b/irc/irssi-devel/Makefile
index 35f65033cffa..c97d23fef184 100644
--- a/irc/irssi-devel/Makefile
+++ b/irc/irssi-devel/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= jim@FreeBSD.org
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
PropList.2:${PORTSDIR}/devel/libPropList
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
LIB_DEPENDS+= gnome.3:${PORTSDIR}/x11/gnomelibs
.endif
@@ -33,7 +33,7 @@ CONFIGURE_ARGS= --without-pthreads --without-socks --with-textui \
--with-proplist=${LOCALBASE} --without-servertest \
--disable-nls
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
PLIST= ${PKGDIR}/PLIST.gnome
.endif
@@ -45,9 +45,9 @@ CONFIGURE_ARGS+= --enable-ipv6
CONFIGURE_ARGS+= --disable-ipv6
.endif
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
CONFIGURE_ARGS+= --with-gnome
-.if defined(USE_PANEL)
+.if defined(WITH_PANEL)
CONFIGURE_ARGS+= --with-gnome-panel
.else
CONFIGURE_ARGS+= --without-gnome-panel
diff --git a/irc/irssi/Makefile b/irc/irssi/Makefile
index 35f65033cffa..c97d23fef184 100644
--- a/irc/irssi/Makefile
+++ b/irc/irssi/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= jim@FreeBSD.org
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
PropList.2:${PORTSDIR}/devel/libPropList
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
LIB_DEPENDS+= gnome.3:${PORTSDIR}/x11/gnomelibs
.endif
@@ -33,7 +33,7 @@ CONFIGURE_ARGS= --without-pthreads --without-socks --with-textui \
--with-proplist=${LOCALBASE} --without-servertest \
--disable-nls
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
PLIST= ${PKGDIR}/PLIST.gnome
.endif
@@ -45,9 +45,9 @@ CONFIGURE_ARGS+= --enable-ipv6
CONFIGURE_ARGS+= --disable-ipv6
.endif
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
CONFIGURE_ARGS+= --with-gnome
-.if defined(USE_PANEL)
+.if defined(WITH_PANEL)
CONFIGURE_ARGS+= --with-gnome-panel
.else
CONFIGURE_ARGS+= --without-gnome-panel
diff --git a/irc/xchat-devel/Makefile b/irc/xchat-devel/Makefile
index 056c5cd088be..394689d3a8c2 100644
--- a/irc/xchat-devel/Makefile
+++ b/irc/xchat-devel/Makefile
@@ -13,12 +13,12 @@ MASTER_SITES= http://xchat.org/files/source/1.4/ \
MAINTAINER= jim@FreeBSD.org
-.if defined(USE_SOCKS)
+.if defined(WITH_SOCKS)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
.endif
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
Imlib.5:${PORTSDIR}/graphics/imlib
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
LIB_DEPENDS+= gnome.3:${PORTSDIR}/x11/gnomelibs
.endif
@@ -32,13 +32,13 @@ USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls --disable-python
-.if defined(USE_SOCKS)
+.if defined(WITH_SOCKS)
CONFIGURE_ARGS+= --enable-socks
.endif
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
CONFIGURE_ARGS+= --enable-gnome
-.if defined(USE_PANEL)
+.if defined(WITH_PANEL)
CONFIGURE_ARGS+= --enable-panel
.else
CONFIGURE_ARGS+= --disable-panel
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+= --disable-gnome
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
GLIB_CONFIG="${GLIB_CONFIG}"
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
PLIST= ${PKGDIR}/PLIST.gnome
.endif
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 056c5cd088be..394689d3a8c2 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -13,12 +13,12 @@ MASTER_SITES= http://xchat.org/files/source/1.4/ \
MAINTAINER= jim@FreeBSD.org
-.if defined(USE_SOCKS)
+.if defined(WITH_SOCKS)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
.endif
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
Imlib.5:${PORTSDIR}/graphics/imlib
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
LIB_DEPENDS+= gnome.3:${PORTSDIR}/x11/gnomelibs
.endif
@@ -32,13 +32,13 @@ USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls --disable-python
-.if defined(USE_SOCKS)
+.if defined(WITH_SOCKS)
CONFIGURE_ARGS+= --enable-socks
.endif
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
CONFIGURE_ARGS+= --enable-gnome
-.if defined(USE_PANEL)
+.if defined(WITH_PANEL)
CONFIGURE_ARGS+= --enable-panel
.else
CONFIGURE_ARGS+= --disable-panel
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+= --disable-gnome
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
GLIB_CONFIG="${GLIB_CONFIG}"
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
PLIST= ${PKGDIR}/PLIST.gnome
.endif
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 056c5cd088be..394689d3a8c2 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -13,12 +13,12 @@ MASTER_SITES= http://xchat.org/files/source/1.4/ \
MAINTAINER= jim@FreeBSD.org
-.if defined(USE_SOCKS)
+.if defined(WITH_SOCKS)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
.endif
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
Imlib.5:${PORTSDIR}/graphics/imlib
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
LIB_DEPENDS+= gnome.3:${PORTSDIR}/x11/gnomelibs
.endif
@@ -32,13 +32,13 @@ USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls --disable-python
-.if defined(USE_SOCKS)
+.if defined(WITH_SOCKS)
CONFIGURE_ARGS+= --enable-socks
.endif
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
CONFIGURE_ARGS+= --enable-gnome
-.if defined(USE_PANEL)
+.if defined(WITH_PANEL)
CONFIGURE_ARGS+= --enable-panel
.else
CONFIGURE_ARGS+= --disable-panel
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+= --disable-gnome
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
GLIB_CONFIG="${GLIB_CONFIG}"
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
PLIST= ${PKGDIR}/PLIST.gnome
.endif
diff --git a/irc/xchat1/Makefile b/irc/xchat1/Makefile
index 056c5cd088be..394689d3a8c2 100644
--- a/irc/xchat1/Makefile
+++ b/irc/xchat1/Makefile
@@ -13,12 +13,12 @@ MASTER_SITES= http://xchat.org/files/source/1.4/ \
MAINTAINER= jim@FreeBSD.org
-.if defined(USE_SOCKS)
+.if defined(WITH_SOCKS)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
.endif
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
Imlib.5:${PORTSDIR}/graphics/imlib
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
LIB_DEPENDS+= gnome.3:${PORTSDIR}/x11/gnomelibs
.endif
@@ -32,13 +32,13 @@ USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls --disable-python
-.if defined(USE_SOCKS)
+.if defined(WITH_SOCKS)
CONFIGURE_ARGS+= --enable-socks
.endif
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
CONFIGURE_ARGS+= --enable-gnome
-.if defined(USE_PANEL)
+.if defined(WITH_PANEL)
CONFIGURE_ARGS+= --enable-panel
.else
CONFIGURE_ARGS+= --disable-panel
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+= --disable-gnome
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
GLIB_CONFIG="${GLIB_CONFIG}"
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
PLIST= ${PKGDIR}/PLIST.gnome
.endif
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index 056c5cd088be..394689d3a8c2 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -13,12 +13,12 @@ MASTER_SITES= http://xchat.org/files/source/1.4/ \
MAINTAINER= jim@FreeBSD.org
-.if defined(USE_SOCKS)
+.if defined(WITH_SOCKS)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
.endif
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
Imlib.5:${PORTSDIR}/graphics/imlib
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
LIB_DEPENDS+= gnome.3:${PORTSDIR}/x11/gnomelibs
.endif
@@ -32,13 +32,13 @@ USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls --disable-python
-.if defined(USE_SOCKS)
+.if defined(WITH_SOCKS)
CONFIGURE_ARGS+= --enable-socks
.endif
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
CONFIGURE_ARGS+= --enable-gnome
-.if defined(USE_PANEL)
+.if defined(WITH_PANEL)
CONFIGURE_ARGS+= --enable-panel
.else
CONFIGURE_ARGS+= --disable-panel
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+= --disable-gnome
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
GLIB_CONFIG="${GLIB_CONFIG}"
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
PLIST= ${PKGDIR}/PLIST.gnome
.endif