aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-10-11 22:39:05 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-10-11 22:39:05 +0000
commitbea5a5e1a59e0c535df4a4e2a17ef88820ba823a (patch)
treed1f3bcfa49f94ae23a22010e9e4568a0dfce47c0 /irc
parent578991f4254a1d0a7e8654eb3768f9c8d752d91f (diff)
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/conspire/Makefile16
-rw-r--r--irc/conspire/distinfo6
-rw-r--r--irc/conspire/pkg-descr2
-rw-r--r--irc/conspire/pkg-plist22
4 files changed, 30 insertions, 16 deletions
diff --git a/irc/conspire/Makefile b/irc/conspire/Makefile
index dd5a2acaeda7..6e3c9ce599a9 100644
--- a/irc/conspire/Makefile
+++ b/irc/conspire/Makefile
@@ -5,11 +5,10 @@
# $FreeBSD$
PORTNAME= conspire
-PORTVERSION= 0.20
-PORTREVISION= 2
-CATEGORIES= irc gnome
+PORTVERSION= 1.0.0
+CATEGORIES= irc gnome ipv6
MASTER_SITES= http://distfiles.atheme.org/
-EXTRACT_SUFX= .tbz2
+EXTRACT_SUFX= .tgz
MAINTAINER= jacob@whotookspaz.org
COMMENT= A high quality IRC client which uses a multitude of interfaces
@@ -19,13 +18,13 @@ LIB_DEPENDS= sexy.2:${PORTSDIR}/x11-toolkits/libsexy \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
notify.1:${PORTSDIR}/devel/libnotify
-USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
USE_GNOME= gnomehack gtk20
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GETTEXT= yes
+MAKE_JOBS_SAFE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -37,10 +36,13 @@ OPTIONS= IPV6 "Enable IPv6 support" off \
PLUGIN "Enable plugin support" on \
REGEX "Enable regex substitution support" on \
GNUTLS "Enale gnutls support" on \
- SOCKS "Build with socks5 support" off
+ SOCKS "Build with socks5 support (broken)" off
.include <bsd.port.pre.mk>
+# Unconditionally disable python, since it doesn't work anyway.
+CONFIGURE_ARGS+=--disable-python
+
.if defined(WITH_IPV6)
CONFIGURE_ARGS+=--enable-ipv6
.endif
@@ -58,6 +60,8 @@ LIB_DEPENDS+= gnutls.40:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+=--enable-gnutls
.endif
+# XXX - causes linker errors... not sure how to fix or if it's even possible
+# to do so...
.if defined(WITH_SOCKS)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+=--enable-socks
diff --git a/irc/conspire/distinfo b/irc/conspire/distinfo
index 4d0a89a870bb..2745de06f5c8 100644
--- a/irc/conspire/distinfo
+++ b/irc/conspire/distinfo
@@ -1,3 +1,3 @@
-MD5 (conspire-0.20.tbz2) = f070e841564495bfc83ad8e20bf65cda
-SHA256 (conspire-0.20.tbz2) = 8029f3ce87c6392e4305ae49a826832e14342b224a315f8020d9804eb30f2065
-SIZE (conspire-0.20.tbz2) = 1150730
+MD5 (conspire-1.0.0.tgz) = 876c62c0314d55bee9fd7bb24e4c4398
+SHA256 (conspire-1.0.0.tgz) = fa4ab59d6c651ea2ce03ef6c33811aff7713ea59e339306d8044d63e2e44a746
+SIZE (conspire-1.0.0.tgz) = 1747742
diff --git a/irc/conspire/pkg-descr b/irc/conspire/pkg-descr
index fcf7c1e6fcff..246b48cb4c11 100644
--- a/irc/conspire/pkg-descr
+++ b/irc/conspire/pkg-descr
@@ -5,4 +5,4 @@ common code. Conspire started as a fork of XChat 2.9 CVS.
Scripting is not yet officially supported, but is being worked on.
-WWW: http://nenolod.net/conspire
+WWW: http://confluence.atheme.org/display/CON/Home
diff --git a/irc/conspire/pkg-plist b/irc/conspire/pkg-plist
index 9be014653df5..25dcd620bc6c 100644
--- a/irc/conspire/pkg-plist
+++ b/irc/conspire/pkg-plist
@@ -4,12 +4,15 @@ include/conspire/base64.h
include/conspire/cap.h
include/conspire/cfgfiles.h
include/conspire/command_factory.h
+include/conspire/command_option.h
+include/conspire/conspire-config.h
include/conspire/ctcp.h
include/conspire/dcc.h
include/conspire/debug.h
include/conspire/fe.h
+include/conspire/format.h
include/conspire/history.h
-include/conspire/ignore.h
+include/conspire/ignore-ng.h
include/conspire/inbound.h
include/conspire/inet.h
include/conspire/linequeue.h
@@ -22,12 +25,12 @@ include/conspire/proto-irc.h
include/conspire/sasl.h
include/conspire/server.h
include/conspire/servlist.h
+include/conspire/session.h
include/conspire/signal_factory.h
include/conspire/signal_printer.h
+include/conspire/stdinc.h
include/conspire/text.h
-include/conspire/textenums.h
include/conspire/textevents.h
-include/conspire/timer.h
include/conspire/tree.h
include/conspire/upnp.h
include/conspire/url.h
@@ -36,21 +39,28 @@ include/conspire/util.h
include/conspire/xchat.h
include/conspire/xchatc.h
lib/conspire/plugins/autoaway.so
+lib/conspire/plugins/country.so
+lib/conspire/plugins/exec.so
lib/conspire/plugins/helloworld.so
lib/conspire/plugins/highlight-notify.so
-lib/libconspire.so
-lib/libconspire.so.0
-lib/libconspire.so.0.1.0
+lib/conspire/plugins/identify-msg.so
+lib/conspire/plugins/presence.so
+lib/conspire/plugins/timer.so
+lib/libconspire.a
libdata/pkgconfig/conspire.pc
share/applications/conspire.desktop
%%DATADIR%%/pixmaps/balloon.png
%%DATADIR%%/pixmaps/book.png
+%%DATADIR%%/pixmaps/channel.png
%%DATADIR%%/pixmaps/conspire.png
+%%DATADIR%%/pixmaps/dialog.png
%%DATADIR%%/pixmaps/fileoffer.png
%%DATADIR%%/pixmaps/hop.png
%%DATADIR%%/pixmaps/op.png
%%DATADIR%%/pixmaps/purple.png
%%DATADIR%%/pixmaps/red.png
+%%DATADIR%%/pixmaps/server.png
+%%DATADIR%%/pixmaps/util.png
%%DATADIR%%/pixmaps/voice.png
share/locale/be/LC_MESSAGES/conspire.mo
share/locale/ca/LC_MESSAGES/conspire.mo