aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2015-12-21 15:41:30 +0000
committerMark Felder <feld@FreeBSD.org>2015-12-21 15:41:30 +0000
commitd573147bc97d065d6056811ea29d5fca9065d2fe (patch)
tree420866c5b568a648f6b008f96bade3035d511124 /irc
parent896a330f0e1260fb7d99304d4cde40ac8bf70bf4 (diff)
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/quassel/Makefile1
-rw-r--r--irc/quassel/files/patch-src_core_coreuserinputhandler.cpp12
2 files changed, 13 insertions, 0 deletions
diff --git a/irc/quassel/Makefile b/irc/quassel/Makefile
index c6975e6d91fb..921750302eaf 100644
--- a/irc/quassel/Makefile
+++ b/irc/quassel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= quassel
PORTVERSION= 0.12.2
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://www.quassel-irc.org/pub/
diff --git a/irc/quassel/files/patch-src_core_coreuserinputhandler.cpp b/irc/quassel/files/patch-src_core_coreuserinputhandler.cpp
new file mode 100644
index 000000000000..c3cff156f59c
--- /dev/null
+++ b/irc/quassel/files/patch-src_core_coreuserinputhandler.cpp
@@ -0,0 +1,12 @@
+Fix CVE-2015-8547
+--- src/core/coreuserinputhandler.cpp.orig 2015-04-23 20:47:17 UTC
++++ src/core/coreuserinputhandler.cpp
+@@ -228,7 +228,7 @@ void CoreUserInputHandler::doMode(const
+ if (!isNumber || maxModes == 0) maxModes = 1;
+
+ QStringList nickList;
+- if (nicks == "*") { // All users in channel
++ if (nicks == "*" && bufferInfo.type() == BufferInfo::ChannelBuffer) { // All users in channel
+ const QList<IrcUser*> users = network()->ircChannel(bufferInfo.bufferName())->ircUsers();
+ foreach(IrcUser *user, users) {
+ if ((addOrRemove == '+' && !network()->ircChannel(bufferInfo.bufferName())->userModes(user).contains(mode))