aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorJase Thew <jase@FreeBSD.org>2012-08-15 15:22:04 +0000
committerJase Thew <jase@FreeBSD.org>2012-08-15 15:22:04 +0000
commit059de5052449ba84a6b96f39f7da4d2a23f6fe43 (patch)
treeda929d88e6667e9cdb60741e8a85b4a14131a3a2 /irc
parent8270937d87b25a02032b7fb9bb93485638b30553 (diff)
downloadports-059de5052449ba84a6b96f39f7da4d2a23f6fe43.tar.gz
ports-059de5052449ba84a6b96f39f7da4d2a23f6fe43.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/weechat-devel/Makefile32
-rw-r--r--irc/weechat-devel/distinfo4
-rw-r--r--irc/weechat-devel/files/patch-cmake-FindPython_cmake10
-rw-r--r--irc/weechat-devel/pkg-plist1
4 files changed, 33 insertions, 14 deletions
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
index 1b21c4261e8f..9da79c7a2a39 100644
--- a/irc/weechat-devel/Makefile
+++ b/irc/weechat-devel/Makefile
@@ -6,9 +6,11 @@
#
PORTNAME= weechat
-PORTVERSION= 20120707
+PORTVERSION= 20120808
CATEGORIES= irc
-MASTER_SITES= http://perturb.me.uk/distfiles/
+MASTER_SITES= http://perturb.me.uk/distfiles/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= jase
PKGNAMESUFFIX= -devel
DISTNAME= weechat-devel-${GITREV}
@@ -22,22 +24,20 @@ CONFLICTS= weechat-0.3*
USE_ICONV= yes
USE_LDCONFIG= yes
USE_NCURSES= yes
-WITH_NCURSES_PORT= yes
USE_CMAKE= yes
-CMAKE_ARGS+= -DNCURSES_INCLUDE_PATH=${LOCALBASE}/include/ncurses
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
WANT_PERL= yes
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
-GITREV= 92aa9bf
+GITREV= 3c615a9
WRKSRC= ${WRKDIR}/${PORTNAME}-${GITREV}
# Please note: the DEBUG option is *NOT* empty, it is utilised by
# bsd.cmake.mk to set the cmake build type to Debug instead of
# Release.
-OPTIONS_DEFINE= RUBY PYTHON PERL TCL LUA GUILE CHARSET BACKTRACE DEBUG ASPELL GNUTLS NLS DOCUMENTATION SASL
+OPTIONS_DEFINE= RUBY PYTHON PERL TCL LUA GUILE CHARSET BACKTRACE DEBUG ASPELL GNUTLS NLS DOCUMENTATION SASL COLOR256
OPTIONS_DEFAULT=CHARSET BACKTRACE DEBUG
BACKTRACE_DESC= Provide crash backtraces
@@ -49,6 +49,8 @@ PERL_DESC= Perl scripting support
PYTHON_DESC= Python scripting support
RUBY_DESC= Ruby scripting support
TCL_DESC= Tcl scripting support
+SASL_DESC= SASL with DH-Blowfish support
+COLOR256_DESC= Use ncurses port for 256 color support
.include <bsd.port.options.mk>
@@ -157,10 +159,15 @@ LIB_DEPENDS+= execinfo:${PORTSDIR}/devel/libexecinfo
LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
PLIST_SUB+= SASL=""
.else
-CMAKE_ARGS+= -DENABLE_SASL=no
+CMAKE_ARGS+= -DENABLE_GCRYPT=no
PLIST_SUB+= SASL="@comment "
.endif
+.if ${PORT_OPTIONS:MCOLOR256}
+WITH_NCURSES_PORT= yes
+CMAKE_ARGS+= -DNCURSES_INCLUDE_PATH=${LOCALBASE}/include/ncurses
+.endif
+
MAN1= weechat-curses.1
post-patch:
@@ -173,6 +180,17 @@ post-patch:
@${REINPLACE_CMD} -e '/IF.*FreeBSD/,/ENDIF.*FreeBSD/d' ${WRKSRC}/src/core/CMakeLists.txt
.endif
+pre-configure:
+.if ${PORT_OPTIONS:MCOLOR256}
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "==> You have selected the ncurses 256 color option. Please ensure that"
+ @${ECHO_MSG} "==> the devel/ncurses port is built with the EXTCOLORS option enabled."
+ @${ECHO_MSG} "==>"
+ @${ECHO_MSG} "==> Ctrl-C now if you'd like to reconfigure."
+ @${ECHO_MSG} ""
+ @sleep 5
+.endif
+
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/weechat-curses.1 ${MAN1PREFIX}/man/man1
diff --git a/irc/weechat-devel/distinfo b/irc/weechat-devel/distinfo
index 29d132cba9f8..1184649b306c 100644
--- a/irc/weechat-devel/distinfo
+++ b/irc/weechat-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (weechat-devel-92aa9bf.tar.gz) = accf76561ea0192c968d3094ad6ebdf35d1e72caeb9b374ccd1529b13ca18adf
-SIZE (weechat-devel-92aa9bf.tar.gz) = 2229030
+SHA256 (weechat-devel-3c615a9.tar.gz) = f0ef85a540e887819d58649008d68ae42f10b20d57a61138a2a37a0d8d4b0095
+SIZE (weechat-devel-3c615a9.tar.gz) = 2340064
diff --git a/irc/weechat-devel/files/patch-cmake-FindPython_cmake b/irc/weechat-devel/files/patch-cmake-FindPython_cmake
index bf80f23b1fe0..4e5f60e2a6a3 100644
--- a/irc/weechat-devel/files/patch-cmake-FindPython_cmake
+++ b/irc/weechat-devel/files/patch-cmake-FindPython_cmake
@@ -1,10 +1,10 @@
---- cmake/FindPython.cmake.orig 2010-12-20 18:43:34.102131358 +0000
-+++ cmake/FindPython.cmake 2010-12-20 19:16:11.918184057 +0000
+--- cmake/FindPython.cmake.orig 2012-08-11 14:06:55.086663842 +0100
++++ cmake/FindPython.cmake 2012-08-11 14:23:55.301504695 +0100
@@ -34,8 +34,7 @@
ENDIF(PYTHON_FOUND)
FIND_PROGRAM(PYTHON_EXECUTABLE
-- NAMES python python2.7 python2.6 python2.5 python2.4 python2.3 python2.2
+- NAMES python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python
- PATHS /usr/bin /usr/local/bin /usr/pkg/bin
+ NAMES ${BSD_PYTHON_CMD}
)
@@ -12,9 +12,9 @@
IF(PYTHON_EXECUTABLE)
@@ -65,7 +64,7 @@
)
-
+
FIND_LIBRARY(PYTHON_LIBRARY
-- NAMES python python2.7 python2.6 python2.5 python2.4 python2.3 python2.2
+- NAMES python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python
+ NAMES ${BSD_PYTHON_VER}
PATHS ${PYTHON_POSSIBLE_LIB_PATH}
)
diff --git a/irc/weechat-devel/pkg-plist b/irc/weechat-devel/pkg-plist
index 7ddb1a07c816..b43562288e28 100644
--- a/irc/weechat-devel/pkg-plist
+++ b/irc/weechat-devel/pkg-plist
@@ -48,6 +48,7 @@ libdata/pkgconfig/weechat.pc
%%DOCUMENTATION%%share/doc/weechat/weechat_user.en.html
%%DOCUMENTATION%%share/doc/weechat/weechat_user.fr.html
%%DOCUMENTATION%%share/doc/weechat/weechat_user.it.html
+%%DOCUMENTATION%%share/doc/weechat/weechat_user.ja.html
%%NLS%%share/locale/cs/LC_MESSAGES/weechat.mo
%%NLS%%share/locale/de/LC_MESSAGES/weechat.mo
%%NLS%%share/locale/es/LC_MESSAGES/weechat.mo