aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-02-09 11:56:30 +0000
committerClement Laforet <clement@FreeBSD.org>2004-02-09 11:56:30 +0000
commit698702546ffbd823d7e13ba77cd7ba53bec5536f (patch)
treeb4687019faa7a0903db87f57f3d02d1b69ebd3b3 /irc
parent35a3256787b35a3ac84c57a93e64ee49f066dfc8 (diff)
downloadports-698702546ffbd823d7e13ba77cd7ba53bec5536f.tar.gz
ports-698702546ffbd823d7e13ba77cd7ba53bec5536f.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/weechat-devel/Makefile31
-rw-r--r--irc/weechat-devel/distinfo2
-rw-r--r--irc/weechat-devel/files/patch-configure10
-rw-r--r--irc/weechat-devel/pkg-descr6
-rw-r--r--irc/weechat/Makefile31
-rw-r--r--irc/weechat/distinfo2
-rw-r--r--irc/weechat/files/patch-configure10
-rw-r--r--irc/weechat/pkg-descr6
9 files changed, 99 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 5a5c8f296fae..6bf87f4393e7 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -78,6 +78,7 @@
SUBDIR += tkirc
SUBDIR += tr-ircd
SUBDIR += trickyirc
+ SUBDIR += weechat
SUBDIR += xaric
SUBDIR += xchat
SUBDIR += xchat-systray-plugin
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
new file mode 100644
index 000000000000..af5688e4f26c
--- /dev/null
+++ b/irc/weechat-devel/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: weechat
+# Date created: 2003-03-07
+# Whom: clement
+#
+# $FreeBSD$
+#
+
+PORTNAME= weechat
+PORTVERSION= 0.0.5
+CATEGORIES= irc
+MASTER_SITES= http://weechat.flashtux.org/download/
+
+MAINTAINER= clement@FreeBSD.org
+COMMENT= A lightweight and user friendly ncurse based IRC client
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GETTEXT= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
+
+MAN1= weechat.1
+
+PLIST_FILES= bin/weechat-curses share/locale/fr/LC_MESSAGES/weechat.mo
+
+post-patch:
+ @${CP} ${LOCALBASE}/share/gettext/config.rpath ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/irc/weechat-devel/distinfo b/irc/weechat-devel/distinfo
new file mode 100644
index 000000000000..aea76ca8a41c
--- /dev/null
+++ b/irc/weechat-devel/distinfo
@@ -0,0 +1,2 @@
+MD5 (weechat-0.0.5.tar.bz2) = 8847dde68bc2fdc4fe93e4d0e04d9dba
+SIZE (weechat-0.0.5.tar.bz2) = 274819
diff --git a/irc/weechat-devel/files/patch-configure b/irc/weechat-devel/files/patch-configure
new file mode 100644
index 000000000000..d990c6dd48ec
--- /dev/null
+++ b/irc/weechat-devel/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sat Feb 7 23:48:23 2004
++++ configure Sat Feb 7 23:48:35 2004
+@@ -8510,7 +8510,6 @@
+
+ fi
+
+-CFLAGS="-Wall -W -pipe -O2"
+
+ ac_config_files="$ac_config_files Makefile src/Makefile src/common/Makefile src/irc/Makefile src/plugins/Makefile src/plugins/perl/Makefile src/gui/Makefile src/gui/curses/Makefile src/gui/gtk/Makefile src/gui/qt/Makefile intl/Makefile po/Makefile.in"
+ cat >confcache <<\_ACEOF
diff --git a/irc/weechat-devel/pkg-descr b/irc/weechat-devel/pkg-descr
new file mode 100644
index 000000000000..c8adcef1b1e7
--- /dev/null
+++ b/irc/weechat-devel/pkg-descr
@@ -0,0 +1,6 @@
+WeeChat (Wee Enhanced Environment for Chat) is a fast and light IRC
+client. Everything can be done with a keyboard, and it is customizable
+and extensible with scripts. For the moment, only ncurse GUI is
+supported by this port.
+
+WWW: http://weechat.flashtux.org
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
new file mode 100644
index 000000000000..af5688e4f26c
--- /dev/null
+++ b/irc/weechat/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: weechat
+# Date created: 2003-03-07
+# Whom: clement
+#
+# $FreeBSD$
+#
+
+PORTNAME= weechat
+PORTVERSION= 0.0.5
+CATEGORIES= irc
+MASTER_SITES= http://weechat.flashtux.org/download/
+
+MAINTAINER= clement@FreeBSD.org
+COMMENT= A lightweight and user friendly ncurse based IRC client
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GETTEXT= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
+
+MAN1= weechat.1
+
+PLIST_FILES= bin/weechat-curses share/locale/fr/LC_MESSAGES/weechat.mo
+
+post-patch:
+ @${CP} ${LOCALBASE}/share/gettext/config.rpath ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/irc/weechat/distinfo b/irc/weechat/distinfo
new file mode 100644
index 000000000000..aea76ca8a41c
--- /dev/null
+++ b/irc/weechat/distinfo
@@ -0,0 +1,2 @@
+MD5 (weechat-0.0.5.tar.bz2) = 8847dde68bc2fdc4fe93e4d0e04d9dba
+SIZE (weechat-0.0.5.tar.bz2) = 274819
diff --git a/irc/weechat/files/patch-configure b/irc/weechat/files/patch-configure
new file mode 100644
index 000000000000..d990c6dd48ec
--- /dev/null
+++ b/irc/weechat/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sat Feb 7 23:48:23 2004
++++ configure Sat Feb 7 23:48:35 2004
+@@ -8510,7 +8510,6 @@
+
+ fi
+
+-CFLAGS="-Wall -W -pipe -O2"
+
+ ac_config_files="$ac_config_files Makefile src/Makefile src/common/Makefile src/irc/Makefile src/plugins/Makefile src/plugins/perl/Makefile src/gui/Makefile src/gui/curses/Makefile src/gui/gtk/Makefile src/gui/qt/Makefile intl/Makefile po/Makefile.in"
+ cat >confcache <<\_ACEOF
diff --git a/irc/weechat/pkg-descr b/irc/weechat/pkg-descr
new file mode 100644
index 000000000000..c8adcef1b1e7
--- /dev/null
+++ b/irc/weechat/pkg-descr
@@ -0,0 +1,6 @@
+WeeChat (Wee Enhanced Environment for Chat) is a fast and light IRC
+client. Everything can be done with a keyboard, and it is customizable
+and extensible with scripts. For the moment, only ncurse GUI is
+supported by this port.
+
+WWW: http://weechat.flashtux.org