aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorTorsten Blum <torstenb@FreeBSD.org>1995-02-11 01:45:04 +0000
committerTorsten Blum <torstenb@FreeBSD.org>1995-02-11 01:45:04 +0000
commit6998b221039bcbbd39fc75f2941270b994d20dbd (patch)
treeab373cab12a0f92c83415f3b59640379b3094956 /irc
parente13d1ecf0b26aa3cab6d56f15d42d4a383c0d96d (diff)
downloadports-6998b221039bcbbd39fc75f2941270b994d20dbd.tar.gz
ports-6998b221039bcbbd39fc75f2941270b994d20dbd.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/irc/Makefile24
-rw-r--r--irc/irc/distinfo2
-rw-r--r--irc/irc/files/patch-ab152
-rw-r--r--irc/irc/pkg-comment2
-rw-r--r--irc/irc/pkg-plist2
5 files changed, 132 insertions, 50 deletions
diff --git a/irc/irc/Makefile b/irc/irc/Makefile
index ccf948bd0961..db25de08058a 100644
--- a/irc/irc/Makefile
+++ b/irc/irc/Makefile
@@ -3,28 +3,16 @@
# Date created: 23 August 1994
# Whom: torstenb
#
-# $Id: Makefile,v 1.1.1.1 1994/08/27 12:17:09 torstenb Exp $
+# $Id: Makefile,v 1.2 1994/09/13 06:34:53 jkh Exp $
#
-.if !defined(prefix)
-prefix= /usr/local
-.endif
-
-DISTNAME= irc2.8.20
+DISTNAME= irc2.8.21
MASTER_SITES= ftp://cs-ftp.bu.edu/irc/servers/
pre-install:
- @if [ ! -d $(prefix)/bin ]; then \
- mkdir -p $(prefix)/bin; \
- fi
- @if [ ! -d $(prefix)/lib/ircd ]; then \
- mkdir -p $(prefix)/lib/ircd; \
- fi
- @if [ ! -d $(prefix)/man/man1 ]; then \
- mkdir -p $(prefix)/man/man1; \
- fi
- @if [ ! -d $(prefix)/man/man8 ]; then \
- mkdir -p $(prefix)/man/man8; \
- fi
+ mkdir -p ${PREFIX}/bin
+ mkdir -p ${PREFIX}/lib/ircd
+ mkdir -p ${PREFIX}/man/man1
+ mkdir -p ${PREFIX}/man/man8
.include <bsd.port.mk>
diff --git a/irc/irc/distinfo b/irc/irc/distinfo
index ae9642669cc3..e225526bf1a1 100644
--- a/irc/irc/distinfo
+++ b/irc/irc/distinfo
@@ -1 +1 @@
-MD5 (irc2.8.20.tar.gz) = 3c57f48bdc1e1e88c3b9460c8f1e344d
+MD5 (irc2.8.21.tar.gz) = f0697bc2f7b10eb46e1e06bc5344c4b3
diff --git a/irc/irc/files/patch-ab b/irc/irc/files/patch-ab
index d9fb676d3233..873d072b69d1 100644
--- a/irc/irc/files/patch-ab
+++ b/irc/irc/files/patch-ab
@@ -1,29 +1,125 @@
-*** /dev/null Tue Aug 23 17:16:08 1994
---- ./include/setup.h Tue Aug 23 17:42:49 1994
+*** include/config.h.orig Tue Jan 31 19:46:22 1995
+--- include/config.h Tue Jan 31 19:53:55 1995
***************
-*** 0 ****
---- 1,24 ----
-+ #ifndef __setup_include__
-+ #define __setup_include__
-+ #define PARAMH
-+ #define UNISTDH
-+ #define STRINGH
-+ #define STRINGSH
-+ #define STDLIBH
-+ #define STDDEFH
-+ #define SYSSYSLOGH
-+ #undef NOINDEX
-+ #undef NEED_STRERROR
-+ #define NEED_STRTOKEN
-+ #undef NEED_STRTOK
-+ #undef NEED_INET_ADDR
-+ #undef NEED_INET_NTOA
-+ #undef NEED_INET_NETOF
-+ #define GETTIMEOFDAY
-+ #undef LRAND48
-+ #undef MALLOCH
-+ #define NBLOCK_POSIX
-+ #define BSD_RELIABLE_SIGNALS
-+ #undef TIMES_2
-+ #define GETRUSAGE_2
-+ #endif
+*** 61,67 ****
+ * If your host supports varargs and has vsprintf(), vprintf() and vscanf()
+ * C calls in its library, then you can define USE_VARARGS to use varargs
+ * instead of imitation variable arg passing.
+! #undef USE_VARARGS
+ * NOTE: with current server code, varargs doesn't survive because it can't
+ * be used in a chain of 3 or more funtions which all have a variable
+ * number of params. If anyone has a solution to this, please notify
+--- 61,67 ----
+ * If your host supports varargs and has vsprintf(), vprintf() and vscanf()
+ * C calls in its library, then you can define USE_VARARGS to use varargs
+ * instead of imitation variable arg passing.
+! #define USE_VARARGS
+ * NOTE: with current server code, varargs doesn't survive because it can't
+ * be used in a chain of 3 or more funtions which all have a variable
+ * number of params. If anyone has a solution to this, please notify
+***************
+*** 90,96 ****
+ * then remove it before starting the server.
+ * The file is for request save/backup.
+ */
+! #define NPATH "/usr/lib/irc/.ircdnote"
+ #endif
+
+ /*
+--- 90,96 ----
+ * then remove it before starting the server.
+ * The file is for request save/backup.
+ */
+! #define NPATH "!!PREFIX!!/lib/ircd/.ircdnote"
+ #endif
+
+ /*
+***************
+*** 98,105 ****
+ * these are only the recommened names and paths. Change as needed.
+ * You must define these to something, even if you don't really want them.
+ */
+! #define DPATH "/scratch/avalon/ircd" /* dir where all ircd stuff is */
+! #define SPATH "/scratch/avalon/ircd/bin/ircd"
+ #define CPATH "ircd.conf" /* server configuration file */
+ #define MPATH "ircd.motd" /* server MOTD file */
+ #define LPATH "/tmp/ircd.log" /* Where the debug file lives, if DEBUGMODE */
+--- 98,105 ----
+ * these are only the recommened names and paths. Change as needed.
+ * You must define these to something, even if you don't really want them.
+ */
+! #define DPATH "!!PREFIX!!/lib/ircd" /* dir where all ircd stuff is */
+! #define SPATH "!!PREFIX!!/bin/ircd"
+ #define CPATH "ircd.conf" /* server configuration file */
+ #define MPATH "ircd.motd" /* server MOTD file */
+ #define LPATH "/tmp/ircd.log" /* Where the debug file lives, if DEBUGMODE */
+***************
+*** 112,119 ****
+ * FNAME_USERLOG just logs user connections, FNAME_OPERLOG logs every
+ * successful use of /oper. These are either full paths or files within DPATH.
+ */
+! #define FNAME_USERLOG "/usr/local/lib/ircd/users" /* */
+! #define FNAME_OPERLOG "/usr/local/lib/ircd/opers" /* */
+
+ /* CHROOTDIR
+ *
+--- 112,119 ----
+ * FNAME_USERLOG just logs user connections, FNAME_OPERLOG logs every
+ * successful use of /oper. These are either full paths or files within DPATH.
+ */
+! #define FNAME_USERLOG "!!PREFIX!!/lib/ircd/users" /* */
+! #define FNAME_OPERLOG "!!PREFIX!!/lib/ircd/opers" /* */
+
+ /* CHROOTDIR
+ *
+***************
+*** 150,156 ****
+ * mode "i" (i == invisible). Invisibility means people dont showup in
+ * WHO or NAMES unless they are on the same channel as you.
+ */
+! #undef NO_DEFAULT_INVISIBLE
+
+ /* OPER_KILL
+ *
+--- 150,156 ----
+ * mode "i" (i == invisible). Invisibility means people dont showup in
+ * WHO or NAMES unless they are on the same channel as you.
+ */
+! #define NO_DEFAULT_INVISIBLE
+
+ /* OPER_KILL
+ *
+***************
+*** 211,217 ****
+ * to a leaf which just has 1 server (typically the uplink). Define this
+ * correctly for performance reasons.
+ */
+! #define HUB
+
+ /* R_LINES: The conf file now allows the existence of R lines, or
+ * restrict lines. These allow more freedom in the ability to restrict
+--- 211,217 ----
+ * to a leaf which just has 1 server (typically the uplink). Define this
+ * correctly for performance reasons.
+ */
+! #undef HUB
+
+ /* R_LINES: The conf file now allows the existence of R lines, or
+ * restrict lines. These allow more freedom in the ability to restrict
+***************
+*** 252,258 ****
+ * The server will then call m4 each time it reads the ircd.conf file,
+ * reading m4 output as the server's ircd.conf file.
+ */
+! #define M4_PREPROC
+
+ /*
+ * If you wish to have the server send 'vital' messages about server
+--- 252,258 ----
+ * The server will then call m4 each time it reads the ircd.conf file,
+ * reading m4 output as the server's ircd.conf file.
+ */
+! #undef M4_PREPROC
+
+ /*
+ * If you wish to have the server send 'vital' messages about server
diff --git a/irc/irc/pkg-comment b/irc/irc/pkg-comment
index f389e8def574..2e7f3177e165 100644
--- a/irc/irc/pkg-comment
+++ b/irc/irc/pkg-comment
@@ -1 +1 @@
-ircd, the 'Internet Relay Chat' Server. Version 2.8.20
+ircd, the 'Internet Relay Chat' Server. Version 2.8.21
diff --git a/irc/irc/pkg-plist b/irc/irc/pkg-plist
index 9579dc3f8fd0..9b9142c06161 100644
--- a/irc/irc/pkg-plist
+++ b/irc/irc/pkg-plist
@@ -1,9 +1,7 @@
@cwd /usr/local
bin/chkconf
-bin/irc
bin/ircd
lib/ircd/example.conf
lib/ircd/ircd.m4
lib/ircd/ircd.motd
-man/man1/irc.1
man/man8/ircd.8