aboutsummaryrefslogtreecommitdiff
path: root/japanese/chasen/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2000-03-21 03:56:20 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2000-03-21 03:56:20 +0000
commitc4e5bad58f37a4eb417fa4bf660e3b829e629dc2 (patch)
tree4d5072842e431d3af700bb5a072f5b330577669c /japanese/chasen/Makefile
parente8c733f4d0d9510f243940d2b5c243d571beede7 (diff)
downloadports-c4e5bad58f37a4eb417fa4bf660e3b829e629dc2.tar.gz
ports-c4e5bad58f37a4eb417fa4bf660e3b829e629dc2.zip
Notes
Diffstat (limited to 'japanese/chasen/Makefile')
-rw-r--r--japanese/chasen/Makefile26
1 files changed, 20 insertions, 6 deletions
diff --git a/japanese/chasen/Makefile b/japanese/chasen/Makefile
index 3c33169c54db..307b7baa0c7f 100644
--- a/japanese/chasen/Makefile
+++ b/japanese/chasen/Makefile
@@ -1,5 +1,5 @@
# New ports collection makefile for: chasen
-# Version required: 2.0 + 2.0
+# Version required: 2.02 + 2.1
# Date created: 21 October 1998
# Whom: kuriyama
#
@@ -7,18 +7,32 @@
# $FreeBSD$
#
-DISTNAME= chasen-sys2.0-ipadic2.0
-PKGNAME= ja-chasen-2.0
+DISTNAME= chasen-sys2.02-ipadic2.1
+PKGNAME= ja-chasen-2.02
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.aist-nara.ac.jp/pub/lab/nlp/tools/chasen/ \
http://cactus.aist-nara.ac.jp/~akira-k/cha/arc/
MAINTAINER= kuriyama@FreeBSD.org
-WRKSRC= ${WRKDIR}/chasen-2.0
+USE_PERL5= YES
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Text::ChaSen.3
+
+WRKSRC= ${WRKDIR}/chasen-2.02
+
+do-configure:
post-build:
- ${ECHO_MSG} "Making dictionaries"
- (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} dic)
+ @${ECHO_MSG} "Making dictionaries"
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} dic
+ @${ECHO_MSG} "Making perl5 module"
+ @cd ${WRKSRC}/perl; \
+ ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL; \
+ ${SETENV} ${MAKE_ENV} ${MAKE}
+
+post-install:
+ @cd ${WRKSRC}/perl; ${SETENV} ${MAKE_ENV} ${MAKE} install
.include <bsd.port.mk>