aboutsummaryrefslogtreecommitdiff
path: root/japanese/eblook/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-09-28 19:16:18 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-09-28 19:16:18 +0000
commit07109bd822ea481200d764bf36e04e25dd8eee29 (patch)
tree5df158b4f3991c2918d4a1419401d0ee8e70f646 /japanese/eblook/Makefile
parentf87c7f1461e521ed98b9302facaf71e353de120f (diff)
Notes
Diffstat (limited to 'japanese/eblook/Makefile')
-rw-r--r--japanese/eblook/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/japanese/eblook/Makefile b/japanese/eblook/Makefile
index 743b86ec408b..118e037a5b66 100644
--- a/japanese/eblook/Makefile
+++ b/japanese/eblook/Makefile
@@ -13,25 +13,24 @@ COMMENT= Command to lookup words in EB format dictionaries
LICENSE= GPLv2
-LIB_DEPENDS= eb:${PORTSDIR}/japanese/eb
+LIB_DEPENDS= libeb.so:${PORTSDIR}/japanese/eb
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-eb-includes=${PREFIX}/include \
--with-eb-libraries=${PREFIX}/lib
INFO= eblook
+PLIST_FILES= bin/eblook
+PORTDOCS= AUTHORS COPYING ChangeLog NEWS README
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- for i in AUTHORS COPYING ChangeLog NEWS README ; do \
- ${INSTALL_DATA} ${WRKSRC}/$${i} ${DOCSDIR} ;\
- done
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>