aboutsummaryrefslogtreecommitdiff
path: root/japanese/ebview
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-02 17:45:30 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-02 17:45:30 +0000
commitb61dae0657086b0dabe97c7406502fcd1503f97e (patch)
tree99453332db59a59fcab5190f71a4382515803112 /japanese/ebview
parent47616dfcd364bacab48029969c3abf1f32f8ded8 (diff)
downloadports-b61dae0657086b0dabe97c7406502fcd1503f97e.tar.gz
ports-b61dae0657086b0dabe97c7406502fcd1503f97e.zip
Notes
Diffstat (limited to 'japanese/ebview')
-rw-r--r--japanese/ebview/Makefile17
-rw-r--r--japanese/ebview/distinfo2
-rw-r--r--japanese/ebview/files/patch-configure.in13
-rw-r--r--japanese/ebview/files/patch-src::Makefile.am19
-rw-r--r--japanese/ebview/files/patch-src::eb.c10
-rw-r--r--japanese/ebview/files/patch-src::ebview-client.c13
-rw-r--r--japanese/ebview/files/patch-util::Makefile.am15
-rw-r--r--japanese/ebview/pkg-plist16
8 files changed, 96 insertions, 9 deletions
diff --git a/japanese/ebview/Makefile b/japanese/ebview/Makefile
index f7f85b561bfa..f04ec5dcc8b8 100644
--- a/japanese/ebview/Makefile
+++ b/japanese/ebview/Makefile
@@ -6,25 +6,28 @@
#
PORTNAME= ebview
-PORTVERSION= 0.1.4
+PORTVERSION= 0.2.0
CATEGORIES= japanese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= eb.6:${PORTSDIR}/japanese/eb
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ eb.6:${PORTSDIR}/japanese/eb
USE_GNOMENG= yes
USE_GNOME= imlib
+USE_REINPLACE= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-MAKE_ARGS= SUBDIRS=src
-CONFIGURE_ARGS= --disable-imlibtest
+USE_AUTOMAKE_VER= 14
+USE_AUTOCONF_VER= 253
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}"
post-install:
- ${MKDIR} ${PREFIX}/share/locale/ja/LC_MESSAGES
- ${INSTALL_DATA} ${WRKSRC}/po/ja.gmo ${PREFIX}/share/locale/ja/LC_MESSAGES/ebview.mo
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for i in ChangeLog README
diff --git a/japanese/ebview/distinfo b/japanese/ebview/distinfo
index e13c9a70f30d..ec88753c4f66 100644
--- a/japanese/ebview/distinfo
+++ b/japanese/ebview/distinfo
@@ -1 +1 @@
-MD5 (ebview-0.1.4.tar.gz) = d95ceca15303c1142c043849eff3efbe
+MD5 (ebview-0.2.0.tar.gz) = 265a37aef3e165f36f7bcae223395274
diff --git a/japanese/ebview/files/patch-configure.in b/japanese/ebview/files/patch-configure.in
new file mode 100644
index 000000000000..a874e9d6d5a1
--- /dev/null
+++ b/japanese/ebview/files/patch-configure.in
@@ -0,0 +1,13 @@
+--- configure.in.orig Tue Nov 19 15:04:30 2002
++++ configure.in Sat Nov 30 09:27:26 2002
+@@ -14,8 +14,8 @@
+ AM_GNU_GETTEXT
+
+ dnl Checks for libraries.
+-AM_PATH_GTK(1.2.8)
+-AM_PATH_IMLIB()
++AM_PATH_GTK(1.2.8,, AC_MSG_ERROR(Cannot find GTK+ 1.2.8), gmodule gthread)
++AM_PATH_GDK_IMLIB()
+ eb_LIB_EB3
+
+ dnl Checks for header files.
diff --git a/japanese/ebview/files/patch-src::Makefile.am b/japanese/ebview/files/patch-src::Makefile.am
new file mode 100644
index 000000000000..241686151746
--- /dev/null
+++ b/japanese/ebview/files/patch-src::Makefile.am
@@ -0,0 +1,19 @@
+--- src/Makefile.am.orig Sat Nov 16 15:33:46 2002
++++ src/Makefile.am Sat Nov 30 09:38:43 2002
+@@ -2,12 +2,12 @@
+
+ AM_CPPFLAGS= @EBCONF_PTHREAD_CPPFLAGS@ @EBCONF_EBINCS@ \
+ @EBCONF_ZLIBINCS@ @EBCONF_INTLINCS@
+-AM_CFLAGS = @GTK_CFLAGS@ @IMLIB_CFLAGS@ @EBCONF_PTHREAD_CFLAGS@
+-AM_CXXFLAGS = @GTK_CFLAGS@ @IMLIB_CFLAGS@ @EBCONF_PTHREAD_CFLAGS@
+-ebview_LDADD = @GTK_LIBS@ @IMLIB_LIBS@ -lgdk_imlib -lpthread -lgthread \
++AM_CFLAGS = @GTK_CFLAGS@ @GDK_IMLIB_CFLAGS@ @EBCONF_PTHREAD_CFLAGS@
++AM_CXXFLAGS = @GTK_CFLAGS@ @GDK_IMLIB_CFLAGS@ @EBCONF_PTHREAD_CFLAGS@
++ebview_LDADD = @GTK_LIBS@ @GDK_IMLIB_LIBS@ \
+ @EBCONF_EBLIBS@ @EBCONF_ZLIBLIBS@ @EBCONF_INTLLIBS@
+ ebview_LDFLAGS = @EBCONF_PTHREAD_LDFLAGS@
+-ebview_client_LDADD = @GTK_LIBS@ @IMLIB_LIBS@ -lgdk_imlib -lpthread \
++ebview_client_LDADD = @GTK_LIBS@ @GDK_IMLIB_LIBS@ \
+ @EBCONF_EBLIBS@ @EBCONF_ZLIBLIBS@ @EBCONF_INTLLIBS@
+ ebview_client_LDFLAGS = @EBCONF_PTHREAD_LDFLAGS@
+
diff --git a/japanese/ebview/files/patch-src::eb.c b/japanese/ebview/files/patch-src::eb.c
new file mode 100644
index 000000000000..c1a9ee211e07
--- /dev/null
+++ b/japanese/ebview/files/patch-src::eb.c
@@ -0,0 +1,10 @@
+--- src/eb.c.orig Mon Nov 18 18:13:06 2002
++++ src/eb.c Sat Nov 30 09:04:05 2002
+@@ -24,6 +24,7 @@
+ #include <iconv.h>
+ #include <langinfo.h>
+ #include <wchar.h>
++#include <pthread.h>
+
+
+ #define MAX_HITS 50
diff --git a/japanese/ebview/files/patch-src::ebview-client.c b/japanese/ebview/files/patch-src::ebview-client.c
new file mode 100644
index 000000000000..d898c12f3e02
--- /dev/null
+++ b/japanese/ebview/files/patch-src::ebview-client.c
@@ -0,0 +1,13 @@
+--- src/ebview-client.c.orig Sat Nov 16 15:33:47 2002
++++ src/ebview-client.c Sat Nov 30 09:49:47 2002
+@@ -1,8 +1,8 @@
+ #include <stdio.h>
+-#include <sys/socket.h>
++#include <unistd.h>
+ #include <sys/un.h>
+ #include <sys/types.h>
+-#include <unistd.h>
++#include <sys/socket.h>
+
+ #include "../config.h"
+
diff --git a/japanese/ebview/files/patch-util::Makefile.am b/japanese/ebview/files/patch-util::Makefile.am
new file mode 100644
index 000000000000..3a673bbe54f7
--- /dev/null
+++ b/japanese/ebview/files/patch-util::Makefile.am
@@ -0,0 +1,15 @@
+--- util/Makefile.am.orig Sat Nov 16 15:33:50 2002
++++ util/Makefile.am Sat Nov 30 09:52:44 2002
+@@ -2,9 +2,9 @@
+
+ AM_CPPFLAGS= @EBCONF_PTHREAD_CPPFLAGS@ @EBCONF_EBINCS@ \
+ @EBCONF_ZLIBINCS@ @EBCONF_INTLINCS@
+-AM_CFLAGS = @GTK_CFLAGS@ @IMLIB_CFLAGS@ @EBCONF_PTHREAD_CFLAGS@
+-AM_CXXFLAGS = @GTK_CFLAGS@ @IMLIB_CFLAGS@ @EBCONF_PTHREAD_CFLAGS@
+-ebdump_LDADD = @GTK_LIBS@ @IMLIB_LIBS@\
++AM_CFLAGS = @GTK_CFLAGS@ @GDK_IMLIB_CFLAGS@ @EBCONF_PTHREAD_CFLAGS@
++AM_CXXFLAGS = @GTK_CFLAGS@ @GDK_IMLIB_CFLAGS@ @EBCONF_PTHREAD_CFLAGS@
++ebdump_LDADD = @GTK_LIBS@ @GDK_IMLIB_LIBS@\
+ @EBCONF_EBLIBS@ @EBCONF_ZLIBLIBS@ @EBCONF_INTLLIBS@
+ ebdump_LDFLAGS = @EBCONF_PTHREAD_LDFLAGS@
+
diff --git a/japanese/ebview/pkg-plist b/japanese/ebview/pkg-plist
index 55284a8ff4af..7389faece08b 100644
--- a/japanese/ebview/pkg-plist
+++ b/japanese/ebview/pkg-plist
@@ -1,5 +1,19 @@
+bin/ebdump
bin/ebview
-share/locale/ja/LC_MESSAGES/ebview.mo
+bin/ebview-client
%%PORTDOCS%%share/doc/ebview/ChangeLog
%%PORTDOCS%%share/doc/ebview/README
+share/ebview/about.en
+share/ebview/about.jp
+share/ebview/endinglist-ja.xml
+share/ebview/endinglist.xml
+share/ebview/help/en/index.html
+share/ebview/help/ja/index.html
+share/ebview/searchengines.xml
+share/ebview/shortcut.xml
+share/locale/ja/LC_MESSAGES/ebview.mo
+@dirrm share/ebview/help/ja
+@dirrm share/ebview/help/en
+@dirrm share/ebview/help
+@dirrm share/ebview
%%PORTDOCS%%@dirrm share/doc/ebview