aboutsummaryrefslogtreecommitdiff
path: root/japanese/eijiro-fpw/Makefile
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2000-12-21 06:27:31 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2000-12-21 06:27:31 +0000
commit52d76f653cc7ec645fa88b129f2f85837f48395c (patch)
tree0f2353b83306b69f6cae0ccbd4be6da24341d6bb /japanese/eijiro-fpw/Makefile
parente2d6082a718a775eb79529627e5c0853479f014a (diff)
downloadports-52d76f653cc7ec645fa88b129f2f85837f48395c.tar.gz
ports-52d76f653cc7ec645fa88b129f2f85837f48395c.zip
Notes
Diffstat (limited to 'japanese/eijiro-fpw/Makefile')
-rw-r--r--japanese/eijiro-fpw/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/japanese/eijiro-fpw/Makefile b/japanese/eijiro-fpw/Makefile
new file mode 100644
index 000000000000..ea9c0ed5e3ce
--- /dev/null
+++ b/japanese/eijiro-fpw/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: EIJIRO Dictionary - JIS X 4081 version
+# Date created: 2000.11.28
+# Whom: Satoshi Taoka <taoka@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eijiro-fpw
+PORTVERSION= 1.0b
+CATEGORIES= japanese
+MASTER_SITES= http://openlab.ring.gr.jp/edict/fpw/dist/eijiro/
+DISTNAME= ${PORTNAME}${PORTVERSION}-src
+
+MAINTAINER= taoka@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/share/doc/freepwing/fpwutils.mk:${PORTSDIR}/japanese/freepwing \
+ catdump:${PORTSDIR}/japanese/epwutil \
+ nkf:${PORTSDIR}/japanese/nkf \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+
+RESTRICTED= "The original dictionary is not free"
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/eijiro-fpw${PORTVERSION}
+DICT_PATH?= /cdrom
+SRCFILE?= EIJI37??.TXT
+MAKE_ENV= PORT_SRCFILE=${DICT_PATH}/${SRCFILE}
+
+post-extract:
+ @if [ ! -f ${DICT_PATH}/${SRCFILE} ]; then \
+ ${ECHO} "###################################################"; \
+ ${ECHO} "I cannot find a file ${DICT_PATH}/${SRCFILE}"; \
+ ${ECHO} "Specify the Eijiro Dictionary file with the full path"; \
+ ${ECHO} "and excecute the following command again:"; \
+ ${ECHO} " make DICT_PATH=${DICT_PATH} SRCFILE=${SRCFILE}"; \
+ ${ECHO} ""; \
+ ${ECHO} "Notice: DICT_PATH must be a full path to the file."; \
+ ${ECHO} "###################################################"; \
+ ${FALSE}; \
+ fi
+ ${CP} ${LOCALBASE}/share/doc/freepwing/fpwutils.mk ${WRKSRC}
+
+post-build:
+ cd ${WRKSRC}; nkf -eSd catalogs.sjis > catalogs.txt; \
+ catdump -u catalogs.txt catalogs
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/dict/eijiro-fpw/eijiro/data
+ ${INSTALL_DATA} ${WRKSRC}/honmon ${PREFIX}/share/dict/eijiro-fpw/eijiro/data
+ ${INSTALL_DATA} ${WRKSRC}/catalogs ${PREFIX}/share/dict/eijiro-fpw
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/eijiro-fpw
+.for i in readme.sjis
+ ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/doc/eijiro-fpw
+.endfor
+.endif
+
+.include <bsd.port.mk>