aboutsummaryrefslogtreecommitdiff
path: root/japanese/eijiro-fpw
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-29 21:27:28 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-29 21:27:28 +0000
commit6ccbb3fb9190224c95eb4e51baf2150209f57694 (patch)
tree0ebd00c2cec8ae4c406bcdff32570ce74c87224b /japanese/eijiro-fpw
parentb2fe9762d062565930d37431c3e2f840ddb568da (diff)
downloadports-6ccbb3fb9190224c95eb4e51baf2150209f57694.tar.gz
ports-6ccbb3fb9190224c95eb4e51baf2150209f57694.zip
Notes
Diffstat (limited to 'japanese/eijiro-fpw')
-rw-r--r--japanese/eijiro-fpw/Makefile62
-rw-r--r--japanese/eijiro-fpw/files/patch-Makefile (renamed from japanese/eijiro-fpw/files/patch-aa)16
-rw-r--r--japanese/eijiro-fpw/pkg-plist7
3 files changed, 41 insertions, 44 deletions
diff --git a/japanese/eijiro-fpw/Makefile b/japanese/eijiro-fpw/Makefile
index 0b93044db3f4..595cad645121 100644
--- a/japanese/eijiro-fpw/Makefile
+++ b/japanese/eijiro-fpw/Makefile
@@ -3,7 +3,7 @@
PORTNAME= eijiro-fpw
PORTVERSION= 1.0b
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= japanese
MASTER_SITES= http://openlab.ring.gr.jp/edict/fpw/dist/eijiro/
DISTNAME= ${PORTNAME}${PORTVERSION}-src
@@ -11,39 +11,45 @@ DISTNAME= ${PORTNAME}${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= EIJIRO English - Japanese Dictionary (EPWING V1 format)
-EXTRACT_DEPENDS=${LOCALBASE}/share/freepwing/fpwutils.mk:${PORTSDIR}/japanese/freepwing
+EXTRACT_DEPENDS=${LOCALBASE}/share/freepwing/fpwutils.mk:${PORTSDIR}/japanese/freepwing \
+ lha:${PORTSDIR}/archivers/lha
BUILD_DEPENDS= ${LOCALBASE}/libexec/freepwing/catdump:${PORTSDIR}/japanese/freepwing \
ja-p5-Jcode>=0:${PORTSDIR}/japanese/p5-Jcode
-MANUAL_PACKAGE_BUILD=Needs data from CDROM
+MANUAL_PACKAGE_BUILD= Needs data from CDROM
+MAKE_JOBS_UNSAFE= yes
+
RESTRICTED= The original dictionary is not free
-USES= perl5 gmake
-MAKE_JOBS_UNSAFE=yes
+USES= dos2unix gmake perl5
+DOS2UNIX_FILES= Makefile
WRKSRC= ${WRKDIR}/eijiro-fpw${PORTVERSION}
+PORTDOCS= readme.sjis
DICT_PATH?= /cdrom
SRCFILE?= eijiro52.txt
+PLIST_FILES= share/dict/eijiro-fpw/eijiro/data/honmon \
+ share/dict/eijiro-fpw/catalogs
+PLIST_DIRS= share/dict/eijiro-fpw/eijiro/data \
+ share/dict/eijiro-fpw/eijiro \
+ share/dict/eijiro-fpw
+
# For eijiro included in a book sold by ALC Inc.
# (http://www.alc.co.jp/alcshop/eng/eijiro/)
+# Avoid copying uncompressed srcfile, it is > 50Mb
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-DICT_ARCHIVE!= ${ECHO_CMD} ${DICT_PATH}/eijiro-original/*.exe || ${TRUE}
-.if exists(${DICT_ARCHIVE})
-EXTRACT_DEPENDS+= lha:${PORTSDIR}/archivers/lha
-
-CDROM_PATH:= ${DICT_PATH}
-DICT_PATH:= ${WRKDIR}
+.if exists(${WRKDIR}/${SRCFILE})
+MAKE_ARGS+= SRCFILE=${WRKDIR}/${SRCFILE}
.else
-CDROM_PATH= ${NONEXISTENT}
-.endif
+MAKE_ARGS+= SRCFILE=${DICT_PATH}/${SRCFILE}
+.fi
+
+OPTIONS_DEFINE= DOCS
-MAKE_ARGS:= SRCFILE=${DICT_PATH}/${SRCFILE}
+.include <bsd.port.options.mk>
post-extract:
- @if [ -f ${CDROM_PATH}/eijiro-original/*.exe ]; then \
- lha xiw=${WRKDIR} ${CDROM_PATH}/eijiro-original/*.exe '*/${SRCFILE}'; \
+ @if [ -f ${DICT_PATH}/eijiro-original/*.exe ]; then \
+ lha xiw=${WRKDIR} ${DICT_PATH}/eijiro-original/*.exe '*/${SRCFILE}'; \
elif [ ! -f ${DICT_PATH}/${SRCFILE} ]; then \
${ECHO} "###################################################"; \
${ECHO} "I cannot find a file ${DICT_PATH}/${SRCFILE}"; \
@@ -62,14 +68,12 @@ post-build:
${SETENV} CATDUMPFLAGS="-e sjis" fpwmake catalogs
do-install:
- ${MKDIR} ${PREFIX}/share/dict/eijiro-fpw/eijiro/data
- ${INSTALL_DATA} ${WRKSRC}/honmon ${PREFIX}/share/dict/eijiro-fpw/eijiro/data
- ${INSTALL_DATA} ${WRKSRC}/catalogs ${PREFIX}/share/dict/eijiro-fpw
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in readme.sjis
- ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
-.endfor
-.endif
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/dict/eijiro-fpw/eijiro/data \
+ ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/honmon \
+ ${STAGEDIR}${PREFIX}/share/dict/eijiro-fpw/eijiro/data
+ ${INSTALL_DATA} ${WRKSRC}/catalogs \
+ ${STAGEDIR}${PREFIX}/share/dict/eijiro-fpw
+ ${INSTALL_DATA} ${WRKSRC}/readme.sjis ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/eijiro-fpw/files/patch-aa b/japanese/eijiro-fpw/files/patch-Makefile
index 948fccc9b6cc..72a356aa7941 100644
--- a/japanese/eijiro-fpw/files/patch-aa
+++ b/japanese/eijiro-fpw/files/patch-Makefile
@@ -1,11 +1,11 @@
--- Makefile.orig Sun Oct 8 14:40:55 2000
+++ Makefile Mon Jun 13 11:55:22 2005
@@ -47,7 +47,7 @@
- DIR = eijiro
-
- FPWPARSER = eijiro-fpw.pl
--FPWPARSERFLAGS = -- --charset=${CHARSET} ${SRCFILE}
-+FPWPARSERFLAGS = -c "${CHARSET}" "${SRCFILE}"
-
- # fpwutils.mk must be located in one of the make include directories or
- # you should user -I option.
+ DIR = eijiro
+
+ FPWPARSER = eijiro-fpw.pl
+-FPWPARSERFLAGS = -- --charset=${CHARSET} ${SRCFILE}
++FPWPARSERFLAGS = -c "${CHARSET}" "${SRCFILE}"
+
+ # fpwutils.mk must be located in one of the make include directories or
+ # you should user -I option.
diff --git a/japanese/eijiro-fpw/pkg-plist b/japanese/eijiro-fpw/pkg-plist
deleted file mode 100644
index f065e248e62b..000000000000
--- a/japanese/eijiro-fpw/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-share/dict/eijiro-fpw/eijiro/data/honmon
-share/dict/eijiro-fpw/catalogs
-@dirrm share/dict/eijiro-fpw/eijiro/data
-@dirrm share/dict/eijiro-fpw/eijiro
-@dirrm share/dict/eijiro-fpw
-%%PORTDOCS%%%%DOCSDIR%%/readme.sjis
-%%PORTDOCS%%@dirrm %%DOCSDIR%%