aboutsummaryrefslogtreecommitdiff
path: root/japanese/escpf/Makefile
diff options
context:
space:
mode:
authorBill Fenner <fenner@FreeBSD.org>1997-11-16 09:05:19 +0000
committerBill Fenner <fenner@FreeBSD.org>1997-11-16 09:05:19 +0000
commit6044f964afa75ca16e1c68890205eac2a8a10f2b (patch)
tree8d7b6038ee9840e690a9c8d121d40c07452835db /japanese/escpf/Makefile
parent8d91cdef88c3b4b9baa9decc92688681261de63c (diff)
downloadports-6044f964afa75ca16e1c68890205eac2a8a10f2b.tar.gz
ports-6044f964afa75ca16e1c68890205eac2a8a10f2b.zip
Notes
Diffstat (limited to 'japanese/escpf/Makefile')
-rw-r--r--japanese/escpf/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/japanese/escpf/Makefile b/japanese/escpf/Makefile
index a03c0f26b5c4..c155451b32a0 100644
--- a/japanese/escpf/Makefile
+++ b/japanese/escpf/Makefile
@@ -3,7 +3,7 @@
# Date created: 15 June 1996
# Whom: Mita Yoshio <mita@iis.u-tokyo.ac.jp>
#
-# $Id: Makefile,v 1.1.1.1 1996/12/19 03:33:09 max Exp $
+# $Id: Makefile,v 1.2 1997/09/14 21:34:34 max Exp $
#
DISTNAME= escpf-0.4beta2
@@ -14,10 +14,26 @@ MASTER_SITES= http://www.bekkoame.or.jp/~wing/Linux/Escpf/
MAINTAINER= mita@jp.FreeBSD.org
DOCDIR= ${PREFIX}/share/doc/escpf
+LINES?= 66
+COLUMNS?= 80
+TOP_MERGIN?= 5
+LEFT_MERGIN?= 5
+LARGE_FONT?= -DLARGE_FONT
+MAKE_ENV+= LINES=${LINES} COLUMNS=${COLUMNS} \
+ TOP_MERGIN=${TOP_MERGIN} LEFT_MERGIN=${LEFT_MERGIN} \
+ LARGE_FONT="${LARGE_FONT}"
+# You can specify page layout with:
+# LINES : lines per page
+# COLUMNS : characters per line
+# TOP_MERGIN : top mergin with lines
+# LEFT_MERGIN : left mergin with cahacters
+# LARGE_FONT : if "-DLARGE_FONT" large font, "" small font
post-install:
+.if !defined(NOPORTDOCS)
${MKDIR} ${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/escpf.doc ${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/escpf.euc ${DOCDIR}
+.endif
.include <bsd.port.mk>