aboutsummaryrefslogtreecommitdiff
path: root/japanese/grep/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-07-23 03:55:20 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-07-23 03:55:20 +0000
commit56693cf7fdeda28dabbf7de9e66272581f47a4c4 (patch)
treeb88f35bd8b7e0260dcd1a0888aef8faba75196c1 /japanese/grep/Makefile
parent059928189b088c2e80e9012f1cef37566f72ff3d (diff)
downloadports-56693cf7fdeda28dabbf7de9e66272581f47a4c4.tar.gz
ports-56693cf7fdeda28dabbf7de9e66272581f47a4c4.zip
Notes
Diffstat (limited to 'japanese/grep/Makefile')
-rw-r--r--japanese/grep/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/japanese/grep/Makefile b/japanese/grep/Makefile
index 37e0fb6a2fd2..5cfdde22858b 100644
--- a/japanese/grep/Makefile
+++ b/japanese/grep/Makefile
@@ -6,27 +6,31 @@
#
PORTNAME= grep
-PORTVERSION= 2.0
-PORTREVISION= 1
+PORTVERSION= 2.4.2
CATEGORIES= japanese textproc
MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= grep
+MASTER_SITE_SUBDIR= ${PORTNAME}
-PATCH_SITES= ftp://ftp.hipecs.hokudai.ac.jp/pub/GNU/jp/
-PATCHFILES= ${DISTNAME}-mb1.04.diff.gz
+PATCH_SITES= http://www.hinadori.dyn.to/~wills/program/
+PATCHFILES= grep-2.4.2-mlb2.patch.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
GNU_CONFIGURE= yes
-MAKE_ARGS= binprefix=j
+CONFIGURE_ARGS= --program-prefix=j --disable-nls
MAN1= jgrep.1
+MLINKS= jgrep.1 jegrep.1 \
+ jgrep.1 jfgrep.1
+
+DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/ja/grep
- ${INSTALL_DATA} ${WRKSRC}/README.MB ${PREFIX}/share/doc/ja/grep
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.MB ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.mlb ${DOCSDIR}
.endif
.include <bsd.port.mk>