aboutsummaryrefslogtreecommitdiff
path: root/japanese/guesswork-classic/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-10-11 12:55:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-10-11 12:55:54 +0000
commit4bc95d9771cab2161338fb9703d1d8009ef2e010 (patch)
tree78ed0f25c84f31bfa8d8140f0c6078098e2ba37a /japanese/guesswork-classic/Makefile
parent20a8433d67cdfbb50df719911fd46a4be7a0e164 (diff)
Notes
Diffstat (limited to 'japanese/guesswork-classic/Makefile')
-rw-r--r--japanese/guesswork-classic/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/japanese/guesswork-classic/Makefile b/japanese/guesswork-classic/Makefile
new file mode 100644
index 000000000000..84ce498cc53f
--- /dev/null
+++ b/japanese/guesswork-classic/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: ja-guesswork-classic
+# Date created: 10 Oct 2005
+# Whom: Shinsuke Matsui (<smatsui@karashi.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= guesswork-classic
+PORTVERSION= 0.0.3
+CATEGORIES= japanese devel
+MASTER_SITES= http://classic.guesswork.jp/download/files/
+
+MAINTAINER= smatsui@karashi.org
+COMMENT= A PHP lightweight framework
+
+RUN_DEPENDS= ${LOCALBASE}/share/smarty/Smarty.class.php:${PORTSDIR}/www/smarty
+
+NO_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+SUB_FILES= pkg-message
+
+PORTDOCS= ChangeLog README LICENSE
+
+post-extract:
+ @${FIND} ${WRKSRC} -name '.cvsignore' -delete
+
+do-install:
+ ${MKDIR} ${DATADIR}
+.for DIR in lib test
+ ${CP} -Rp ${WRKSRC}/${DIR} ${DATADIR}
+ ${FIND} ${DATADIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+.endfor
+ ${MKDIR} ${EXAMPLESDIR}
+.for DIR in examples public_html smarty
+ ${CP} -Rp ${WRKSRC}/${DIR} ${EXAMPLESDIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>