aboutsummaryrefslogtreecommitdiff
path: root/japanese/jadetex-ptex/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2004-07-25 14:34:18 +0000
committerHiroki Sato <hrs@FreeBSD.org>2004-07-25 14:34:18 +0000
commitf290c8002aa7cb9156ddc17d690743aaee5e4988 (patch)
treecab7d940f5a6888b3d630c0e5cdfd7686124b2a5 /japanese/jadetex-ptex/Makefile
parenta3475b87d7f1a3ff320154075c43a808d0f359d3 (diff)
downloadports-f290c8002aa7cb9156ddc17d690743aaee5e4988.tar.gz
ports-f290c8002aa7cb9156ddc17d690743aaee5e4988.zip
Notes
Diffstat (limited to 'japanese/jadetex-ptex/Makefile')
-rw-r--r--japanese/jadetex-ptex/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/japanese/jadetex-ptex/Makefile b/japanese/jadetex-ptex/Makefile
index d058e0942f08..4a668eaec963 100644
--- a/japanese/jadetex-ptex/Makefile
+++ b/japanese/jadetex-ptex/Makefile
@@ -7,35 +7,33 @@
PORTNAME= jadetex
PORTVERSION= 3.13
+PORTREVISION= 1
CATEGORIES= japanese print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= jadetex
+MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMESUFFIX= -ptex
DISTNAME= jadetex-${PORTVERSION}
MAINTAINER= hrs@FreeBSD.org
COMMENT= A pTeX backend for Jade, for typesetting SGML documents
-BUILD_DEPENDS= ptex:${PORTSDIR}/japanese/ptex
+BUILD_DEPENDS= ptex:${PORTSDIR}/japanese/ptex-tetex
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
-RUN_DEPENDS= ptex:${PORTSDIR}/japanese/ptex
+RUN_DEPENDS= ptex:${PORTSDIR}/japanese/ptex-tetex
-MESSAGE= ${PKGDIR}/pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+PKGMESSAGE_SUB= LOCALBASE=${LOCALBASE}
pre-patch:
- @${SED} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${MESSAGE} > ${PKGMESSAGE}
+ ${SED} ${PKGMESSAGE_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ < ${PKGDIR}/pkg-message > ${PKGMESSAGE}
-post-install: rebuild-tex-database display-message
+post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}${PKGNAMESUFFIX}
- ${INSTALL_MAN} ${WRKSRC}/README.jadetex-ptex ${DOCSDIR}${PKGNAMESUFFIX}
+ ${INSTALL_MAN} ${WRKSRC}/README.jadetex-ptex ${DOCSDIR}${PKGNAMESUFFIX}/
.endif
-
-rebuild-tex-database:
${LOCALBASE}/bin/mktexlsr
-
-display-message:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>