aboutsummaryrefslogtreecommitdiff
path: root/japanese/jed
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2000-02-08 16:03:55 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2000-02-08 16:03:55 +0000
commitbd6671bf57a83827a2cc006c09b7bc4c22b600b3 (patch)
tree6f44634ed98e2e88e255a03e76af328c818aed77 /japanese/jed
parent0d462002d901b7fdd24d89d3eb1d1cc37a751f9b (diff)
downloadports-bd6671bf57a83827a2cc006c09b7bc4c22b600b3.tar.gz
ports-bd6671bf57a83827a2cc006c09b7bc4c22b600b3.zip
Notes
Diffstat (limited to 'japanese/jed')
-rw-r--r--japanese/jed/Makefile104
-rw-r--r--japanese/jed/distinfo2
-rw-r--r--japanese/jed/files/patch-aa32
-rw-r--r--japanese/jed/files/patch-ab22
-rw-r--r--japanese/jed/files/patch-ac17
-rw-r--r--japanese/jed/files/patch-ad13
-rw-r--r--japanese/jed/files/patch-ae29
-rw-r--r--japanese/jed/files/patch-af15
-rw-r--r--japanese/jed/pkg-comment1
-rw-r--r--japanese/jed/pkg-descr22
-rw-r--r--japanese/jed/pkg-message5
-rw-r--r--japanese/jed/pkg-plist191
12 files changed, 453 insertions, 0 deletions
diff --git a/japanese/jed/Makefile b/japanese/jed/Makefile
new file mode 100644
index 000000000000..64a5f5a29328
--- /dev/null
+++ b/japanese/jed/Makefile
@@ -0,0 +1,104 @@
+# New ports collection makefile for: Jed text editor w/ Japanese support
+# Version required: 0.99.8.j067
+# Date created: 2 Feb 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= jed-B0.99-8__J067
+PKGNAME= ja-jed-0.99.8.j067
+CATEGORIES= japanese editors
+MASTER_SITES= http://knu.and.or.jp/ports/distfiles/ \
+ http://www.idaemons.org/ports/distfiles/ \
+ http://kondara.sdri.co.jp/~kikutani/slang/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ jed-extralibs-0.99.8${EXTRACT_SUFX}
+
+MAINTAINER= knu@idaemons.org
+
+LIB_DEPENDS= slang.2:${PORTSDIR}/japanese/libslang \
+ ${LIBDEP_CANNA}
+
+DIST_SUBDIR= jed
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= JED_ROOT="${JED_ROOT}" X_EXTRA_LIBS="-lxpg4 -lcurses"
+CONFIGURE_ARGS= --enable-x-locale=no --with-canna="${WITH_CANNA}"
+ALL_TARGET= ${BINSTUFF} getmail
+MAN1= jed.1 rgrep.1
+
+JED_ROOT= ${PREFIX}/lib/jed
+BINSTUFF= jed rgrep
+
+.include <bsd.port.pre.mk>
+
+.if defined(NO_CANNA)
+WITH_CANNA= no
+.else
+WITH_CANNA= yes
+LIBDEP_CANNA= canna.1:${PORTSDIR}/japanese/Canna
+.endif
+
+# XJED core dumps on 3.x-STABLE for the present.
+.if ${OSVERSION} < 400000
+XJED_BROKEN= yes
+.endif
+
+.if defined(NO_X11)
+NO_XJED= yes
+.endif
+
+.if defined(NO_XJED)
+PLIST_SUB= XJED_ENTRY="@comment xjed is not installed"
+.else
+USE_XLIB= yes
+BINSTUFF+= xjed
+PLIST_SUB= XJED_ENTRY="bin/xjed"
+.endif
+
+_OBJDIR= ${WRKSRC}/src/${ARCH}objs
+_DOCDIR= ${WRKSRC}/doc
+_INFODIR= ${WRKSRC}/info
+_LIBDIR= ${WRKSRC}/lib
+
+pre-fetch:
+.if !defined(NO_CANNA)
+ @${ECHO_MSG} "To build this port without Canna, define \"NO_CANNA\"."
+.endif
+.if !defined(NO_XJED)
+.if defined(XJED_BROKEN)
+ @${ECHO_MSG} "Sorry, I will not build xjed since it is broken on 3.x-STABLE for the present."
+.else
+ @${ECHO_MSG} "To build this port without xjed, define \"NO_XJED\"."
+.endif
+.endif
+
+post-extract:
+ @cd ${WRKDIR} && ${MV} *.sl ${_LIBDIR}/
+
+do-install:
+ @${MKDIR} ${JED_ROOT}
+.for d in bin doc lib lib/colors lib/tm
+ @${MKDIR} ${JED_ROOT}/${d}
+.endfor
+.for f in ${BINSTUFF}
+ ${INSTALL_PROGRAM} ${_OBJDIR}/${f} ${PREFIX}/bin/
+.endfor
+ ${INSTALL_PROGRAM} ${_OBJDIR}/getmail ${JED_ROOT}/bin/
+ ${INSTALL_DATA} ${_LIBDIR}/*.sl ${_LIBDIR}/*.dat ${_LIBDIR}/*.hlp ${_LIBDIR}/jed.rc ${JED_ROOT}/lib/
+ ${INSTALL_DATA} ${_LIBDIR}/colors/* ${JED_ROOT}/lib/colors/
+ ${INSTALL_DATA} ${_LIBDIR}/tm/* ${JED_ROOT}/lib/tm/
+.for f in ${MAN1}
+ ${INSTALL_MAN} ${_DOCDIR}/${f} ${PREFIX}/man/man1/
+.endfor
+ ${INSTALL_DATA} ${_INFODIR}/jed.* ${PREFIX}/info/
+ @install-info ${PREFIX}/info/jed.info ${PREFIX}/info/dir
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${JED_ROOT}/doc/
+ ${INSTALL_DATA} ${_DOCDIR}/README ${_DOCDIR}/*.txt ${_DOCDIR}/jed.tex ${WRKSRC}/jed-j.doc ${JED_ROOT}/doc/
+.endif
+
+post-install:
+ @${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.post.mk>
diff --git a/japanese/jed/distinfo b/japanese/jed/distinfo
new file mode 100644
index 000000000000..3a2bbe753c23
--- /dev/null
+++ b/japanese/jed/distinfo
@@ -0,0 +1,2 @@
+MD5 (jed/jed-B0.99-8__J067.tar.gz) = c5d2eb69a1aeff4b6b861b766410d6cb
+MD5 (jed/jed-extralibs-0.99.8.tar.gz) = 3797a4f541e118669a76ed1798f5367a
diff --git a/japanese/jed/files/patch-aa b/japanese/jed/files/patch-aa
new file mode 100644
index 000000000000..5e4a0932496f
--- /dev/null
+++ b/japanese/jed/files/patch-aa
@@ -0,0 +1,32 @@
+--- configure.orig Tue Jul 20 20:22:45 1999
++++ configure Sat Feb 5 23:49:47 2000
+@@ -2580,7 +2580,8 @@
+ # the other directories may have a better chance of containing a more recent
+ # version.
+
+-JD_Search_Dirs="$JD_Search_Dirs \
++JD_Search_Dirs="${prefix}/include/slang,${prefix}/lib \
++ $JD_Search_Dirs \
+ $includedir,$libdir \
+ /usr/local/include,/usr/local/lib \
+ /usr/include,/usr/lib \
+@@ -3176,12 +3177,17 @@
+ cd \$(OBJDIR); \$(COMPILE_CMD) \$(SRCDIR)/vterm.c
+ "
+
+-
++if test "$ac_cv_xlocale" = yes; then
+ PROGRAM_OBJECT_RULES="$PROGRAM_OBJECT_RULES
+ \$(OBJDIR)/xterm.o : \$(SRCDIR)/xterm.c \$(DOT_O_DEPS) \$("xterm"_O_DEP)
+ cd \$(OBJDIR); \$(COMPILE_CMD) -DX_LOCALE \$(SRCDIR)/xterm.c
+ "
+-
++else
++PROGRAM_OBJECT_RULES="$PROGRAM_OBJECT_RULES
++\$(OBJDIR)/xterm.o : \$(SRCDIR)/xterm.c \$(DOT_O_DEPS) \$("xterm"_O_DEP)
++ cd \$(OBJDIR); \$(COMPILE_CMD) \$(SRCDIR)/xterm.c
++"
++fi
+
+ PROGRAM_OBJECT_RULES="$PROGRAM_OBJECT_RULES
+ \$(OBJDIR)/gpmmouse.o : \$(SRCDIR)/gpmmouse.c \$(DOT_O_DEPS) \$("gpmmouse"_O_DEP)
diff --git a/japanese/jed/files/patch-ab b/japanese/jed/files/patch-ab
new file mode 100644
index 000000000000..504e48a70333
--- /dev/null
+++ b/japanese/jed/files/patch-ab
@@ -0,0 +1,22 @@
+--- lib/jed.rc~ Tue Jul 20 20:22:46 1999
++++ lib/jed.rc Thu Feb 3 19:15:23 2000
+@@ -166,6 +166,19 @@
+ % that are continued onto the next line.
+ %---------------------------------------------------------------------------
+
++%---------------------------------------------------------------------------
++% Ruby-mode
++%---------------------------------------------------------------------------
++
++% amount of space to indent within block.
++variable ruby_indent_level = 2;
++
++% Load ruby mode when openning .rb' files.
++autoload("ruby_mode", "ruby");
++add_mode_for_extension ("ruby", "rb");
++
++%---------------------------------------------------------------------------
++
+ #ifdef MSDOS XWINDOWS MSWINDOWS
+ % Alt-key handling. Setting this variable controls how the
+ % Alt key is handled. By default it is set to 27 (Ascii ESCAPE). This means
diff --git a/japanese/jed/files/patch-ac b/japanese/jed/files/patch-ac
new file mode 100644
index 000000000000..386553f67bd4
--- /dev/null
+++ b/japanese/jed/files/patch-ac
@@ -0,0 +1,17 @@
+--- lib/canna.sl~ Sat Aug 14 13:03:12 1999
++++ lib/canna.sl Sat Aug 14 13:02:35 1999
+@@ -348,9 +348,10 @@
+ message("Canna can not be used in any more buffer. Sorry...");
+ return -1;
+ }
+- create_blocal_var("canna_buf_id", 'i');
++% create_blocal_var("canna_buf_id", 'i');
+ canna_buf_number++;
+- set_blocal_var(canna_buf_number, "canna_buf_id");
++ % set_blocal_var(canna_buf_number, "canna_buf_id");
++ define_blocal_var("canna_buf_id", canna_buf_number);
+ return canna_buf_number;
+ }
+ return get_blocal_var("canna_buf_id");
+
+
diff --git a/japanese/jed/files/patch-ad b/japanese/jed/files/patch-ad
new file mode 100644
index 000000000000..6a384c6f1713
--- /dev/null
+++ b/japanese/jed/files/patch-ad
@@ -0,0 +1,13 @@
+--- info/jed.info~ Wed Jul 14 06:01:25 1999
++++ info/jed.info Fri Feb 4 02:11:19 2000
+@@ -1,6 +1,10 @@
+ This is Info file jed.info, produced by Makeinfo-1.55 from the input
+ file jed.ti.
+
++START-INFO-DIR-ENTRY
++* JED: (jed). JED editor documentation.
++END-INFO-DIR-ENTRY
++
+ 
+ Indirect:
+ jed.1in: 83
diff --git a/japanese/jed/files/patch-ae b/japanese/jed/files/patch-ae
new file mode 100644
index 000000000000..ff6401154b16
--- /dev/null
+++ b/japanese/jed/files/patch-ae
@@ -0,0 +1,29 @@
+--- src/Makefile.in.orig Tue Jul 20 20:55:47 1999
++++ src/Makefile.in Sun Feb 6 00:02:49 2000
+@@ -104,7 +104,7 @@
+ all: jed rgrep
+
+
+-jed: $(OBJDIR) $(CONFIG_H) slangversion $(OBJDIR)/jed
++jed: $(OBJDIR) $(CONFIG_H) $(OBJDIR)/jed
+ @echo jed created in $(OBJDIR)
+ $(OBJDIR)/jed: $(OBJS) $(OBJDIR)/display.o $(OBJGPMMOUSEO)
+ cd $(OBJDIR); $(CC) $(OFILES) display.o $(GPMMOUSEO) \
+@@ -132,7 +132,7 @@
+ $(SRCDIR)/syntax.c: $(SRCDIR)/dfasyntx.c
+ touch $(SRCDIR)/syntax.c
+ #
+-xjed : $(OBJDIR) $(CONFIG_H) slangversion $(OBJDIR)/xjed
++xjed : $(OBJDIR) $(CONFIG_H) $(OBJDIR)/xjed
+ @echo xjed created in $(OBJDIR)
+ $(OBJDIR)/xjed : $(OBJS) $(OBJDIR)/xterm.o $(OBJDIR)/vterm.o
+ cd $(OBJDIR); \
+@@ -142,7 +142,7 @@
+ rgrep: $(OBJDIR)/rgrep
+ @echo rgrep created in $(OBJDIR)
+ $(OBJDIR)/rgrep: $(OBJDIR)/vfile.o $(OBJDIR)/rgrep.o
+- cd $(OBJDIR); $(CC) vfile.o rgrep.o -o rgrep $(LDFLAGS) $(SLANG_LIB) -lslang -lm
++ cd $(OBJDIR); $(CC) vfile.o rgrep.o -o rgrep $(LDFLAGS) $(SLANG_LIB) -lslang -lcurses -lm
+ #
+ getmail: $(OBJDIR)/getmail
+ @echo getmail created in $(OBJDIR)
diff --git a/japanese/jed/files/patch-af b/japanese/jed/files/patch-af
new file mode 100644
index 000000000000..2a2475324b82
--- /dev/null
+++ b/japanese/jed/files/patch-af
@@ -0,0 +1,15 @@
+--- lib/japanese.sl~ Tue Feb 8 16:17:10 2000
++++ lib/japanese.sl Tue Feb 8 16:17:49 2000
+@@ -5,8 +5,10 @@
+ %
+
+
+-define TRUE() { -1;}
+-define FALSE() { 0;}
++!if (is_defined("TRUE")) {
++ eval("define TRUE() { -1;}");
++ eval("define FALSE() { 0;}");
++}
+
+ % If your slang-j's version in jed-j is after 0.3.2,
+ % you can use KANJI function name.
diff --git a/japanese/jed/pkg-comment b/japanese/jed/pkg-comment
new file mode 100644
index 000000000000..8df513bc523e
--- /dev/null
+++ b/japanese/jed/pkg-comment
@@ -0,0 +1 @@
+A SLang-based text editor (w/ Japanese support)
diff --git a/japanese/jed/pkg-descr b/japanese/jed/pkg-descr
new file mode 100644
index 000000000000..701ebf3574b8
--- /dev/null
+++ b/japanese/jed/pkg-descr
@@ -0,0 +1,22 @@
+JED is a highly customizable text editor offering most of
+the commonly used features of EMACS without the proportions
+of EMACS. The default configuration uses EMACS keystrokes,
+though WordStar keystrokes are available, and most any
+keystrokes can be programmed.n JED is customizable and
+programmable in the language S-Lang, which can look like
+Forth or C, depending on your preferences.
+
+WWW: http://space.mit.edu/~davis/jed.html
+
+See /usr/local/lib/jed/doc/jed-j.doc about Japanese support.
+For the latest information, take a look at:
+
+ http://kondara.sdri.co.jp/~kikutani/jed.html
+
+Japanese translation of JED documents can be found at:
+
+ http://www.dsl.tutics.tut.ac.jp/~kawamoto/jed/jed.html
+
+Have fun!
+
+Akinori MUSHA aka knu <knu@idaemons.org>
diff --git a/japanese/jed/pkg-message b/japanese/jed/pkg-message
new file mode 100644
index 000000000000..24c9ee252bcc
--- /dev/null
+++ b/japanese/jed/pkg-message
@@ -0,0 +1,5 @@
+************************************************************
+Quickstart:
+ cp /usr/local/lib/jed/lib/jed.rc ~/.jedrc
+ jed ~/.jedrc
+************************************************************
diff --git a/japanese/jed/pkg-plist b/japanese/jed/pkg-plist
new file mode 100644
index 000000000000..ff51e932190b
--- /dev/null
+++ b/japanese/jed/pkg-plist
@@ -0,0 +1,191 @@
+bin/jed
+bin/rgrep
+%%XJED_ENTRY%%
+@unexec install-info --delete %D/info/jed.info %D/info/dir
+info/jed.info
+info/jed.1in
+info/jed.2in
+info/jed.3in
+@exec install-info %D/info/jed.info %D/info/dir
+lib/jed/bin/getmail
+lib/jed/doc/abbrev.txt
+lib/jed/doc/color.txt
+lib/jed/doc/dfa.txt
+lib/jed/doc/edt.txt
+lib/jed/doc/emacs.txt
+lib/jed/doc/fold.txt
+lib/jed/doc/hooks.txt
+lib/jed/doc/ide-mode.txt
+lib/jed/doc/jed_faq.txt
+lib/jed/doc/jedfuns.txt
+lib/jed/doc/libfuns.txt
+lib/jed/doc/menus.txt
+lib/jed/doc/mouse.txt
+lib/jed/doc/pc-keys.txt
+lib/jed/doc/program.txt
+lib/jed/doc/rgrep.txt
+lib/jed/doc/rmail.txt
+lib/jed/doc/script.txt
+lib/jed/doc/slangfun.txt
+lib/jed/doc/syntax.txt
+lib/jed/doc/undo.txt
+lib/jed/doc/wjed.txt
+lib/jed/doc/wordstar.txt
+lib/jed/doc/xjed.txt
+lib/jed/doc/yankpop.txt
+lib/jed/doc/README
+lib/jed/doc/jed.tex
+lib/jed/doc/jed-j.doc
+lib/jed/lib/colors/README
+lib/jed/lib/colors/black1.sl
+lib/jed/lib/colors/black2.sl
+lib/jed/lib/colors/black3.sl
+lib/jed/lib/colors/blue1.sl
+lib/jed/lib/colors/blue2.sl
+lib/jed/lib/colors/default1.sl
+lib/jed/lib/colors/white1.sl
+lib/jed/lib/tm/linuxdoc.tm
+lib/jed/lib/abbrev.sl
+lib/jed/lib/abbrmisc.sl
+lib/jed/lib/acompile.sl
+lib/jed/lib/ashell.sl
+lib/jed/lib/backups.sl
+lib/jed/lib/bibtex.sl
+lib/jed/lib/binary.sl
+lib/jed/lib/bookmark.sl
+lib/jed/lib/brief.sl
+lib/jed/lib/buf.sl
+lib/jed/lib/bufed.sl
+lib/jed/lib/bytecomp.sl
+lib/jed/lib/cal.sl
+lib/jed/lib/canna.sl
+lib/jed/lib/cmisc.sl
+lib/jed/lib/cmode.sl
+lib/jed/lib/compat.sl
+lib/jed/lib/compile.sl
+lib/jed/lib/ctags.sl
+lib/jed/lib/dabbrev.sl
+lib/jed/lib/dcl.sl
+lib/jed/lib/digraph.sl
+lib/jed/lib/dired.sl
+lib/jed/lib/dispesc.sl
+lib/jed/lib/dos437.sl
+lib/jed/lib/dos850.sl
+lib/jed/lib/edt.sl
+lib/jed/lib/emacs.sl
+lib/jed/lib/emacsmsc.sl
+lib/jed/lib/emul.sl
+lib/jed/lib/f90.sl
+lib/jed/lib/ff90.sl
+lib/jed/lib/filter.sl
+lib/jed/lib/folding.sl
+lib/jed/lib/fortran.sl
+lib/jed/lib/help.sl
+lib/jed/lib/hooks.sl
+lib/jed/lib/html.sl
+lib/jed/lib/ide.sl
+lib/jed/lib/idl.sl
+lib/jed/lib/info.sl
+lib/jed/lib/isearch.sl
+lib/jed/lib/iso-lat2.sl
+lib/jed/lib/iso-lat3.sl
+lib/jed/lib/iso-latin.sl
+lib/jed/lib/iso2xxx.sl
+lib/jed/lib/ispell.sl
+lib/jed/lib/japanese.sl
+lib/jed/lib/javamode.sl
+lib/jed/lib/jedhelp.sl
+lib/jed/lib/jp-samp.sl
+lib/jed/lib/keycode.sl
+lib/jed/lib/krconv.sl
+lib/jed/lib/latex.sl
+lib/jed/lib/latex209.sl
+lib/jed/lib/linux.sl
+lib/jed/lib/lisp.sl
+lib/jed/lib/ltx-math.sl
+lib/jed/lib/macro.sl
+lib/jed/lib/mail.sl
+lib/jed/lib/mailalias.sl
+lib/jed/lib/man.sl
+lib/jed/lib/maple.sl
+lib/jed/lib/matlab.sl
+lib/jed/lib/menu.sl
+lib/jed/lib/menus.sl
+lib/jed/lib/mime.sl
+lib/jed/lib/mini.sl
+lib/jed/lib/misc.sl
+lib/jed/lib/mkdoc.sl
+lib/jed/lib/mktex.sl
+lib/jed/lib/modehook.sl
+lib/jed/lib/modeinfo.sl
+lib/jed/lib/most.sl
+lib/jed/lib/mouse.sl
+lib/jed/lib/mousex.sl
+lib/jed/lib/mswmouse.sl
+lib/jed/lib/mutekeys.sl
+lib/jed/lib/nroff.sl
+lib/jed/lib/occur.sl
+lib/jed/lib/os.sl
+lib/jed/lib/perl.sl
+lib/jed/lib/pipe.sl
+lib/jed/lib/popups.sl
+lib/jed/lib/preparse.sl
+lib/jed/lib/pscript.sl
+lib/jed/lib/pushmode.sl
+lib/jed/lib/pymode.sl
+lib/jed/lib/rcs.sl
+lib/jed/lib/regexp.sl
+lib/jed/lib/register.sl
+lib/jed/lib/replace.sl
+lib/jed/lib/rmail.sl
+lib/jed/lib/rot13.sl
+lib/jed/lib/ruby.sl
+lib/jed/lib/search.sl
+lib/jed/lib/seldisp.sl
+lib/jed/lib/sendmail.sl
+lib/jed/lib/sgml.sl
+lib/jed/lib/shell.sl
+lib/jed/lib/shmode.sl
+lib/jed/lib/site.sl
+lib/jed/lib/skk.sl
+lib/jed/lib/slmode.sl
+lib/jed/lib/sort.sl
+lib/jed/lib/sortmisc.sl
+lib/jed/lib/spicemod.sl
+lib/jed/lib/srchmisc.sl
+lib/jed/lib/syntax.sl
+lib/jed/lib/tabs.sl
+lib/jed/lib/tclmode.sl
+lib/jed/lib/tex.sl
+lib/jed/lib/texcom.sl
+lib/jed/lib/textmac.sl
+lib/jed/lib/tiasm.sl
+lib/jed/lib/tm2sgml.sl
+lib/jed/lib/tmisc.sl
+lib/jed/lib/tpascal.sl
+lib/jed/lib/untab.sl
+lib/jed/lib/util.sl
+lib/jed/lib/verilog.sl
+lib/jed/lib/vhdlmode.sl
+lib/jed/lib/vmshelp.sl
+lib/jed/lib/wmark.sl
+lib/jed/lib/wmenu.sl
+lib/jed/lib/wordstar.sl
+lib/jed/lib/yankpop.sl
+lib/jed/lib/ltx-comp.dat
+lib/jed/lib/aboutjed.hlp
+lib/jed/lib/cpright.hlp
+lib/jed/lib/edt.hlp
+lib/jed/lib/emacs.hlp
+lib/jed/lib/generic.hlp
+lib/jed/lib/ide.hlp
+lib/jed/lib/jed.hlp
+lib/jed/lib/simple.hlp
+lib/jed/lib/wordstar.hlp
+lib/jed/lib/jed.rc
+@dirrm lib/jed/bin
+@dirrm lib/jed/lib/tm
+@dirrm lib/jed/lib/colors
+@dirrm lib/jed/lib
+@dirrm lib/jed/doc
+@dirrm lib/jed