aboutsummaryrefslogtreecommitdiff
path: root/japanese/latex2html
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-28 18:26:55 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-28 18:26:55 +0000
commit4b927259dcc054857c80e12e109dd11202ccb6e1 (patch)
tree6a5e7f8446b455c3803fcb6eaa77dec0d8652f75 /japanese/latex2html
parent4b7f9c06ec0de8bfd5c7d4e1324303c37c157472 (diff)
downloadports-4b927259dcc054857c80e12e109dd11202ccb6e1.tar.gz
ports-4b927259dcc054857c80e12e109dd11202ccb6e1.zip
Notes
Diffstat (limited to 'japanese/latex2html')
-rw-r--r--japanese/latex2html/files/patch-ba38
-rw-r--r--japanese/latex2html/files/patch-bb11
-rw-r--r--japanese/latex2html/files/patch-bc11
-rw-r--r--japanese/latex2html/files/patch-bd11
-rw-r--r--japanese/latex2html/files/patch-be11
-rw-r--r--japanese/latex2html/pkg-plist4
6 files changed, 86 insertions, 0 deletions
diff --git a/japanese/latex2html/files/patch-ba b/japanese/latex2html/files/patch-ba
new file mode 100644
index 000000000000..acc73fe0c080
--- /dev/null
+++ b/japanese/latex2html/files/patch-ba
@@ -0,0 +1,38 @@
+--- latex2html.orig Tue Jul 18 09:41:56 2000
++++ latex2html Tue Jul 18 09:46:11 2000
+@@ -2780,7 +2780,7 @@
+ if (defined &$trans) {
+ &set_default_language($pattern,*_);
+ }
+- undef($cmd,$trans);
++ undef $cmd; undef $trans;
+ }
+ next;
+ } elsif ($4) {
+@@ -3085,7 +3085,7 @@
+ # Modifies $contents
+ &process_command($single_cmd_rx,*contents) if ($contents =~ /\\/o);
+ }
+- undef ($cmd,$tmp,$etmp);
++ undef $cmd; undef $tmp; undef $etmp;
+ } else {
+ $contents = &translate_environments($contents);
+ $contents = &translate_commands($contents)
+@@ -8916,7 +8916,7 @@
+ };
+ }
+ return(1) if ($this_dir eq '.');
+- rmdir($this_dir,$print_dir) if $mode;
++ if ($mode) { rmdir $this_dir; rmdir $print_dir }
+ if (!$mode) { &new_dir($this_dir,'r')};
+ return(1);
+ } elsif ($answer =~ /^q$/) {
+@@ -11326,7 +11326,7 @@
+ &extract_captions($cap_env) if ($_ =~ /\\caption/m);
+ $minipage_caption = $captions;
+ $_ = $contents;
+- undef($contents, $captions);
++ undef $contentscw; undef $captions;
+ };
+ }
+
diff --git a/japanese/latex2html/files/patch-bb b/japanese/latex2html/files/patch-bb
new file mode 100644
index 000000000000..18ff12030c1d
--- /dev/null
+++ b/japanese/latex2html/files/patch-bb
@@ -0,0 +1,11 @@
+--- versions/html3_1.pl Tue Mar 30 20:29:04 1999
++++ versions/html3_1.pl.new Tue Jul 18 09:27:13 2000
+@@ -1731,7 +1731,7 @@
+ ($this, $_) = &$ctmp($_);
+ $this = &parse_math_toks($mode,$style,$face,$slevel,1,$this);
+ @open_tags = @save_open_tags;
+- undef ($color_env, $inside_math, @save_open_tags);
++ undef $color_env; undef $inside_math; undef @save_open_tags;
+ };
+ } elsif ($cmd eq 'left') {
+ #expandable delimiter: make an image
diff --git a/japanese/latex2html/files/patch-bc b/japanese/latex2html/files/patch-bc
new file mode 100644
index 000000000000..a0d4af98f86b
--- /dev/null
+++ b/japanese/latex2html/files/patch-bc
@@ -0,0 +1,11 @@
+--- versions/html3_2.pl Wed Dec 2 19:43:50 1998
++++ versions/html3_2.pl.new Tue Jul 18 09:24:27 2000
+@@ -801,7 +801,7 @@
+ local($tmp) = ++$global{'max_id'};
+ "\\begin$OP$tmp${CP}math$OP$tmp$CP$1\\end$OP$tmp${CP}math$OP$tmp$CP"
+ /eg;
+- undef ($cmd,$tmp,$endspec); undef @cmds;
++ undef $cmd; undef $tmp; undef $endspec; undef @cmds;
+
+ local($tmp) = ++$global{'max_id'};
+ if(@save_open_tags_tabular) {
diff --git a/japanese/latex2html/files/patch-bd b/japanese/latex2html/files/patch-bd
new file mode 100644
index 000000000000..23616be6e0f3
--- /dev/null
+++ b/japanese/latex2html/files/patch-bd
@@ -0,0 +1,11 @@
+--- versions/html4_0.pl Wed Dec 2 19:43:52 1998
++++ versions/html4_0.pl.new Tue Jul 18 09:25:00 2000
+@@ -1138,7 +1138,7 @@
+ local($tmp) = ++$global{'max_id'};
+ "\\begin$OP$tmp${CP}math$OP$tmp$CP$1\\end$OP$tmp${CP}math$OP$tmp$CP"
+ /eg;
+- undef ($cmd,$tmp,$endspec); undef @cmds;
++ undef $cmd; undef $tmp; undef $endspec; undef @cmds;
+
+ local($tmp) = ++$global{'max_id'};
+ if(@save_open_tags_tabular) {
diff --git a/japanese/latex2html/files/patch-be b/japanese/latex2html/files/patch-be
new file mode 100644
index 000000000000..1ccd8b1d4a88
--- /dev/null
+++ b/japanese/latex2html/files/patch-be
@@ -0,0 +1,11 @@
+--- versions/math.pl Tue Jul 18 09:25:39 2000
++++ versions/math.pl.new Tue Jul 18 09:26:05 2000
+@@ -1731,7 +1731,7 @@
+ ($this, $_) = &$ctmp($_);
+ $this = &parse_math_toks($mode,$style,$face,$slevel,1,$this);
+ @open_tags = @save_open_tags;
+- undef ($color_env, $inside_math, @save_open_tags);
++ undef $color_env; undef $inside_math; undef @save_open_tags;
+ };
+ } elsif ($cmd eq 'left') {
+ #expandable delimiter: make an image
diff --git a/japanese/latex2html/pkg-plist b/japanese/latex2html/pkg-plist
index 7fe1cd8f4090..6bc5ef0b79cd 100644
--- a/japanese/latex2html/pkg-plist
+++ b/japanese/latex2html/pkg-plist
@@ -396,8 +396,11 @@ share/latex2html/versions/html2_1.pl
share/latex2html/versions/html2_2.pl
share/latex2html/versions/html3_0.pl
share/latex2html/versions/html3_1.pl
+share/latex2html/versions/html3_1.pl.orig
share/latex2html/versions/html3_2.pl
+share/latex2html/versions/html3_2.pl.orig
share/latex2html/versions/html4_0.pl
+share/latex2html/versions/html4_0.pl.orig
share/latex2html/versions/i18n.pl
share/latex2html/versions/lang.pl
share/latex2html/versions/latin1.pl
@@ -407,6 +410,7 @@ share/latex2html/versions/latin4.pl
share/latex2html/versions/latin5.pl
share/latex2html/versions/latin6.pl
share/latex2html/versions/math.pl
+share/latex2html/versions/math.pl.orig
share/latex2html/versions/table.pl
share/latex2html/versions/unicode.pl
share/texmf/tex/latex/latex2html/floatflt.ins