aboutsummaryrefslogtreecommitdiff
path: root/japanese/less
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-01-19 16:57:52 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-01-19 16:57:52 +0000
commitc0470cd468082e6cb1fd5b2d6b7b4ff9290f3eda (patch)
tree7f9f2812beafcccf29ac8867af2194f9434ed79d /japanese/less
parentbbd172b869ee0abfef3bd738e12e39521c760f2a (diff)
downloadports-c0470cd468082e6cb1fd5b2d6b7b4ff9290f3eda.tar.gz
ports-c0470cd468082e6cb1fd5b2d6b7b4ff9290f3eda.zip
Notes
Diffstat (limited to 'japanese/less')
-rw-r--r--japanese/less/Makefile34
-rw-r--r--japanese/less/distinfo2
-rw-r--r--japanese/less/files/patch-ac4
-rw-r--r--japanese/less/files/patch-filename.c16
-rw-r--r--japanese/less/files/patch-regex_cs.c (renamed from japanese/less/files/regex_cs.c.patch)0
-rw-r--r--japanese/less/pkg-descr20
-rw-r--r--japanese/less/pkg-plist6
7 files changed, 37 insertions, 45 deletions
diff --git a/japanese/less/Makefile b/japanese/less/Makefile
index a2409905e747..a3292fad99f5 100644
--- a/japanese/less/Makefile
+++ b/japanese/less/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: jless
-# Date created: 7 March 1995
-# Whom: Nobuhiro Yasutomi <nobu@psrc.isac.co.jp>
-#
+# Created by: Nobuhiro Yasutomi <nobu@psrc.isac.co.jp>
# $FreeBSD$
-#
PORTNAME= less+iso
PORTVERSION= 382.262
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= japanese
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= nork
@@ -22,31 +18,33 @@ PATCHFILES= ${DISTNAME}-iso258.patch.gz \
${DISTNAME}-iso258-259.patch.gz \
${DISTNAME}-iso259-260.patch.gz \
${DISTNAME}-iso260-261.patch.gz \
- ${DISTNAME}-iso261-${PORTVERSION:E}.patch.gz
+ ${DISTNAME}-iso261-${PORTVERSION:E}.patch.gz \
+ ${DISTNAME}-iso${PORTVERSION:E}.ext03.patch.gz
PATCH_DIST_STRIP= -p1
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Less + zcat + ISO-2022 - a pager similar to more and pg
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Less + zcat + ISO-2022 + UTF-8 - a pager similar to more and pg
+
+LICENSE= GPLv2
MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-cs-regex
MAN1= jless.1 jlesskey.1
-
DOCSDIR= ${PREFIX}/share/doc/less
-READMES= README.iso README.regex README.iso.jp README.regex.jp
+PORTDOCS= README.iso README.iso.jp README.lesw.euc \
+ README.regex README.regex.jp
-post-patch:
- (cd ${WRKSRC} ; \
- ${RM} -f COPYING; \
- ${GZCAT} ${DISTDIR}/regex_cs-lwp9k.shar.gz | ${SH}; \
- ${PATCH} < ${PATCHDIR}/regex_cs.c.patch )
- ${TOUCH} ${WRKSRC}/configure
+post-extract:
+ cd ${WRKDIR} && \
+ ${GZCAT} ${DISTDIR}/regex_cs-lwp9k.shar.gz | ${SH} && \
+ ${MV} regex_cs.[ch] README.regex README.regex.jp \
+ README.lesw.euc ${WRKSRC}
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC}; ${INSTALL_DATA} ${READMES} ${DOCSDIR})
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/japanese/less/distinfo b/japanese/less/distinfo
index ca19697649e7..7c9dd8f3a82b 100644
--- a/japanese/less/distinfo
+++ b/japanese/less/distinfo
@@ -12,3 +12,5 @@ SHA256 (less-382-iso260-261.patch.gz) = b595378ae65a5a7256df3b6279d755d6fdce66ab
SIZE (less-382-iso260-261.patch.gz) = 841
SHA256 (less-382-iso261-262.patch.gz) = e7249de419acc3b8c4a11bed376d778711fd031887d0df0624d62a6d07356842
SIZE (less-382-iso261-262.patch.gz) = 2215
+SHA256 (less-382-iso262.ext03.patch.gz) = 82fb77f21ea1f3281224fcbfad073aeab12fb40d6623c9b40698be952401f821
+SIZE (less-382-iso262.ext03.patch.gz) = 138951
diff --git a/japanese/less/files/patch-ac b/japanese/less/files/patch-ac
index 45da9fa27463..e2362debfa3f 100644
--- a/japanese/less/files/patch-ac
+++ b/japanese/less/files/patch-ac
@@ -4,5 +4,5 @@
This modification make regex_cs-lwp9k be able to compile.
*/
--char version[] = "382+iso262";
-+char version[] = "382+iso262+regex_cs-lwp9k";
+-char version[] = "382+iso262+ext3";
++char version[] = "382+iso262+ext3+regex_cs-lwp9k";
diff --git a/japanese/less/files/patch-filename.c b/japanese/less/files/patch-filename.c
index 004eb4a38ebc..deb54789d380 100644
--- a/japanese/less/files/patch-filename.c
+++ b/japanese/less/files/patch-filename.c
@@ -1,15 +1,9 @@
--- filename.c.orig 2010-05-10 23:08:16.800855000 +0900
-+++ filename.c 2010-05-10 23:10:53.231134025 +0900
-@@ -802,9 +802,15 @@
- else if (strcmp(".gz", &filename[length - 3]) == 0 ||
- strcmp(".GZ", &filename[length - 3]) == 0)
- return ("| gzip -cd %s");
-+ else if (strcmp(".xz", &filename[length - 3]) == 0 ||
-+ strcmp(".XZ", &filename[length - 3]) == 0)
-+ return ("| xz -cd %s");
- else if (strcmp(".bz2", &filename[length - 4]) == 0 ||
- strcmp(".BZ2", &filename[length - 4]) == 0)
- return ("| bzip2 -cd %s");
++++ filename.c 2013-01-19 08:38:15.691025968 +0900
+@@ -817,6 +817,9 @@
+ else if (strcmp(".xz", &filename[length - 3]) == 0 ||
+ strcmp(".XZ", &filename[length - 3]) == 0)
+ return ("| xz -cd %s");
+ else if (strcmp(".lzma", &filename[length - 5]) == 0 ||
+ strcmp(".LZMA", &filename[length - 5]) == 0)
+ return ("| lzma -cd %s");
diff --git a/japanese/less/files/regex_cs.c.patch b/japanese/less/files/patch-regex_cs.c
index 54e8fb0de136..54e8fb0de136 100644
--- a/japanese/less/files/regex_cs.c.patch
+++ b/japanese/less/files/patch-regex_cs.c
diff --git a/japanese/less/pkg-descr b/japanese/less/pkg-descr
index 7a41f5ace4a5..fa5d1ed2c659 100644
--- a/japanese/less/pkg-descr
+++ b/japanese/less/pkg-descr
@@ -1,11 +1,13 @@
- Less is a program similar to more (1), but which allows
- backward movement in the file as well as forward movement.
- Also, less does not have to read the entire input file
- before starting, so with large input files it starts up
- faster than text editors like vi (1).
+Less is a program similar to more(1), but which allows backward
+movement in the file as well as forward movement. Also, less does not
+have to read the entire input file before starting, so with large
+input files it starts up faster than text editors like vi(1).
- This enhanced less support ISO 2022 code extension techniqes and
+This enhanced less support ISO 2022 code extension techniqes and
Japanese codes(EUC Japanese, SJIS) and compressed(or gzipped) file
-viewing. The author of this patch is jam@pobox.com. See
-WWW: http://www25.big.jp/~jam/less/
-for the latest info.
+viewing. The author of the patch is jam@pobox.com, and the UTF-8
+support patch is written by bogytech.
+
+WWW: http://www25.big.jp/~jam/less/ (broken link)
+WWW: http://web.archive.org/web/20070220213232/http://www25.big.or.jp/~jam/less
+WWW: http://bogytech.blogspot.jp/search/label/jless
diff --git a/japanese/less/pkg-plist b/japanese/less/pkg-plist
index d75e698ad550..2b272cc6f595 100644
--- a/japanese/less/pkg-plist
+++ b/japanese/less/pkg-plist
@@ -1,8 +1,4 @@
+@comment $FreeBSD$
bin/jless
bin/jlesskey
bin/jlessecho
-%%PORTDOCS%%%%DOCSDIR%%/README.iso
-%%PORTDOCS%%%%DOCSDIR%%/README.iso.jp
-%%PORTDOCS%%%%DOCSDIR%%/README.regex
-%%PORTDOCS%%%%DOCSDIR%%/README.regex.jp
-%%PORTDOCS%%@dirrm %%DOCSDIR%%