aboutsummaryrefslogtreecommitdiff
path: root/japanese/linux-JM
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2001-03-10 19:17:30 +0000
committerSADA Kenji <sada@FreeBSD.org>2001-03-10 19:17:30 +0000
commit27974d7f2a238d08c7c47a19996521cb602d6319 (patch)
treefc570ce4e3ae51672b1c72594e82f6dac37d4f91 /japanese/linux-JM
parent823b95549903abdafb847f408d782c97154a7105 (diff)
downloadports-27974d7f2a238d08c7c47a19996521cb602d6319.tar.gz
ports-27974d7f2a238d08c7c47a19996521cb602d6319.zip
Notes
Diffstat (limited to 'japanese/linux-JM')
-rw-r--r--japanese/linux-JM/Makefile87
-rw-r--r--japanese/linux-JM/distinfo17
-rw-r--r--japanese/linux-JM/files/Makefile9
-rw-r--r--japanese/linux-JM/files/Makefile.inc23
-rw-r--r--japanese/linux-JM/pkg-comment1
-rw-r--r--japanese/linux-JM/pkg-descr3
-rw-r--r--japanese/linux-JM/pkg-message4
-rw-r--r--japanese/linux-JM/scripts/configure47
8 files changed, 191 insertions, 0 deletions
diff --git a/japanese/linux-JM/Makefile b/japanese/linux-JM/Makefile
new file mode 100644
index 000000000000..53d0ba323535
--- /dev/null
+++ b/japanese/linux-JM/Makefile
@@ -0,0 +1,87 @@
+# New ports collection makefile for: linux-JM japanized man pages
+# Date created: 21 Jan 2001
+# Whom: SADA Kenji <sada@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linux-JM
+PORTVERSION= ${DATESPEC}
+CATEGORIES= japanese
+MASTER_SITES= http://www.linux.or.jp/JM/per-pkg/
+DISTFILES= ${DISTFILES_GNU} ${DISTFILES_OTHERS}
+
+MAINTAINER= sada@FreeBSD.org
+
+DIST_SUBDIR= ${PORTNAME}
+MANSECS= 1 3 5 8
+NO_MTREE= yes
+NO_WRKSUBDIR= yes
+PLIST= ${WRKDIR}/PLIST
+SCRIPTS_ENV+= MANSECS="${MANSECS}"
+
+DATESPEC= 20010215
+MANPAGES_GNU= bash gdbm
+MANPAGES_OTHERS= \
+ bzip2 \
+ cdparanoia cdrecord cvsup \
+ dhcpcd \
+ eject expect \
+ fetchmail fort77 \
+ mpg123 \
+ ncftp \
+ rdate \
+ smbfs sudo \
+ uudeview
+
+.include <bsd.port.pre.mk>
+
+DISTFILES_GNU!=\
+ ${ECHO} ${MANPAGES_GNU} \
+ | ${SED} 's/[^ ]*/man-pages-ja-GNU_&-${DATESPEC}.tar.gz/g'
+DISTFILES_OTHERS!=\
+ ${ECHO} ${MANPAGES_OTHERS} \
+ | ${SED} 's/[^ ]*/man-pages-ja-&-${DATESPEC}.tar.gz/g'
+
+post-extract:
+.for i in Makefile Makefile.inc
+ @${CP} ${FILESDIR}/$i ${WRKSRC}
+.endfor
+.for i in ${MANSECS}
+ @cd ${WRKSRC} \
+ && ${MKDIR} man$i \
+ && ${LN} man-*/man$i/*.$i man$i
+.endfor
+
+post-build:
+ @${ECHO} -n "" > ${PLIST}
+ @for sec in ${MANSECS}; do \
+ if [ -d ${WRKSRC}/man$${sec} ]; then \
+ cd ${WRKSRC}/man$${sec}; \
+ list=`${MAKE} pages-list`; \
+ set `${ECHO} $$list " "|${SED} 's/\.\([0-9]\) /.\1 \1 /g'`; \
+ while : ; do \
+ case $$# in \
+ 0) break;; \
+ [1]) ${ECHO} "can not happen" >/dev/tty; \
+ exit 1;; \
+ esac; \
+ ${ECHO} man/ja/man$$2/$$1.gz; shift 2; \
+ done; \
+ fi; \
+ done|sort|uniq >>${PLIST}
+.for sec in ${MANSECS}
+ @${ECHO} '@unexec rmdir %D/man/ja/man'${sec}' 2>/dev/null || true' \
+ >>${PLIST}
+.endfor
+ @${ECHO} '@unexec rmdir %D/man/ja 2>/dev/null || true' >>${PLIST}
+
+pre-install:
+.for sec in ${MANSECS}
+ @${MKDIR} ${PREFIX}/man/ja/man${sec}
+.endfor
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/japanese/linux-JM/distinfo b/japanese/linux-JM/distinfo
new file mode 100644
index 000000000000..8be885541ce9
--- /dev/null
+++ b/japanese/linux-JM/distinfo
@@ -0,0 +1,17 @@
+MD5 (linux-JM/man-pages-ja-GNU_bash-20010215.tar.gz) = 56e6a756390c6e69a4de77757bda01f4
+MD5 (linux-JM/man-pages-ja-GNU_gdbm-20010215.tar.gz) = b337507391c17aca42c717cda1a5b5d6
+MD5 (linux-JM/man-pages-ja-bzip2-20010215.tar.gz) = cd619ebeab53e1ad18fa3a18c76583db
+MD5 (linux-JM/man-pages-ja-cdparanoia-20010215.tar.gz) = 165e671ae393de0fc497f6412b8b9656
+MD5 (linux-JM/man-pages-ja-cdrecord-20010215.tar.gz) = 5dbeb7358f2103a6293fc91cde8265b8
+MD5 (linux-JM/man-pages-ja-cvsup-20010215.tar.gz) = 191c91e84e63417c09e309f2a03c954b
+MD5 (linux-JM/man-pages-ja-dhcpcd-20010215.tar.gz) = e326a5c1b51763d0d802134d477a542c
+MD5 (linux-JM/man-pages-ja-eject-20010215.tar.gz) = 762f152ad41c593c1786a307b78334f0
+MD5 (linux-JM/man-pages-ja-expect-20010215.tar.gz) = e487da74644938eb309f19bf4299ba95
+MD5 (linux-JM/man-pages-ja-fetchmail-20010215.tar.gz) = f11eb02d72407267babe43c6127cdc19
+MD5 (linux-JM/man-pages-ja-fort77-20010215.tar.gz) = 097e1594f017719aba198224a1b26c36
+MD5 (linux-JM/man-pages-ja-mpg123-20010215.tar.gz) = 4fa0ef23fbd87b773a4575d3824e2f0c
+MD5 (linux-JM/man-pages-ja-ncftp-20010215.tar.gz) = c68964f877a2121b8c64a45dbfe164b3
+MD5 (linux-JM/man-pages-ja-rdate-20010215.tar.gz) = 65509855e38764a41dcc0c4e616f5e6f
+MD5 (linux-JM/man-pages-ja-smbfs-20010215.tar.gz) = 58927b3273db7337082ca9149f5ade3b
+MD5 (linux-JM/man-pages-ja-sudo-20010215.tar.gz) = 656fe652dc0e56bdfdbc1021f31409c5
+MD5 (linux-JM/man-pages-ja-uudeview-20010215.tar.gz) = 22abc1c6282bf30b6b6478fa02cd6073
diff --git a/japanese/linux-JM/files/Makefile b/japanese/linux-JM/files/Makefile
new file mode 100644
index 000000000000..9c9e00a33699
--- /dev/null
+++ b/japanese/linux-JM/files/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+BINDIR= ${PREFIX}
+SUBDIR= man1 man3 man5 man8
+
+makedb:
+ LANG=ja_JP.EUC jmakewhatis ${DESTDIR}${BINDIR}/man/ja/
+
+.include <bsd.subdir.mk>
diff --git a/japanese/linux-JM/files/Makefile.inc b/japanese/linux-JM/files/Makefile.inc
new file mode 100644
index 000000000000..25a10387c555
--- /dev/null
+++ b/japanese/linux-JM/files/Makefile.inc
@@ -0,0 +1,23 @@
+PREFIX?= /usr/local
+MANDIR= ${PREFIX}/man/ja/man
+MROFF_CMD= /usr/local/bin/groff -Tnippon -man
+
+NOMLINKS= yes
+
+afterinstall:
+.if defined(MLINKS) && !empty(MLINKS)
+ @set `echo ${MLINKS} " " | sed 's/\.\([^.]\)\([^.]*\) /.\1\2 \1 /g'`; \
+ while : ; do \
+ case $$# in \
+ 0) break;; \
+ [123]) echo "warn: empty MLINK: $$1 $$2 $$3"; break;; \
+ esac; \
+ name=$$1; shift; sect=$$1; shift; \
+ l=${DESTDIR}${MANDIR}$${sect}${MANSUBDIR}/$$name; \
+ name=$$1; shift; sect=$$1; shift; \
+ t=${DESTDIR}${MANDIR}$${sect}${MANSUBDIR}/$$name; \
+ ${ECHO} $${t}${ZEXT} -\> $${l}${ZEXT}; \
+ rm -f $${t} $${t}${MCOMPRESS_EXT}; \
+ ln $${l}${ZEXT} $${t}${ZEXT}; \
+ done
+.endif
diff --git a/japanese/linux-JM/pkg-comment b/japanese/linux-JM/pkg-comment
new file mode 100644
index 000000000000..2878fc7876d0
--- /dev/null
+++ b/japanese/linux-JM/pkg-comment
@@ -0,0 +1 @@
+Japanese translated man pages by JM Project
diff --git a/japanese/linux-JM/pkg-descr b/japanese/linux-JM/pkg-descr
new file mode 100644
index 000000000000..7094d47385a4
--- /dev/null
+++ b/japanese/linux-JM/pkg-descr
@@ -0,0 +1,3 @@
+JM is Japanese translated manual pages by JM Project.
+
+WWW: http://www.linux.or.jp/JM/
diff --git a/japanese/linux-JM/pkg-message b/japanese/linux-JM/pkg-message
new file mode 100644
index 000000000000..802462abf359
--- /dev/null
+++ b/japanese/linux-JM/pkg-message
@@ -0,0 +1,4 @@
+Copyright (C) 1999-2000 JM Project All rights reserved.
+
+Those man pages are presented by JM Project <http://www.linux.or.jp/JM/>.
+If you find problem, please send a report to <JM@linux.or.jp>.
diff --git a/japanese/linux-JM/scripts/configure b/japanese/linux-JM/scripts/configure
new file mode 100644
index 000000000000..8da3fb55d313
--- /dev/null
+++ b/japanese/linux-JM/scripts/configure
@@ -0,0 +1,47 @@
+exec /usr/bin/perl -Sx "$0" ${1+"$@"}
+#! perl
+
+$WRKSRC = $ENV{'WRKSRC'};
+@MANSECS = split(/\s+/, $ENV{'MANSECS'});
+
+for $sec (@MANSECS) {
+ print "===> Creating Makefile in man${sec}\n";
+
+ chdir "$WRKSRC/man$sec";
+ @manpages = ();
+ @mlinks = ();
+
+ for $manpage (<*.${sec}>) {
+ open(F, $manpage) || die "cannot open $manpage: $!\n";
+ $_ = <F>;
+ chop;
+ close(F);
+ if (/^\.so /) {
+ ($real = $') =~ s!^man./!!;
+ push(@mlinks, "$real\t$manpage");
+ }
+ else {
+ push(@manpages, $manpage);
+ }
+ }
+
+ open(MAKEFILE, '>Makefile');
+
+ if (@manpages) {
+ print MAKEFILE join("\t\\\n\t", "MAN${sec} =", sort @manpages);
+ print MAKEFILE "\n\n";
+ }
+ if (@mlinks) {
+ print MAKEFILE join("\t\\\n\t", "MLINKS =", sort @mlinks);
+ print MAKEFILE "\n\n";
+ }
+
+ print MAKEFILE <<EOF;
+pages-list:
+ @\${ECHO} \${MAN${sec}} \${MLINKS}
+
+.include <bsd.prog.mk>
+EOF
+
+ close(MAKEFILE);
+}