aboutsummaryrefslogtreecommitdiff
path: root/japanese/lyx/Makefile
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>1999-03-31 11:44:24 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>1999-03-31 11:44:24 +0000
commita44712165e284cf615e43e38d7e6d4bab616c863 (patch)
tree8ee5bce0ece506de8341e5aa6f71c7fa1b9c9360 /japanese/lyx/Makefile
parentb8c742d9d090b7b3d7288ec1e759ea3d8b0d4a89 (diff)
downloadports-a44712165e284cf615e43e38d7e6d4bab616c863.tar.gz
ports-a44712165e284cf615e43e38d7e6d4bab616c863.zip
Notes
Diffstat (limited to 'japanese/lyx/Makefile')
-rw-r--r--japanese/lyx/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/japanese/lyx/Makefile b/japanese/lyx/Makefile
new file mode 100644
index 000000000000..19744722d84d
--- /dev/null
+++ b/japanese/lyx/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: lyx
+# Version required: 1.0.0
+# Date created: 27 April 1999
+# Whom: Seiichirou Hiraoka
+#
+# $Id$
+#
+
+DISTNAME= lyx-1.0.0
+PKGNAME= ja-lyx-1.0.0
+CATEGORIES= japanese print
+MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
+ ftp://la1ad.uio.no/pub/lyx/ \
+ ftp://alpha.tat.physik.uni-tuebingen.de/pub/lyx/stable/ \
+ ftp://ftp.sdsc.edu/pub/other/lyx/stable/ \
+ http://cgi.din.or.jp/~kawakami/product/LyX/
+DISTFILES= lyx-1.0.0.tar.gz lyx-jp-kit0.04for1.0.0.tar.gz
+
+MAINTAINER= flathill@FreeBSD.ORG
+
+BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+.if defined(WITH_ISPELL)
+RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
+.endif
+LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms \
+ Xpm.4:${PORTSDIR}/graphics/xpm
+
+# depends on xforms
+ONLY_FOR_ARCHS= i386
+
+USE_PERL5= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LYX_LIBS="-lxpg4" CXXFLAGS="${CFLAGS}"
+STRIP=
+CONFIGURE_ARGS= --with-extra-lib=${X11BASE}/lib --with-extra-inc="${X11BASE}/include ${X11BASE}/include/X11"
+MAN1= lyx.1 reLyX.1
+
+pre-fetch:
+.if !defined(WITH_ISPELL)
+ @${ECHO_MSG} "if you want this port build with spell checker type"
+ @${ECHO_MSG} "make WITH_ISPELL=yes"
+.endif
+
+do-patch:
+ @cd ${WRKSRC}; ${PATCH} -p1 < ../lyx-jp-patch
+
+post-install:
+ @strip ${PREFIX}/bin/lyx
+ ${INSTALL_DATA} ${WRKDIR}/ChangeLog.jis ${PREFIX}/share/lyx
+ ${INSTALL_DATA} ${WRKDIR}/README.jis ${PREFIX}/share/lyx
+ ${INSTALL_DATA} ${WRKSRC}/lib/lyxrc.jp ${PREFIX}/share/lyx
+
+.include <bsd.port.mk>