aboutsummaryrefslogtreecommitdiff
path: root/japanese/migemo
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-09-20 04:46:10 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-09-20 04:46:10 +0000
commit634259747c59cb84ee9686d3d5b6b0808b92292a (patch)
treee7937e1a349e26df3a27c546231bd00ebbfcec44 /japanese/migemo
parentd6ef81783edb7c4400aa5c4741c299f360dff171 (diff)
downloadports-634259747c59cb84ee9686d3d5b6b0808b92292a.tar.gz
ports-634259747c59cb84ee9686d3d5b6b0808b92292a.zip
Notes
Diffstat (limited to 'japanese/migemo')
-rw-r--r--japanese/migemo/Makefile35
-rw-r--r--japanese/migemo/distinfo2
-rw-r--r--japanese/migemo/files/extra-patch-Makefile.am19
-rw-r--r--japanese/migemo/files/extra-patch-configure.in10
-rw-r--r--japanese/migemo/files/patch-Makefile.am10
-rw-r--r--japanese/migemo/files/patch-migemo-cache.rb11
-rw-r--r--japanese/migemo/pkg-comment2
-rw-r--r--japanese/migemo/pkg-descr8
-rw-r--r--japanese/migemo/pkg-plist37
9 files changed, 63 insertions, 71 deletions
diff --git a/japanese/migemo/Makefile b/japanese/migemo/Makefile
index f258efd236b5..f41c9800e03e 100644
--- a/japanese/migemo/Makefile
+++ b/japanese/migemo/Makefile
@@ -6,46 +6,29 @@
#
PORTNAME= migemo
-PORTVERSION= 0.3
+PORTVERSION= 0.32
PORTEPOCH= 1
CATEGORIES= japanese elisp
MASTER_SITES= http://migemo.namazu.org/stable/
-PKGNAMESUFFIX= -${EMACS_PORT_NAME}
MAINTAINER= nobutaka@nobutaka.com
-EMACS_PORT_NAME?= emacs20
-
-.if (${EMACS_PORT_NAME} == "xemacs21-mule")
-EMACS_PACKAGESDIR= lib/xemacs/site-packages
-
-BUILD_DEPENDS= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
-RUN_DEPENDS= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
-.else
-BUILD_DEPENDS= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
-RUN_DEPENDS= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+.if !defined(EMACS_PORT_NAME)
+USE_AUTOMAKE= yes
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile.am ${FILESDIR}/extra-patch-configure.in
+PLIST_SUB= MIGEMO="" ELISP="@comment "
.endif
-USE_AUTOMAKE= yes
USE_RUBY= yes
BUILD_DEPENDS+= ${RUBY_SITELIBDIR}/romkan.rb:${PORTSDIR}/japanese/ruby-romkan \
${RUBY_SITELIBDIR}/bsearch.rb:${PORTSDIR}/devel/ruby-bsearch
RUN_DEPENDS+= ${RUBY_SITELIBDIR}/romkan.rb:${PORTSDIR}/japanese/ruby-romkan \
${RUBY_SITELIBDIR}/bsearch.rb:${PORTSDIR}/devel/ruby-bsearch
-CONFIGURE_ARGS= --with-rubydir=${RUBY_SITELIBDIR} --with-emacs=${EMACS_CMD}
-.if (${EMACS_PORT_NAME} == "xemacs21-mule")
-CONFIGURE_ARGS+= --with-lispdir=${PREFIX}/${EMACS_LIBDIR}/site-lisp
-.endif
-
-.include <bsd.port.pre.mk>
-
-post-configure:
- ${RUBY} -i -pe 'sub /@list=/, "list="' ${WRKSRC}/${MAKEFILE}
+CONFIGURE_ARGS+=--with-rubydir=${RUBY_SITELIBDIR}
post-install:
- @${MKDIR} ${PREFIX}/share/doc/migemo
- @${MV} ${PREFIX}/share/migemo/migemo.ja.html ${PREFIX}/share/doc/migemo
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} -p ${DOCSDIR}
+ @${MV} ${PREFIX}/share/migemo/migemo.ja.html ${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/migemo/distinfo b/japanese/migemo/distinfo
index 6355fdb5c6a1..ca069677f28f 100644
--- a/japanese/migemo/distinfo
+++ b/japanese/migemo/distinfo
@@ -1 +1 @@
-MD5 (migemo-0.3.tar.gz) = e16e0bccaae5a79b41770584f10efb84
+MD5 (migemo-0.32.tar.gz) = 937b0cd743b79e6bcdd45b8eb8ba8ba8
diff --git a/japanese/migemo/files/extra-patch-Makefile.am b/japanese/migemo/files/extra-patch-Makefile.am
new file mode 100644
index 000000000000..d2ab2a06707e
--- /dev/null
+++ b/japanese/migemo/files/extra-patch-Makefile.am
@@ -0,0 +1,19 @@
+--- Makefile.am.orig Mon Sep 17 18:40:23 2001
++++ Makefile.am Mon Sep 17 18:41:59 2001
+@@ -1,6 +1,5 @@
+ SUBDIRS = tests
+ bin_SCRIPTS = migemo migemo-grep migemo-server migemo-client
+-lisp_LISP = migemo.el
+ ruby_DATA = migemo.rb migemo-dict.rb migemo-regex.rb\
+ migemo-convert.rb migemo-index.rb migemo-cache.rb
+ pkgdata_DATA = migemo-dict migemo-dict.idx\
+@@ -9,9 +8,6 @@
+ migemo.ja.rd migemo.ja.html
+ EXTRA_DIST = $(bin_SCRIPTS) $(ruby_DATA) migemo.el.in \
+ genchars.sh ngram.sh frequent-chars $(pkgdata_DATA)
+-
+-migemo.el: migemo.el.in
+- sed -e 's!@pkgdatadir@!$(pkgdatadir)!g' migemo.el.in > $@
+
+ migemo-dict: # SKK-JISYO.L
+ ruby -I. migemo-convert.rb SKK-JISYO.L > $@
diff --git a/japanese/migemo/files/extra-patch-configure.in b/japanese/migemo/files/extra-patch-configure.in
new file mode 100644
index 000000000000..3168966dbc43
--- /dev/null
+++ b/japanese/migemo/files/extra-patch-configure.in
@@ -0,0 +1,10 @@
+--- configure.in.orig Mon Sep 17 18:33:52 2001
++++ configure.in Mon Sep 17 18:35:03 2001
+@@ -6,7 +6,6 @@
+ AC_MSG_ERROR(ruby not found)
+ fi
+
+-AM_PATH_LISPDIR
+ AM_PATH_RUBYDIR
+
+ echo -n "checking Ruby/Bsearch... "
diff --git a/japanese/migemo/files/patch-Makefile.am b/japanese/migemo/files/patch-Makefile.am
deleted file mode 100644
index 440a8846d15b..000000000000
--- a/japanese/migemo/files/patch-Makefile.am
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.am.orig Sat Jul 14 14:58:55 2001
-+++ Makefile.am Sat Jul 14 14:59:44 2001
-@@ -47,7 +47,3 @@
- tar zxf ruby-bsearch.tar.gz
- cp ruby-bsearch/bsearch.rb .
- rm -rf ruby-bsearch
--
--migemo.ja.html: migemo.ja.rd
-- rd2 migemo.ja.rd > migemo.ja.html
--
diff --git a/japanese/migemo/files/patch-migemo-cache.rb b/japanese/migemo/files/patch-migemo-cache.rb
deleted file mode 100644
index 46a7c94584f0..000000000000
--- a/japanese/migemo/files/patch-migemo-cache.rb
+++ /dev/null
@@ -1,11 +0,0 @@
---- migemo-cache.rb.orig Sat Jul 14 14:51:42 2001
-+++ migemo-cache.rb Sat Jul 14 14:51:58 2001
-@@ -16,7 +16,7 @@
- next if pattern == ""
-
- migemo = Migemo.new(static_dict, pattern)
-- migemo.optimize = 3
-+ migemo.optimization = 3
- data = Marshal.dump(migemo.regex_tree)
- output = [pattern.length].pack("N") + pattern +
- [data.length].pack("N") + data
diff --git a/japanese/migemo/pkg-comment b/japanese/migemo/pkg-comment
index b1f77f7440f2..dfd8b192d930 100644
--- a/japanese/migemo/pkg-comment
+++ b/japanese/migemo/pkg-comment
@@ -1 +1 @@
-Japanese incremental search tool for emacs20
+Japanese incremental search tool
diff --git a/japanese/migemo/pkg-descr b/japanese/migemo/pkg-descr
index a62fc3603cc2..61ad9df770fc 100644
--- a/japanese/migemo/pkg-descr
+++ b/japanese/migemo/pkg-descr
@@ -1,9 +1,5 @@
-Migemo is a Japanese incremental search tool for Emacs.
-You can search Japanese words on Emacs without Kanji conversion.
-
-To use Migemo, you must set following elisp to your own .emacs file.
-
-(load-library "migemo")
+Migemo is a Japanese incremental search tool.
+You can search a text for Japanese words without having to input kanji.
WWW: http://migemo.namazu.org/
diff --git a/japanese/migemo/pkg-plist b/japanese/migemo/pkg-plist
index b97057b208ec..14f576bf9bd2 100644
--- a/japanese/migemo/pkg-plist
+++ b/japanese/migemo/pkg-plist
@@ -1,16 +1,21 @@
-%%EMACS_LIBDIR%%/site-lisp/migemo.el
-%%EMACS_LIBDIR%%/site-lisp/migemo.elc
-%%RUBY_SITELIBDIR%%/migemo.rb
-%%RUBY_SITELIBDIR%%/migemo-cache.rb
-%%RUBY_SITELIBDIR%%/migemo-convert.rb
-%%RUBY_SITELIBDIR%%/migemo-dict.rb
-%%RUBY_SITELIBDIR%%/migemo-index.rb
-share/doc/migemo/migemo.ja.html
-@dirrm share/doc/migemo
-share/migemo/migemo-dict
-share/migemo/migemo-dict.idx
-share/migemo/migemo-dict.cache
-share/migemo/migemo-dict.cache.idx
-share/migemo/user-dict.sample
-share/migemo/regex-dict.sample
-@dirrm share/migemo
+%%MIGEMO%%bin/migemo
+%%MIGEMO%%bin/migemo-grep
+%%MIGEMO%%bin/migemo-server
+%%MIGEMO%%bin/migemo-client
+%%MIGEMO%%%%RUBY_SITELIBDIR%%/migemo.rb
+%%MIGEMO%%%%RUBY_SITELIBDIR%%/migemo-cache.rb
+%%MIGEMO%%%%RUBY_SITELIBDIR%%/migemo-convert.rb
+%%MIGEMO%%%%RUBY_SITELIBDIR%%/migemo-dict.rb
+%%MIGEMO%%%%RUBY_SITELIBDIR%%/migemo-index.rb
+%%ELISP%%%%EMACS_LIBDIR%%/site-lisp/migemo.el
+%%ELISP%%%%EMACS_LIBDIR%%/site-lisp/migemo.elc
+%%MIGEMO%%share/doc/migemo/migemo.ja.html
+%%MIGEMO%%@dirrm share/doc/migemo
+%%MIGEMO%%share/migemo/migemo-dict
+%%MIGEMO%%share/migemo/migemo-dict.idx
+%%MIGEMO%%share/migemo/migemo-dict.cache
+%%MIGEMO%%share/migemo/migemo-dict.cache.idx
+%%MIGEMO%%share/migemo/migemo.ja.rd
+%%MIGEMO%%share/migemo/user-dict.sample
+%%MIGEMO%%share/migemo/regex-dict.sample
+%%MIGEMO%%@dirrm share/migemo