aboutsummaryrefslogtreecommitdiff
path: root/japanese/mime_pls/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2005-12-19 03:22:16 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2005-12-19 03:22:16 +0000
commit1814b4fda0e837b95913189cbfaba2c8a35bc02b (patch)
tree05c367fbec4028a95d198a83705b505c29560f3c /japanese/mime_pls/Makefile
parent4cbbfd5f1031e98c01163f47c9e258a43c96c778 (diff)
downloadports-1814b4fda0e837b95913189cbfaba2c8a35bc02b.tar.gz
ports-1814b4fda0e837b95913189cbfaba2c8a35bc02b.zip
Notes
Diffstat (limited to 'japanese/mime_pls/Makefile')
-rw-r--r--japanese/mime_pls/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/japanese/mime_pls/Makefile b/japanese/mime_pls/Makefile
new file mode 100644
index 000000000000..9455fd18ebff
--- /dev/null
+++ b/japanese/mime_pls/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: mime_pls
+# Date created: 2005/12/19
+# Whom: n-shigemura@ensure.jp
+#
+# $FreeBSD$
+#
+
+PORTNAME= mime_pls
+PORTVERSION= 2.02
+CATEGORIES= japanese perl5 mail
+MASTER_SITES= http://www.cc.rim.or.jp/~ikuta/mime_pls/
+PKGNAMEPREFIX= ja-p5-
+DISTNAME= ${PORTNAME}${PORTVERSION:C/\.//}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= Perl Library for MIME encode/decode
+
+USE_PERL5= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+BINS= rmime wmime rbody wbody
+LIBS= mimer.pl mimew.pl
+PLIST_FILES= ${BINS:C,^,bin/,} ${LIBS:C,^,${SITE_PERL_REL}/,}
+
+do-install:
+ @${INSTALL_SCRIPT} ${BINS:C,^,${WRKSRC}/,} ${PREFIX}/bin
+ @${INSTALL_DATA} ${LIBS:C,^,${WRKSRC}/,} ${SITE_PERL}
+
+.include <bsd.port.mk>