aboutsummaryrefslogtreecommitdiff
path: root/japanese/mozc-server/Makefile
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2012-09-07 03:28:18 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2012-09-07 03:28:18 +0000
commit66dcdf29bf6a22a09d25ad5ec6319428cfffa6f1 (patch)
treef8083401476b570aa964a741c3e00d2276c0f058 /japanese/mozc-server/Makefile
parentf00b6afb0c190ebdf0c9007e1a0980c3292392ff (diff)
downloadports-66dcdf29bf6a22a09d25ad5ec6319428cfffa6f1.tar.gz
ports-66dcdf29bf6a22a09d25ad5ec6319428cfffa6f1.zip
Notes
Diffstat (limited to 'japanese/mozc-server/Makefile')
-rw-r--r--japanese/mozc-server/Makefile68
1 files changed, 6 insertions, 62 deletions
diff --git a/japanese/mozc-server/Makefile b/japanese/mozc-server/Makefile
index afe1316cc00e..736e0d2e4c6e 100644
--- a/japanese/mozc-server/Makefile
+++ b/japanese/mozc-server/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= mozc
-PORTVERSION= 1.5.1090.102
-PORTREVISION= 7
+PORTVERSION= 1.6.1187.102
CATEGORIES= japanese
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX?= ja-
PKGNAMESUFFIX?= -server
MAINTAINER= daichi@FreeBSD.org
-COMMENT?= Mozc server for IBus, SCIM, and others
+COMMENT?= Mozc server for IBus and others
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
gtest.0:${PORTSDIR}/devel/googletest \
@@ -32,9 +31,8 @@ BUILD_MOZC_LIST?= mozc_server
.if ${BUILD_MOZC_LIST:Mmozc_tool} == "mozc_tool"
USE_QT4+= gui dbus qmake_build moc_build uic_build rcc_build
-.elif ${BUILD_MOZC_LIST:Mibus_mozc} == "ibus_mozc" || \
- ${BUILD_MOZC_LIST:Mscim_mozc} == "scim_mozc"
-USE_GNOME+= pygtk2
+.elif ${BUILD_MOZC_LIST:Mibus_mozc} == "ibus_mozc"
+USE_GNOME+= glib20 gtk20 pygtk2
.elif ${BUILD_MOZC_LIST:Mfcitx_mozc} == "fcitx_mozc"
USE_GNOME+= glib20 gtk20
.elif ${BUILD_MOZC_LIST:Mmozc_el} == "mozc_el"
@@ -62,8 +60,6 @@ LOCALBASE_REPLACE_FILES= \
unix/ibus/gen_mozc_xml.py \
unix/ibus/mozc.xml \
unix/ibus/path_util.cc \
- unix/scim/scim.gyp \
- unix/scim/scim_mozc.cc \
base/util.cc \
base/process.cc \
gui/about_dialog/about_dialog.cc \
@@ -73,13 +69,7 @@ SSL_REINPLACE_STR=
SSL_REINPLACE_STR+= -e "s,%%${V}%%,${${V}},"
.endfor
-.if ${BUILD_MOZC_LIST:Mmozc_server} == "mozc_server" || \
- ${BUILD_MOZC_LIST:Mmozc_tool} == "mozc_tool" || \
- ${BUILD_MOZC_LIST:Mmozc_el} == "mozc_el"
-GYP_DEFINES="use_libprotobuf=1 enable_gtk_renderer=0"
-.else
GYP_DEFINES="use_libprotobuf=1"
-.endif
BUILD_CMD= ${SETENV} ${MAKE_ENV} ${GMAKE}
BUILD_MOZC_CMD= cd ${BUILD_WRKSRC} && \
@@ -154,7 +144,8 @@ do-install-mozc_tool:
# ibus_mozc
.if ${BUILD_MOZC_LIST:Mibus_mozc} == "ibus_mozc"
-LIB_DEPENDS+= ibus-1.0.401:${PORTSDIR}/textproc/ibus
+LIB_DEPENDS+= ibus-1.0.401:${PORTSDIR}/textproc/ibus \
+ xcb-xfixes.0:${PORTSDIR}/x11/libxcb
RUN_DEPENDS+= mozc_server:${PORTSDIR}/japanese/mozc-server \
mozc_tool:${PORTSDIR}/japanese/mozc-tool \
mozc_server_start:${PORTSDIR}/japanese/mozc-additions \
@@ -196,53 +187,6 @@ do-install-ibus_mozc:
${DATADIR}/icons/product_logo.png
.endif
-# scim_mozc
-.if ${BUILD_MOZC_LIST:Mscim_mozc} == "scim_mozc"
-BUILD_DEPENDS+= scim:${PORTSDIR}/textproc/scim
-RUN_DEPENDS+= scim:${PORTSDIR}/textproc/scim \
- mozc_server:${PORTSDIR}/japanese/mozc-server \
- mozc_tool:${PORTSDIR}/japanese/mozc-tool \
- mozc_server_start:${PORTSDIR}/japanese/mozc-additions \
- ${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/_pynotify.so:${PORTSDIR}/devel/py-notify
-
-PLIST_FILES+= lib/scim-1.0/1.4.0/IMEngine/mozc.so \
- lib/scim-1.0/1.4.0/SetupUI/mozc_setup.so \
- ${DATADIR_REL}/icons/scim-mozc-alpha_full.png \
- ${DATADIR_REL}/icons/scim-mozc-alpha_half.png \
- ${DATADIR_REL}/icons/scim-mozc-dictionary.png \
- ${DATADIR_REL}/icons/scim-mozc-direct.png \
- ${DATADIR_REL}/icons/scim-mozc-hiragana.png \
- ${DATADIR_REL}/icons/scim-mozc-katakana_full.png \
- ${DATADIR_REL}/icons/scim-mozc-katakana_half.png \
- ${DATADIR_REL}/icons/scim-mozc-properties.png \
- ${DATADIR_REL}/icons/scim-mozc-tool.png \
- ${DATADIR_REL}/icons/scim-mozc.png
-PLIST_DIRS+= ${DATADIR_REL}/icons ${DATADIR_REL}
-
-do-build-scim_mozc:
- ${BUILD_MOZC_CMD} build -c ${BUILD_MODE} \
- unix/scim/scim.gyp:scim_mozc \
- unix/scim/scim.gyp:scim_mozc_setup
-
-do-install-scim_mozc:
- ${INSTALL_LIB} \
- ${WRKSRC}/out_linux/${BUILD_MODE}/lib.target/libscim_mozc.so \
- ${PREFIX}/lib/scim-1.0/1.4.0/IMEngine/mozc.so
- ${INSTALL_LIB} \
- ${WRKSRC}/out_linux/${BUILD_MODE}/lib.target/libscim_mozc_setup.so \
- ${PREFIX}/lib/scim-1.0/1.4.0/SetupUI/mozc_setup.so
- @${MKDIR} ${DATADIR}/icons
-.for F in ui-alpha_full ui-alpha_half ui-dictionary ui-direct \
- ui-hiragana ui-katakana_full ui-katakana_half ui-properties ui-tool
- @${INSTALL_DATA} \
- ${WRKSRC}/data/images/unix/${F}.png \
- ${DATADIR}/icons/${F:S/^ui-/scim-mozc-/}.png
-.endfor
- @${INSTALL_DATA} \
- ${WRKSRC}/data/images/unix/ime_product_icon_opensource-32.png \
- ${DATADIR}/icons/scim-mozc.png
-.endif
-
# fcitx_mozc
.if ${BUILD_MOZC_LIST:Mfcitx_mozc} == "fcitx_mozc"
PATCH_SITES= http://fcitx.googlecode.com/files/