aboutsummaryrefslogtreecommitdiff
path: root/japanese/mozc-server
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2012-01-07 04:49:16 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2012-01-07 04:49:16 +0000
commitb706405e3a6b34bb044ea52afedd86ccfcc7a06f (patch)
tree4a8a49360d832134138739093d0d7001b939bed8 /japanese/mozc-server
parentc2e6cf2d7cd8c9f9b75ef478530f850c1825aec6 (diff)
downloadports-b706405e3a6b34bb044ea52afedd86ccfcc7a06f.tar.gz
ports-b706405e3a6b34bb044ea52afedd86ccfcc7a06f.zip
Notes
Diffstat (limited to 'japanese/mozc-server')
-rw-r--r--japanese/mozc-server/Makefile4
-rw-r--r--japanese/mozc-server/files/patch-unix_ibus_mozc_engine.cc11
2 files changed, 14 insertions, 1 deletions
diff --git a/japanese/mozc-server/Makefile b/japanese/mozc-server/Makefile
index ae11ac9d4c91..e5416aef43ff 100644
--- a/japanese/mozc-server/Makefile
+++ b/japanese/mozc-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mozc
PORTVERSION= 1.3.931.102
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= japanese
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX?= ja-
@@ -132,6 +132,8 @@ do-install-mozc_tool:
# ibus_mozc
.if ${BUILD_MOZC_LIST:Mibus_mozc} == "ibus_mozc"
LIB_DEPENDS+= ibus.2:${PORTSDIR}/textproc/ibus
+# after ibus updated to 1.4.0, use below instead.
+#LIB_DEPENDS+= ibus-1.0.400:${PORTSDIR}/textproc/ibus
RUN_DEPENDS+= mozc_server:${PORTSDIR}/japanese/mozc-server \
mozc_tool:${PORTSDIR}/japanese/mozc-tool \
mozc_server_start:${PORTSDIR}/japanese/mozc-additions \
diff --git a/japanese/mozc-server/files/patch-unix_ibus_mozc_engine.cc b/japanese/mozc-server/files/patch-unix_ibus_mozc_engine.cc
new file mode 100644
index 000000000000..c269c5b95f71
--- /dev/null
+++ b/japanese/mozc-server/files/patch-unix_ibus_mozc_engine.cc
@@ -0,0 +1,11 @@
+--- unix/ibus/mozc_engine.cc.orig 2011-12-24 13:17:12.915092360 +0900
++++ unix/ibus/mozc_engine.cc 2012-01-07 13:40:28.811283808 +0900
+@@ -1187,7 +1187,7 @@
+
+ string selection_text;
+ const uint32 selection_start = min(cursor_pos, anchor_pos);
+- const uint32 selection_length = abs(cursor_pos - anchor_pos);
++ const uint32 selection_length = ::abs(cursor_pos - anchor_pos);
+ Util::SubString(surrounding_text,
+ selection_start,
+ selection_length,