aboutsummaryrefslogtreecommitdiff
path: root/japanese/mozc-server
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2012-03-16 04:22:16 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2012-03-16 04:22:16 +0000
commit5c0d726ca97107100caa8ffcb358e75265950a54 (patch)
tree1e3890367f33c8875fece8587da11e4d97f3eb62 /japanese/mozc-server
parentbb2cf24072805d33ff1b0ca17bb6d562206e0a00 (diff)
downloadports-5c0d726ca97107100caa8ffcb358e75265950a54.tar.gz
ports-5c0d726ca97107100caa8ffcb358e75265950a54.zip
Notes
Diffstat (limited to 'japanese/mozc-server')
-rw-r--r--japanese/mozc-server/Makefile6
-rw-r--r--japanese/mozc-server/distinfo4
-rw-r--r--japanese/mozc-server/files/patch-base_iconv.cc6
-rw-r--r--japanese/mozc-server/files/patch-base_logging.cc2
-rw-r--r--japanese/mozc-server/files/patch-base_mutex.h2
-rw-r--r--japanese/mozc-server/files/patch-base_process.cc2
-rw-r--r--japanese/mozc-server/files/patch-base_util.cc17
-rw-r--r--japanese/mozc-server/files/patch-build_mozc.py4
-rw-r--r--japanese/mozc-server/files/patch-build_tools_mozc_version.py2
-rw-r--r--japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc2
-rw-r--r--japanese/mozc-server/files/patch-gyp_common.gypi8
-rw-r--r--japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc2
-rw-r--r--japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc4
-rw-r--r--japanese/mozc-server/files/patch-ipc_unix_ipc.cc2
-rw-r--r--japanese/mozc-server/files/patch-server_mozc_server.cc2
-rw-r--r--japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_common.py2
-rw-r--r--japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_generator_make.py2
-rw-r--r--japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py2
-rw-r--r--japanese/mozc-server/files/patch-unix_ibus_mozc_engine.cc28
-rw-r--r--japanese/mozc-server/files/patch-unix_ibus_path_util.cc2
-rw-r--r--japanese/mozc-server/files/patch-unix_scim_scim.gyp4
21 files changed, 53 insertions, 52 deletions
diff --git a/japanese/mozc-server/Makefile b/japanese/mozc-server/Makefile
index 0b12ba51fcb2..82d3b9bb7456 100644
--- a/japanese/mozc-server/Makefile
+++ b/japanese/mozc-server/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mozc
-PORTVERSION= 1.3.975.102
-PORTREVISION?= 0
+PORTVERSION= 1.4.1003.102
CATEGORIES= japanese
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX?= ja-
@@ -73,6 +72,7 @@ BUILD_CMD= ${SETENV} ${MAKE_ENV} ${GMAKE}
BUILD_MOZC_CMD= cd ${BUILD_WRKSRC} && \
${SETENV} BUILD_COMMAND="${WRKSRC}/mozcmake" \
PYTHONPATH=${WRKSRC}/third_party/gyp/local/lib/python${PYTHON_VER}/site-packages \
+ MOZC_SERVER_DIRECTORY="${PREFIX}/bin" GYP_DEFINES="use_libprotobuf=1" \
${PYTHON_CMD} build_mozc.py
BUILD_GYP_CMD= cd ${WRKSRC}/third_party/gyp && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP}
@@ -87,7 +87,7 @@ pre-build:
${BUILD_GYP_CMD} ${PYDISTUTILS_CONFIGURE_TARGET} ${PYDISTUTILS_CONFIGUREARGS}
${BUILD_GYP_CMD} ${PYDISTUTILS_BUILD_TARGET} ${PYDISTUTILS_BUILDARGS}
${BUILD_GYP_CMD} ${PYDISTUTILS_INSTALL_TARGET} --prefix=${WRKSRC}/third_party/gyp/local
- ${BUILD_MOZC_CMD} gyp --gypdir=${WRKSRC}/third_party/gyp/local/bin
+ ${BUILD_MOZC_CMD} gyp --gypdir=${WRKSRC}/third_party/gyp/local/bin --channel_dev=0
${BUILD_MOZC_CMD} build_tools -c ${BUILD_MODE}
# mozc_server
diff --git a/japanese/mozc-server/distinfo b/japanese/mozc-server/distinfo
index 78b6bf77bc9c..aea8e2aeaf9f 100644
--- a/japanese/mozc-server/distinfo
+++ b/japanese/mozc-server/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mozc-1.3.975.102.tar.bz2) = 1ee57425c159bc0066645f086472f72aa16567fe5be272f35339c41e9a52d27a
-SIZE (mozc-1.3.975.102.tar.bz2) = 55961505
+SHA256 (mozc-1.4.1003.102.tar.bz2) = 11948514ef05e9a1c1184af33dfef143d50dafa425b7f01631f8858c158f40ba
+SIZE (mozc-1.4.1003.102.tar.bz2) = 55626457
diff --git a/japanese/mozc-server/files/patch-base_iconv.cc b/japanese/mozc-server/files/patch-base_iconv.cc
index 703c7a1ed994..460088a58f18 100644
--- a/japanese/mozc-server/files/patch-base_iconv.cc
+++ b/japanese/mozc-server/files/patch-base_iconv.cc
@@ -1,5 +1,5 @@
---- base/iconv.cc.orig 2012-01-29 13:42:31.196806922 +0900
-+++ base/iconv.cc 2012-01-29 13:49:21.142806483 +0900
+--- base/iconv.cc.orig 2012-03-16 10:48:02.102712152 +0900
++++ base/iconv.cc 2012-03-16 10:59:56.300711667 +0900
@@ -52,7 +52,11 @@
size_t olen_org = olen;
iconv(ic, 0, &ilen, 0, &olen); // reset iconv state
@@ -10,5 +10,5 @@
if (iconv(ic, reinterpret_cast<char **>(&ibuf), &ilen, &obuf, &olen)
+#endif
== static_cast<size_t>(-1)) {
- return;
+ return false;
}
diff --git a/japanese/mozc-server/files/patch-base_logging.cc b/japanese/mozc-server/files/patch-base_logging.cc
index 6b3cbbec55ce..5908641f2a25 100644
--- a/japanese/mozc-server/files/patch-base_logging.cc
+++ b/japanese/mozc-server/files/patch-base_logging.cc
@@ -1,4 +1,4 @@
---- base/logging.cc.orig 2012-01-29 13:42:31.194805201 +0900
+--- base/logging.cc.orig 2012-03-16 10:48:02.103712883 +0900
+++ base/logging.cc 2012-01-29 13:49:21.256805888 +0900
@@ -212,7 +212,7 @@
char buf[512];
diff --git a/japanese/mozc-server/files/patch-base_mutex.h b/japanese/mozc-server/files/patch-base_mutex.h
index 605f8a2cb6d6..26a7dcf6940e 100644
--- a/japanese/mozc-server/files/patch-base_mutex.h
+++ b/japanese/mozc-server/files/patch-base_mutex.h
@@ -1,4 +1,4 @@
---- base/mutex.h.orig 2012-01-29 13:42:31.195806306 +0900
+--- base/mutex.h.orig 2012-03-16 10:48:02.113712658 +0900
+++ base/mutex.h 2012-01-29 13:49:20.902806916 +0900
@@ -82,11 +82,11 @@
// PTHREAD_MUTEX_RECURSIVE_NP and PTHREAD_MUTEX_RECURSIVE seem to be
diff --git a/japanese/mozc-server/files/patch-base_process.cc b/japanese/mozc-server/files/patch-base_process.cc
index 9b65593fa83f..b31258c5dcc2 100644
--- a/japanese/mozc-server/files/patch-base_process.cc
+++ b/japanese/mozc-server/files/patch-base_process.cc
@@ -1,4 +1,4 @@
---- base/process.cc.orig 2012-01-29 13:42:31.198806477 +0900
+--- base/process.cc.orig 2012-03-16 10:48:02.109712053 +0900
+++ base/process.cc 2012-01-29 13:49:21.340806019 +0900
@@ -120,13 +120,18 @@
return ShellExecuteInSystemDir(L"open", wurl.c_str(), NULL, SW_SHOW);
diff --git a/japanese/mozc-server/files/patch-base_util.cc b/japanese/mozc-server/files/patch-base_util.cc
deleted file mode 100644
index d3efc90019fd..000000000000
--- a/japanese/mozc-server/files/patch-base_util.cc
+++ /dev/null
@@ -1,17 +0,0 @@
---- base/util.cc.orig 2012-01-29 13:42:31.192806902 +0900
-+++ base/util.cc 2012-01-29 13:49:21.226806684 +0900
-@@ -2636,9 +2636,13 @@
- return MacUtil::GetServerDirectory();
- #endif // OS_MACOSX
-
--#ifdef OS_LINUX
-+#if defined(OS_LINUX) && !defined(__FreeBSD__)
- return "/usr/lib/mozc";
- #endif // OS_LINUX
-+
-+#ifdef __FreeBSD__
-+ return "@@LOCALBASE@@/bin";
-+#endif
- }
-
- string Util::GetDocumentDirectory() {
diff --git a/japanese/mozc-server/files/patch-build_mozc.py b/japanese/mozc-server/files/patch-build_mozc.py
index 710f7dc10cd7..76c6dae0a186 100644
--- a/japanese/mozc-server/files/patch-build_mozc.py
+++ b/japanese/mozc-server/files/patch-build_mozc.py
@@ -1,5 +1,5 @@
---- build_mozc.py.orig 2012-01-29 13:42:31.525804671 +0900
-+++ build_mozc.py 2012-01-29 13:49:21.572805896 +0900
+--- build_mozc.py.orig 2012-03-16 10:48:09.087711537 +0900
++++ build_mozc.py 2012-03-16 10:59:56.396715771 +0900
@@ -70,7 +70,7 @@
def IsLinux():
diff --git a/japanese/mozc-server/files/patch-build_tools_mozc_version.py b/japanese/mozc-server/files/patch-build_tools_mozc_version.py
index 7c16c38901aa..d134a061cd78 100644
--- a/japanese/mozc-server/files/patch-build_tools_mozc_version.py
+++ b/japanese/mozc-server/files/patch-build_tools_mozc_version.py
@@ -1,4 +1,4 @@
---- build_tools/mozc_version.py.orig 2012-01-29 13:42:31.190807067 +0900
+--- build_tools/mozc_version.py.orig 2012-03-16 10:48:02.096712071 +0900
+++ build_tools/mozc_version.py 2012-01-29 13:49:15.791805587 +0900
@@ -56,7 +56,7 @@
diff --git a/japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc b/japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc
index ae4e6dd7f5ed..2422ce538340 100644
--- a/japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc
+++ b/japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc
@@ -1,4 +1,4 @@
---- gui/about_dialog/about_dialog.cc.orig 2012-01-29 13:42:31.223806652 +0900
+--- gui/about_dialog/about_dialog.cc.orig 2012-03-16 10:48:02.153986629 +0900
+++ gui/about_dialog/about_dialog.cc 2012-01-29 13:49:18.542805785 +0900
@@ -119,7 +119,11 @@
SetLabelText(label_terms);
diff --git a/japanese/mozc-server/files/patch-gyp_common.gypi b/japanese/mozc-server/files/patch-gyp_common.gypi
index 43171c5fc118..90d9aadb91e3 100644
--- a/japanese/mozc-server/files/patch-gyp_common.gypi
+++ b/japanese/mozc-server/files/patch-gyp_common.gypi
@@ -1,6 +1,6 @@
---- gyp/common.gypi.orig 2012-01-29 13:42:31.215806054 +0900
-+++ gyp/common.gypi 2012-01-29 13:49:19.328805472 +0900
-@@ -50,7 +50,7 @@
+--- gyp/common.gypi.orig 2012-03-16 10:48:02.138711974 +0900
++++ gyp/common.gypi 2012-03-16 10:59:55.917712287 +0900
+@@ -43,7 +43,7 @@
# warning_cflags will be shared with Mac and Linux.
'warning_cflags': [
'-Wall',
@@ -9,7 +9,7 @@
'-Wno-char-subscripts',
'-Wno-sign-compare',
'-Wno-deprecated-declarations',
-@@ -568,6 +568,12 @@
+@@ -593,6 +593,12 @@
# <unordered_map> and <unordered_set>.
'-Wno-deprecated',
],
diff --git a/japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc b/japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc
index fedb027c5e48..dce0ecbc15c6 100644
--- a/japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc
+++ b/japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc
@@ -1,4 +1,4 @@
---- handwriting/zinnia_handwriting.cc.orig 2012-01-29 13:42:31.214806556 +0900
+--- handwriting/zinnia_handwriting.cc.orig 2012-03-16 10:48:02.136714319 +0900
+++ handwriting/zinnia_handwriting.cc 2012-01-29 13:49:21.926806405 +0900
@@ -49,10 +49,16 @@
const char kModelFile[] = "handwriting-light-ja.model";
diff --git a/japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc b/japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc
index a79988adc47a..33b6abed74df 100644
--- a/japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc
+++ b/japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc
@@ -1,5 +1,5 @@
---- ipc/ipc_path_manager.cc.orig 2012-01-29 13:42:31.212806790 +0900
-+++ ipc/ipc_path_manager.cc 2012-01-29 13:49:21.426806055 +0900
+--- ipc/ipc_path_manager.cc.orig 2012-03-16 10:48:02.136714319 +0900
++++ ipc/ipc_path_manager.cc 2012-03-16 10:59:56.379712949 +0900
@@ -274,7 +274,7 @@
*ipc_name = kIPCPrefix;
#endif // OS_WINDOWS
diff --git a/japanese/mozc-server/files/patch-ipc_unix_ipc.cc b/japanese/mozc-server/files/patch-ipc_unix_ipc.cc
index 57ef3a7cfe7c..077783871915 100644
--- a/japanese/mozc-server/files/patch-ipc_unix_ipc.cc
+++ b/japanese/mozc-server/files/patch-ipc_unix_ipc.cc
@@ -1,4 +1,4 @@
---- ipc/unix_ipc.cc.orig 2012-01-29 13:42:31.213805520 +0900
+--- ipc/unix_ipc.cc.orig 2012-03-16 10:48:02.134842636 +0900
+++ ipc/unix_ipc.cc 2012-01-29 13:49:21.405805900 +0900
@@ -41,7 +41,7 @@
#include <sys/time.h>
diff --git a/japanese/mozc-server/files/patch-server_mozc_server.cc b/japanese/mozc-server/files/patch-server_mozc_server.cc
index 5fbca69c1175..b048b501cc65 100644
--- a/japanese/mozc-server/files/patch-server_mozc_server.cc
+++ b/japanese/mozc-server/files/patch-server_mozc_server.cc
@@ -1,4 +1,4 @@
---- server/mozc_server.cc.orig 2012-01-29 13:42:31.175805998 +0900
+--- server/mozc_server.cc.orig 2012-03-16 10:48:02.074712300 +0900
+++ server/mozc_server.cc 2012-01-29 13:49:16.896805385 +0900
@@ -32,6 +32,9 @@
#ifdef OS_WINDOWS
diff --git a/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_common.py b/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_common.py
index d853fc0f9398..a833bfeb1555 100644
--- a/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_common.py
+++ b/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_common.py
@@ -1,4 +1,4 @@
---- third_party/gyp/pylib/gyp/common.py.orig 2012-01-29 13:42:31.158806631 +0900
+--- third_party/gyp/pylib/gyp/common.py.orig 2012-03-16 10:48:02.041717236 +0900
+++ third_party/gyp/pylib/gyp/common.py 2012-01-30 15:35:06.300889252 +0900
@@ -351,8 +351,10 @@
flavors = {
diff --git a/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_generator_make.py b/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_generator_make.py
index 90314d2ddba3..8ed8b3f6e8b4 100644
--- a/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_generator_make.py
+++ b/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_generator_make.py
@@ -1,4 +1,4 @@
---- third_party/gyp/pylib/gyp/generator/make.py.orig 2012-01-29 13:42:31.157805247 +0900
+--- third_party/gyp/pylib/gyp/generator/make.py.orig 2012-03-16 10:48:02.039723886 +0900
+++ third_party/gyp/pylib/gyp/generator/make.py 2012-01-30 15:37:51.791889791 +0900
@@ -1998,6 +1998,9 @@
srcdir_prefix = '$(srcdir)/'
diff --git a/japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py b/japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py
index 781b0e2ae7cb..775fd05bba72 100644
--- a/japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py
+++ b/japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py
@@ -1,4 +1,4 @@
---- unix/ibus/gen_mozc_xml.py.orig 2012-01-29 13:42:31.153806065 +0900
+--- unix/ibus/gen_mozc_xml.py.orig 2012-03-16 10:48:02.015738213 +0900
+++ unix/ibus/gen_mozc_xml.py 2012-01-29 13:49:15.972806246 +0900
@@ -39,6 +39,7 @@
diff --git a/japanese/mozc-server/files/patch-unix_ibus_mozc_engine.cc b/japanese/mozc-server/files/patch-unix_ibus_mozc_engine.cc
index fe065be5702e..52d6c7aa590b 100644
--- a/japanese/mozc-server/files/patch-unix_ibus_mozc_engine.cc
+++ b/japanese/mozc-server/files/patch-unix_ibus_mozc_engine.cc
@@ -1,11 +1,29 @@
---- unix/ibus/mozc_engine.cc.orig 2012-01-29 13:42:31.155805132 +0900
-+++ unix/ibus/mozc_engine.cc 2012-01-29 13:49:15.880806284 +0900
-@@ -1205,7 +1205,7 @@
+--- unix/ibus/mozc_engine.cc.orig 2012-03-16 10:48:02.015738213 +0900
++++ unix/ibus/mozc_engine.cc 2012-03-16 12:46:11.976711448 +0900
+@@ -192,14 +192,14 @@
+ COMPILE_ASSERT(sizeof(int64) > sizeof(guint), int64_guint_check);
+ const int64 kInt32AbsMax =
+- abs(static_cast<int64>(numeric_limits<int32>::max()));
++ ::abs(static_cast<int64>(numeric_limits<int32>::max()));
+ const int64 kInt32AbsMin =
+- abs(static_cast<int64>(numeric_limits<int32>::min()));
++ ::abs(static_cast<int64>(numeric_limits<int32>::min()));
+ const int64 kInt32SafeAbsMax =
+ min(kInt32AbsMax, kInt32AbsMin);
+
+ const int64 diff = static_cast<int64>(from) - static_cast<int64>(to);
+- if (abs(diff) > kInt32SafeAbsMax) {
++ if (::abs(diff) > kInt32SafeAbsMax) {
+ return false;
+ }
+
+@@ -1360,7 +1360,7 @@
+ // on size_t, not uint32.
string selection_text;
const uint32 selection_start = min(cursor_pos, anchor_pos);
-- const uint32 selection_length = abs(cursor_pos - anchor_pos);
-+ const uint32 selection_length = ::abs(cursor_pos - anchor_pos);
+- const uint32 selection_length = abs(relative_selected_length);
++ const uint32 selection_length = ::abs(relative_selected_length);
Util::SubString(surrounding_text,
selection_start,
selection_length,
diff --git a/japanese/mozc-server/files/patch-unix_ibus_path_util.cc b/japanese/mozc-server/files/patch-unix_ibus_path_util.cc
index dfbb43af30ae..5c287fe450ab 100644
--- a/japanese/mozc-server/files/patch-unix_ibus_path_util.cc
+++ b/japanese/mozc-server/files/patch-unix_ibus_path_util.cc
@@ -1,4 +1,4 @@
---- unix/ibus/path_util.cc.orig 2012-01-29 13:42:31.154805704 +0900
+--- unix/ibus/path_util.cc.orig 2012-03-16 10:48:02.017713438 +0900
+++ unix/ibus/path_util.cc 2012-01-29 13:49:15.994806248 +0900
@@ -30,14 +30,22 @@
#include "unix/ibus/path_util.h"
diff --git a/japanese/mozc-server/files/patch-unix_scim_scim.gyp b/japanese/mozc-server/files/patch-unix_scim_scim.gyp
index 30a12ae216bb..84a090e15566 100644
--- a/japanese/mozc-server/files/patch-unix_scim_scim.gyp
+++ b/japanese/mozc-server/files/patch-unix_scim_scim.gyp
@@ -1,5 +1,5 @@
---- unix/scim/scim.gyp.orig 2012-01-29 13:42:31.153806065 +0900
-+++ unix/scim/scim.gyp 2012-01-29 13:49:16.076805497 +0900
+--- unix/scim/scim.gyp.orig 2012-03-16 10:48:02.019712085 +0900
++++ unix/scim/scim.gyp 2012-03-16 10:59:20.258715241 +0900
@@ -39,7 +39,7 @@
'gtk+-2.0',
],