aboutsummaryrefslogtreecommitdiff
path: root/japanese/mozc-server
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2011-12-24 14:15:31 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2011-12-24 14:15:31 +0000
commitdaa6d8547710c24984fe3f283e9d40b807f433a6 (patch)
treef7e600befa6ec05906bbdb8ebad1281c765abdfd /japanese/mozc-server
parent51d187e026f5bd53ab53bb68d2cf38d6b8ce9cb5 (diff)
downloadports-daa6d8547710c24984fe3f283e9d40b807f433a6.tar.gz
ports-daa6d8547710c24984fe3f283e9d40b807f433a6.zip
Notes
Diffstat (limited to 'japanese/mozc-server')
-rw-r--r--japanese/mozc-server/Makefile36
-rw-r--r--japanese/mozc-server/distinfo4
-rw-r--r--japanese/mozc-server/files/patch-base_iconv.cc2
-rw-r--r--japanese/mozc-server/files/patch-base_logging.cc2
-rw-r--r--japanese/mozc-server/files/patch-base_mutex.h2
-rw-r--r--japanese/mozc-server/files/patch-base_process.cc2
-rw-r--r--japanese/mozc-server/files/patch-base_util.cc6
-rw-r--r--japanese/mozc-server/files/patch-build_mozc.py4
-rw-r--r--japanese/mozc-server/files/patch-build_tools_mozc_version.py2
-rw-r--r--japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc2
-rw-r--r--japanese/mozc-server/files/patch-gyp_common.gypi6
-rw-r--r--japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc2
-rw-r--r--japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc2
-rw-r--r--japanese/mozc-server/files/patch-ipc_unix_ipc.cc2
-rw-r--r--japanese/mozc-server/files/patch-server_mozc_server.cc2
-rw-r--r--japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py2
-rw-r--r--japanese/mozc-server/files/patch-unix_ibus_path_util.cc2
-rw-r--r--japanese/mozc-server/files/patch-unix_scim_scim.gyp2
18 files changed, 57 insertions, 25 deletions
diff --git a/japanese/mozc-server/Makefile b/japanese/mozc-server/Makefile
index 64442fb80e6b..6d774d3fb328 100644
--- a/japanese/mozc-server/Makefile
+++ b/japanese/mozc-server/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= mozc
-PORTVERSION= 1.3.911.102
-PORTREVISION= 1
+PORTVERSION= 1.3.931.102
+PORTREVISION= 0
CATEGORIES= japanese
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX?= ja-
@@ -36,6 +36,9 @@ QT_COMPONENTS= gui dbus qmake_build moc_build uic_build rcc_build
.if ${BUILD_MOZC_LIST:Mibus_mozc} == "ibus_mozc" || ${BUILD_MOZC_LIST:Mscim_mozc} == "scim_mozc"
USE_GNOME= pygtk2
.endif
+.if ${BUILD_MOZC_LIST:Mmozc-el} == "mozc-el"
+USE_EMACS= yes
+.endif
.include <bsd.port.pre.mk>
@@ -217,6 +220,35 @@ do-install-scim_mozc:
${DATADIR}/icons/scim-mozc.png
.endif
+# mozc-el
+.if ${BUILD_MOZC_LIST:Mmozc-el} == "mozc-el"
+CATEGORIES+= editors elisp
+RUN_DEPENDS+= mozc_server:${PORTSDIR}/japanese/mozc-server \
+ mozc_server_start:${PORTSDIR}/japanese/mozc-additions
+
+PLIST_FILES+= bin/mozc_emacs_helper \
+ ${EMACS_VERSION_SITE_LISPDIR}/mozc.el \
+ ${EMACS_VERSION_SITE_LISPDIR}/mozc.elc
+
+do-build-mozc-el:
+ ${BUILD_MOZC_CMD} build -c ${BUILD_MODE} \
+ unix/emacs/emacs.gyp:mozc_emacs_helper
+ @cd ${WRKSRC}/unix/emacs && \
+ ${EMACS_CMD} -batch -q -no-site-file -no-init-file \
+ -f batch-byte-compile mozc.el
+
+do-install-mozc-el:
+ @${INSTALL_PROGRAM} \
+ ${WRKSRC}/out_linux/${BUILD_MODE}/mozc_emacs_helper \
+ ${PREFIX}/bin/
+ @${INSTALL_DATA} \
+ ${WRKSRC}/unix/emacs/mozc.el \
+ ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/
+ @${INSTALL_DATA} \
+ ${WRKSRC}/unix/emacs/mozc.elc \
+ ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/
+.endif
+
do-build: ${BUILD_MOZC_LIST:S/^/do-build-/}
do-install: ${BUILD_MOZC_LIST:S/^/do-install-/}
diff --git a/japanese/mozc-server/distinfo b/japanese/mozc-server/distinfo
index 3c6903f8ca22..cf6e7ac12852 100644
--- a/japanese/mozc-server/distinfo
+++ b/japanese/mozc-server/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mozc-1.3.911.102.tar.bz2) = da27945d6732e4fc70c08534cc8d10cd23d6fba5ebc52e6b31cac5d04ba1588a
-SIZE (mozc-1.3.911.102.tar.bz2) = 39180652
+SHA256 (mozc-1.3.931.102.tar.bz2) = f56a899e1e445e01d0f28fec45a7b3cc3dd9c68e0d6507bca00a8c01ef68c7a0
+SIZE (mozc-1.3.931.102.tar.bz2) = 55891776
diff --git a/japanese/mozc-server/files/patch-base_iconv.cc b/japanese/mozc-server/files/patch-base_iconv.cc
index a51ccec8e65b..18723f92dcf2 100644
--- a/japanese/mozc-server/files/patch-base_iconv.cc
+++ b/japanese/mozc-server/files/patch-base_iconv.cc
@@ -1,4 +1,4 @@
---- base/iconv.cc.orig 2011-12-04 16:22:26.109606820 +0900
+--- base/iconv.cc.orig 2011-12-24 13:17:13.100092268 +0900
+++ base/iconv.cc 2011-12-04 16:46:50.884607344 +0900
@@ -52,7 +52,11 @@
size_t olen_org = olen;
diff --git a/japanese/mozc-server/files/patch-base_logging.cc b/japanese/mozc-server/files/patch-base_logging.cc
index 69d7783587ff..5980226c95b1 100644
--- a/japanese/mozc-server/files/patch-base_logging.cc
+++ b/japanese/mozc-server/files/patch-base_logging.cc
@@ -1,4 +1,4 @@
---- base/logging.cc.orig 2011-12-04 16:22:26.116610643 +0900
+--- base/logging.cc.orig 2011-12-24 13:17:13.094097336 +0900
+++ base/logging.cc 2011-12-04 19:57:28.052770432 +0900
@@ -212,7 +212,7 @@
char buf[512];
diff --git a/japanese/mozc-server/files/patch-base_mutex.h b/japanese/mozc-server/files/patch-base_mutex.h
index 8d52c97c3594..10b5c7bcb181 100644
--- a/japanese/mozc-server/files/patch-base_mutex.h
+++ b/japanese/mozc-server/files/patch-base_mutex.h
@@ -1,4 +1,4 @@
---- base/mutex.h.orig 2011-12-04 16:22:26.106606369 +0900
+--- base/mutex.h.orig 2011-12-24 13:17:13.096092253 +0900
+++ base/mutex.h 2011-12-04 16:46:50.658605855 +0900
@@ -82,11 +82,11 @@
// PTHREAD_MUTEX_RECURSIVE_NP and PTHREAD_MUTEX_RECURSIVE seem to be
diff --git a/japanese/mozc-server/files/patch-base_process.cc b/japanese/mozc-server/files/patch-base_process.cc
index 0bdaff0a1847..e17ea24326cc 100644
--- a/japanese/mozc-server/files/patch-base_process.cc
+++ b/japanese/mozc-server/files/patch-base_process.cc
@@ -1,4 +1,4 @@
---- base/process.cc.orig 2011-12-04 16:22:26.103607664 +0900
+--- base/process.cc.orig 2011-12-24 13:17:13.098092385 +0900
+++ base/process.cc 2011-12-04 16:46:51.045606717 +0900
@@ -120,13 +120,18 @@
return ShellExecuteInSystemDir(L"open", wurl.c_str(), NULL, SW_SHOW);
diff --git a/japanese/mozc-server/files/patch-base_util.cc b/japanese/mozc-server/files/patch-base_util.cc
index 5e7abf37af9c..92bd49aaa1db 100644
--- a/japanese/mozc-server/files/patch-base_util.cc
+++ b/japanese/mozc-server/files/patch-base_util.cc
@@ -1,6 +1,6 @@
---- base/util.cc.orig 2011-12-04 16:22:26.112610903 +0900
-+++ base/util.cc 2011-12-04 16:46:50.958606064 +0900
-@@ -2592,9 +2592,13 @@
+--- base/util.cc.orig 2011-12-24 13:17:13.099092285 +0900
++++ base/util.cc 2011-12-24 13:35:51.531092368 +0900
+@@ -2636,9 +2636,13 @@
return MacUtil::GetServerDirectory();
#endif // OS_MACOSX
diff --git a/japanese/mozc-server/files/patch-build_mozc.py b/japanese/mozc-server/files/patch-build_mozc.py
index cf77ec55146c..07c4f7d094f6 100644
--- a/japanese/mozc-server/files/patch-build_mozc.py
+++ b/japanese/mozc-server/files/patch-build_mozc.py
@@ -1,5 +1,5 @@
---- build_mozc.py.orig 2011-12-04 16:22:26.517605881 +0900
-+++ build_mozc.py 2011-12-04 16:46:51.189606024 +0900
+--- build_mozc.py.orig 2011-12-24 13:17:28.363092915 +0900
++++ build_mozc.py 2011-12-24 13:35:51.596092253 +0900
@@ -70,7 +70,7 @@
def IsLinux():
diff --git a/japanese/mozc-server/files/patch-build_tools_mozc_version.py b/japanese/mozc-server/files/patch-build_tools_mozc_version.py
index c2d3263872f4..717c313d062d 100644
--- a/japanese/mozc-server/files/patch-build_tools_mozc_version.py
+++ b/japanese/mozc-server/files/patch-build_tools_mozc_version.py
@@ -1,4 +1,4 @@
---- build_tools/mozc_version.py.orig 2011-12-04 16:22:26.211608471 +0900
+--- build_tools/mozc_version.py.orig 2011-12-24 13:17:12.978092858 +0900
+++ build_tools/mozc_version.py 2011-12-04 16:35:15.156605950 +0900
@@ -56,7 +56,7 @@
diff --git a/japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc b/japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc
index 30454a4930ef..61d7b3479164 100644
--- a/japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc
+++ b/japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc
@@ -1,4 +1,4 @@
---- gui/about_dialog/about_dialog.cc.orig 2011-12-04 16:22:26.291606976 +0900
+--- gui/about_dialog/about_dialog.cc.orig 2011-12-24 13:17:13.116092657 +0900
+++ gui/about_dialog/about_dialog.cc 2011-12-04 16:44:21.340606780 +0900
@@ -119,7 +119,11 @@
SetLabelText(label_terms);
diff --git a/japanese/mozc-server/files/patch-gyp_common.gypi b/japanese/mozc-server/files/patch-gyp_common.gypi
index da7dbe9a1783..de7a25545243 100644
--- a/japanese/mozc-server/files/patch-gyp_common.gypi
+++ b/japanese/mozc-server/files/patch-gyp_common.gypi
@@ -1,5 +1,5 @@
---- gyp/common.gypi.orig 2011-12-04 16:22:26.257607334 +0900
-+++ gyp/common.gypi 2011-12-12 22:34:30.005072813 +0900
+--- gyp/common.gypi.orig 2011-12-24 13:17:13.115092509 +0900
++++ gyp/common.gypi 2011-12-24 13:35:51.371092696 +0900
@@ -50,7 +50,7 @@
# warning_cflags will be shared with Mac and Linux.
'warning_cflags': [
@@ -9,7 +9,7 @@
'-Wno-char-subscripts',
'-Wno-sign-compare',
'-Wno-deprecated-declarations',
-@@ -512,6 +512,12 @@
+@@ -528,6 +528,12 @@
# <unordered_map> and <unordered_set>.
'-Wno-deprecated',
],
diff --git a/japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc b/japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc
index 672a5e0afd1c..e8b155f6b6eb 100644
--- a/japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc
+++ b/japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc
@@ -1,4 +1,4 @@
---- handwriting/zinnia_handwriting.cc.orig 2011-12-04 22:26:40.226138013 +0900
+--- handwriting/zinnia_handwriting.cc.orig 2011-12-24 13:17:13.115092509 +0900
+++ handwriting/zinnia_handwriting.cc 2011-12-04 22:27:01.145136587 +0900
@@ -49,10 +49,16 @@
const char kModelFile[] = "handwriting-light-ja.model";
diff --git a/japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc b/japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc
index 2221123cc15f..0e0767d63a66 100644
--- a/japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc
+++ b/japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc
@@ -1,4 +1,4 @@
---- ipc/ipc_path_manager.cc.orig 2011-12-04 16:22:26.515606954 +0900
+--- ipc/ipc_path_manager.cc.orig 2011-12-24 13:17:13.114092857 +0900
+++ ipc/ipc_path_manager.cc 2011-12-04 16:46:51.134605388 +0900
@@ -274,7 +274,7 @@
*ipc_name = kIPCPrefix;
diff --git a/japanese/mozc-server/files/patch-ipc_unix_ipc.cc b/japanese/mozc-server/files/patch-ipc_unix_ipc.cc
index 48407580903a..96a7c3d244dd 100644
--- a/japanese/mozc-server/files/patch-ipc_unix_ipc.cc
+++ b/japanese/mozc-server/files/patch-ipc_unix_ipc.cc
@@ -1,4 +1,4 @@
---- ipc/unix_ipc.cc.orig 2011-12-04 16:22:26.515606954 +0900
+--- ipc/unix_ipc.cc.orig 2011-12-24 13:17:13.113092874 +0900
+++ ipc/unix_ipc.cc 2011-12-04 16:46:51.120605285 +0900
@@ -41,7 +41,7 @@
#include <sys/time.h>
diff --git a/japanese/mozc-server/files/patch-server_mozc_server.cc b/japanese/mozc-server/files/patch-server_mozc_server.cc
index a5465a103c38..e8c4f170f124 100644
--- a/japanese/mozc-server/files/patch-server_mozc_server.cc
+++ b/japanese/mozc-server/files/patch-server_mozc_server.cc
@@ -1,4 +1,4 @@
---- server/mozc_server.cc.orig 2011-12-04 16:22:26.174607330 +0900
+--- server/mozc_server.cc.orig 2011-12-24 13:17:12.964092352 +0900
+++ server/mozc_server.cc 2011-12-04 16:43:55.914606129 +0900
@@ -32,6 +32,9 @@
#ifdef OS_WINDOWS
diff --git a/japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py b/japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py
index dab9c8e72334..9df474261e88 100644
--- a/japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py
+++ b/japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py
@@ -1,4 +1,4 @@
---- unix/ibus/gen_mozc_xml.py.orig 2011-12-04 16:22:26.122609031 +0900
+--- unix/ibus/gen_mozc_xml.py.orig 2011-12-24 13:17:12.914092543 +0900
+++ unix/ibus/gen_mozc_xml.py 2011-12-04 16:35:15.333604982 +0900
@@ -39,6 +39,7 @@
diff --git a/japanese/mozc-server/files/patch-unix_ibus_path_util.cc b/japanese/mozc-server/files/patch-unix_ibus_path_util.cc
index fc83f75e8883..190cc3b1d1cf 100644
--- a/japanese/mozc-server/files/patch-unix_ibus_path_util.cc
+++ b/japanese/mozc-server/files/patch-unix_ibus_path_util.cc
@@ -1,4 +1,4 @@
---- unix/ibus/path_util.cc.orig 2011-12-04 16:22:26.124607888 +0900
+--- unix/ibus/path_util.cc.orig 2011-12-24 13:17:12.914092543 +0900
+++ unix/ibus/path_util.cc 2011-12-04 16:35:15.354607302 +0900
@@ -30,14 +30,22 @@
#include "unix/ibus/path_util.h"
diff --git a/japanese/mozc-server/files/patch-unix_scim_scim.gyp b/japanese/mozc-server/files/patch-unix_scim_scim.gyp
index 566e9d8bb1dd..efcac56f8f25 100644
--- a/japanese/mozc-server/files/patch-unix_scim_scim.gyp
+++ b/japanese/mozc-server/files/patch-unix_scim_scim.gyp
@@ -1,4 +1,4 @@
---- unix/scim/scim.gyp.orig 2011-12-04 16:22:26.127609806 +0900
+--- unix/scim/scim.gyp.orig 2011-12-24 13:17:12.916092674 +0900
+++ unix/scim/scim.gyp 2011-12-04 16:39:02.023609368 +0900
@@ -39,7 +39,7 @@
'gtk+-2.0',