aboutsummaryrefslogtreecommitdiff
path: root/japanese/onew
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-15 18:18:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-15 18:18:28 +0000
commit7804df1d4d98787d1c64a62c1b8d3541eb6e6336 (patch)
tree6a6ff35f139c673609a8e6a41b92a95cf2e9d937 /japanese/onew
parentc5347d62d6b8c5475cb3b97bec2cd6bb1b90029d (diff)
downloadports-7804df1d4d98787d1c64a62c1b8d3541eb6e6336.tar.gz
ports-7804df1d4d98787d1c64a62c1b8d3541eb6e6336.zip
Notes
Diffstat (limited to 'japanese/onew')
-rw-r--r--japanese/onew/Makefile4
-rw-r--r--japanese/onew/files/patch-gcc4250
2 files changed, 50 insertions, 4 deletions
diff --git a/japanese/onew/Makefile b/japanese/onew/Makefile
index 307238f4064f..d069458e4e11 100644
--- a/japanese/onew/Makefile
+++ b/japanese/onew/Makefile
@@ -61,10 +61,6 @@ PORT_DOCDIR= ${LOCALBASE}/share/doc/ja-onew${INPUT_METHOD}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
${SED} -e 's,%LOCALBASE%,${LOCALBASE},g' \
-e 's,%X11BASE%,${X11BASE},g' \
diff --git a/japanese/onew/files/patch-gcc42 b/japanese/onew/files/patch-gcc42
new file mode 100644
index 000000000000..689f21801f51
--- /dev/null
+++ b/japanese/onew/files/patch-gcc42
@@ -0,0 +1,50 @@
+--- engine.orig/Canna.c 1995-06-28 11:13:26.000000000 -0500
++++ engine/Canna.c 2007-11-12 21:30:29.000000000 -0500
+@@ -33,6 +33,7 @@
+ static int ready;
+ static int CID;
+ static int nbunsetsu;
++static disp_kanji_buf();
+ int ONEW_CannarcDone;
+
+ static ONEWkanakan_ready()
+@@ -102,7 +103,6 @@
+ int comch;
+ int rcode;
+ char yomibuf[1024];
+- static disp_kanji_buf();
+
+ Onew_setupYomistr(startch,yomi,yomibuf);
+ yomi = yomibuf;
+--- onewlib.c.orig 1995-07-02 02:55:41.000000000 -0500
++++ onewlib.c 2007-11-12 21:28:01.000000000 -0500
+@@ -50,6 +50,11 @@
+ int ONEW_I_SYNC_CHAR = 0xFF;
+ int ONEW_KK_OPDICT = 'x';
+
++static definedKanamode();
++static romkan_modesw();
++static thru_char1();
++static Onew_kakuteiInRomkan();
++
+ #define MODE_SWITCHER ONEW_MODE_SWITCHER
+ #define ZENKAKU_TOGGLE ONEW_ZENKAKU_TOGGLE
+ #define KANA_TOGGLE ONEW_KANA_TOGGLE
+@@ -116,9 +121,6 @@
+ }
+ ONEW_getch1(){
+ int ch;
+- static definedKanamode();
+- static romkan_modesw();
+- static thru_char1();
+
+ for(;;){
+ ch = ONEW_getch0(ONEW_getch_asis);
+@@ -313,7 +315,6 @@
+
+ kget_char1(){
+ unsigned int kc;
+- static Onew_kakuteiInRomkan();
+
+ if( !Onew_RK_init() ){
+ kc = OnewGetchar();