aboutsummaryrefslogtreecommitdiff
path: root/japanese/otojiro-fpw/Makefile
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2002-09-13 05:52:57 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2002-09-13 05:52:57 +0000
commit322031a4c5bab8a843ed915f1d88357ec9fddd3f (patch)
treed1595493959c2e75cfa7cbfa4414cab5c748f53e /japanese/otojiro-fpw/Makefile
parent5408006015d38680131c1f34735acf5d03685f41 (diff)
New port: OTOJIRO English - Japanese Dictionary (EPWING V1 format)
Notes
Notes: svn path=/head/; revision=66232
Diffstat (limited to 'japanese/otojiro-fpw/Makefile')
-rw-r--r--japanese/otojiro-fpw/Makefile67
1 files changed, 67 insertions, 0 deletions
diff --git a/japanese/otojiro-fpw/Makefile b/japanese/otojiro-fpw/Makefile
new file mode 100644
index 000000000000..9a2ed784cd8c
--- /dev/null
+++ b/japanese/otojiro-fpw/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: OTOJIRO Dictionary - JIS X 4081 version
+# Date created: 2002.9.9
+# Whom: Satoshi Taoka <taoka@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= otojiro-fpw
+PORTVERSION= 1.0.a
+CATEGORIES= japanese
+MASTER_SITES= http://openlab.ring.gr.jp/edict/fpw/dist/eijiro/ \
+ http://member.nifty.ne.jp/~satomii/freepwing/archive/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.a/a/}-src
+
+MAINTAINER= taoka@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/share/doc/freepwing/fpwutils.mk:${PORTSDIR}/japanese/freepwing \
+ nkf:${PORTSDIR}/japanese/nkf \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+
+RESTRICTED= "The original dictionary is not free"
+NO_PACKAGE= "The original dictionary is not free"
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/otojiro-fpw${PORTVERSION:S/.a/a/}
+DICT_PATH?= /cdrom
+SRCFILE?= otojiro.txt
+MAKE_ENV= OTOJIRO_FILE=${DICT_PATH}/${SRCFILE}
+
+pre-extract::
+ @if [ ! -f ${DICT_PATH}/${SRCFILE} ]; then \
+ ${ECHO} "###################################################"; \
+ ${ECHO} "I cannot find a file ${DICT_PATH}/${SRCFILE}"; \
+ ${ECHO} "Specify the Otojiro Dictionary file with the full path"; \
+ ${ECHO} "and excecute the following command again:"; \
+ ${ECHO} " make DICT_PATH=${DICT_PATH} SRCFILE=${SRCFILE}"; \
+ ${ECHO} ""; \
+ ${ECHO} "Notice: DICT_PATH must be a full path to the file."; \
+ ${ECHO} "###################################################"; \
+ ${FALSE}; \
+ fi
+
+post-build:
+## To delete CR after NL
+ cd ${WRKSRC}; ${MV} catalogs.txt catalogs.txt.org; \
+ nkf -sSd catalogs.txt.org > catalogs.txt; \
+ fpwmake catalogs
+
+do-build:
+ cd ${WRKSRC}; ${ENV} ${MAKE_ENV} fpwmake
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/dict/otojiro-fpw/otojiro/data
+ ${MKDIR} ${PREFIX}/share/dict/otojiro-fpw/otojiro/gaiji
+ ${INSTALL_DATA} ${WRKSRC}/honmon ${PREFIX}/share/dict/otojiro-fpw/otojiro/data
+# ${INSTALL_DATA} ${WRKSRC}/gai16f \
+# ${PREFIX}/share/dict/otojiro-fpw/otojiro/gaiji
+ ${INSTALL_DATA} ${WRKSRC}/gai16h \
+ ${PREFIX}/share/dict/otojiro-fpw/otojiro/gaiji
+ ${INSTALL_DATA} ${WRKSRC}/catalogs ${PREFIX}/share/dict/otojiro-fpw
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/otojiro-fpw
+.for i in readme.txt COPYING
+ ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/doc/otojiro-fpw
+.endfor
+.endif
+
+.include <bsd.port.mk>