aboutsummaryrefslogtreecommitdiff
path: root/japanese/p5-Mail-SpamAssassin
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-01-13 12:13:44 +0000
committerWen Heping <wen@FreeBSD.org>2010-01-13 12:13:44 +0000
commit95227d393cf51271d7b12dc3d674e15edda0219b (patch)
treed985f857ee6dff400b31d3e45caa10e0f3ca5a50 /japanese/p5-Mail-SpamAssassin
parentb5cafe76ce298195a50a6dca0dbb6e23732cd1b9 (diff)
downloadports-95227d393cf51271d7b12dc3d674e15edda0219b.tar.gz
ports-95227d393cf51271d7b12dc3d674e15edda0219b.zip
Notes
Diffstat (limited to 'japanese/p5-Mail-SpamAssassin')
-rw-r--r--japanese/p5-Mail-SpamAssassin/Makefile12
-rw-r--r--japanese/p5-Mail-SpamAssassin/files/patch-spamassassin.raw12
-rw-r--r--japanese/p5-Mail-SpamAssassin/pkg-install2
3 files changed, 21 insertions, 5 deletions
diff --git a/japanese/p5-Mail-SpamAssassin/Makefile b/japanese/p5-Mail-SpamAssassin/Makefile
index 71c2ec32f44b..efc66a26278f 100644
--- a/japanese/p5-Mail-SpamAssassin/Makefile
+++ b/japanese/p5-Mail-SpamAssassin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Mail-SpamAssassin
PORTVERSION= 3.2.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= japanese mail perl5
MASTER_SITES= ${MASTER_SITE_APACHE:S/$/:apache/} ${MASTER_SITE_PERL_CPAN:S/$/:cpan/} \
${PATCH_SITES}
@@ -62,6 +62,10 @@ OPTIONS= AS_ROOT "Run spamd as root (recommended)" on \
SPF_QUERY "Add SPF query support" off \
RELAY_COUNTRY "Relay country support" off
+.if !defined(WITHOUT_SSL)
+USE_OPENSSL= yes
+.endif
+
.include <bsd.port.pre.mk>
.if defined (WITH_SPAMC)
@@ -80,7 +84,6 @@ RUN_DEPENDS+= ${SITE_PERL}/Mail/SPF.pm:${PORTSDIR}/mail/p5-Mail-SPF
.if !defined(WITHOUT_SSL)
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
-USE_OPENSSL= yes
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
CONFIGURE_ARGS+= ENABLE_SSL=yes
@@ -107,7 +110,7 @@ RUN_DEPENDS+= razor-agents>=2.84:${PORTSDIR}/mail/razor-agents
.endif
.if defined(WITH_DKIM)
-RUN_DEPENDS+= p5-Mail-DKIM>=0.33:${PORTSDIR}/mail/p5-Mail-DKIM
+RUN_DEPENDS+= p5-Mail-DKIM>=0.34:${PORTSDIR}/mail/p5-Mail-DKIM
RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
RUN_DEPENDS+= p5-Crypt-OpenSSL-RSA>=0.24:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA
.endif
@@ -222,7 +225,8 @@ post-patch:
-e 's#B_CONFDIR)/v320.pre#B_CONFDIR)/v320.pre.sample#g' \
-e 's/require DBI/0/' \
${WRKSRC}/Makefile.PL
- @${REINPLACE_CMD} -e '/^CC =/d' ${WRKSRC}/spamc/Makefile.in
+ @${REINPLACE_CMD} -e '/^CC =/d; \
+ s|@SSLCFLAGS@|& $${CFLAGS}|g' ${WRKSRC}/spamc/Makefile.in
.if defined(WITH_RAZOR)
${REINPLACE_CMD} -e '/Razor2/s/^#loadplugin/loadplugin/' ${WRKSRC}/rules/v312.pre
diff --git a/japanese/p5-Mail-SpamAssassin/files/patch-spamassassin.raw b/japanese/p5-Mail-SpamAssassin/files/patch-spamassassin.raw
new file mode 100644
index 000000000000..c2300b8d4a04
--- /dev/null
+++ b/japanese/p5-Mail-SpamAssassin/files/patch-spamassassin.raw
@@ -0,0 +1,12 @@
+--- spamassassin.raw.orig 2009-05-14 20:48:01.000000000 -0500
++++ spamassassin.raw 2009-05-14 20:48:19.000000000 -0500
+@@ -530,7 +530,7 @@
+ $mail->finish(); # bug 5626: remove temp files etc.
+ $mail = undef;
+ }
+- exit 0;
++ exit 15;
+ }
+
+ # ---------------------------------------------------------------------------
+
diff --git a/japanese/p5-Mail-SpamAssassin/pkg-install b/japanese/p5-Mail-SpamAssassin/pkg-install
index ee783924a624..92b3dabfe6fa 100644
--- a/japanese/p5-Mail-SpamAssassin/pkg-install
+++ b/japanese/p5-Mail-SpamAssassin/pkg-install
@@ -39,7 +39,7 @@ if [ "$2" = "POST-INSTALL" ];then
fi
grep '^load.*Rule2XSBody' ${PKG_PREFIX}/etc/mail/spamassassin/v320.pre > /dev/null
if [ $? -eq 0 ];then
- if yesno "Do you with to compile rules with re2c (will take a long time)" "N";then
+ if yesno "Do you wish to compile rules with re2c (will take a long time)" "N";then
${PKG_PREFIX}/bin/sa-compile
fi
fi