aboutsummaryrefslogtreecommitdiff
path: root/japanese/p5-MeCab
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-04-23 08:19:23 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-04-23 08:19:23 +0000
commite7e14f405c4afe7d30feb1279442f2c921213a86 (patch)
treea0f28f636a692c3d3d6c661fbfac788358295f66 /japanese/p5-MeCab
parent3bc55d8076c240df5c1704b18ad51bff5450967b (diff)
downloadports-e7e14f405c4afe7d30feb1279442f2c921213a86.tar.gz
ports-e7e14f405c4afe7d30feb1279442f2c921213a86.zip
Notes
Diffstat (limited to 'japanese/p5-MeCab')
-rw-r--r--japanese/p5-MeCab/Makefile38
-rw-r--r--japanese/p5-MeCab/pkg-descr4
-rw-r--r--japanese/p5-MeCab/pkg-plist6
3 files changed, 48 insertions, 0 deletions
diff --git a/japanese/p5-MeCab/Makefile b/japanese/p5-MeCab/Makefile
new file mode 100644
index 000000000000..d45aa84748ff
--- /dev/null
+++ b/japanese/p5-MeCab/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-MeCab
+# Date created: 23 April 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MeCab
+PORTVERSION= ${MECAB_PORTVERSION}
+CATEGORIES= japanese textproc perl5
+MASTER_SITES= # none
+DISTFILES= # none
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= MeCab library module for Perl5
+
+EXTRACT_DEPENDS= ${NONEXISTENT}:${MECAB_PORTDIR}:patch
+LIB_DEPENDS= mecab.0:${MECAB_PORTDIR}
+
+PERL_CONFIGURE= yes
+
+.include "${.CURDIR}/../mecab/Makefile.common"
+
+.include <bsd.port.pre.mk>
+
+PKGNAMEPREFIX:= ${PKGNAMEPREFIX}p5-
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${LN} -fs `${MECAB_WRKSRC_CMD}`/perl ${WRKSRC}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/examples/mecab
+ ${INSTALL_DATA} ${WRKSRC}/test.pl ${PREFIX}/share/examples/mecab/
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/japanese/p5-MeCab/pkg-descr b/japanese/p5-MeCab/pkg-descr
new file mode 100644
index 000000000000..37428f238dfe
--- /dev/null
+++ b/japanese/p5-MeCab/pkg-descr
@@ -0,0 +1,4 @@
+This is the MeCab library module for Perl5.
+
+Author: Taku Kudoh <taku-ku@is.aist-nara.ac.jp>
+WWW: http://cl.aist-nara.ac.jp/~taku-ku/software/mecab/
diff --git a/japanese/p5-MeCab/pkg-plist b/japanese/p5-MeCab/pkg-plist
new file mode 100644
index 000000000000..362a722409e4
--- /dev/null
+++ b/japanese/p5-MeCab/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/MeCab.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/MeCab/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/MeCab/MeCab.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/MeCab/MeCab.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/MeCab
+%%PORTDOCS%%share/examples/mecab/test.pl