aboutsummaryrefslogtreecommitdiff
path: root/japanese/p5-Text-MeCab/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-06 20:24:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-06 20:24:10 +0000
commit07c185425d7716af435136e41cde5ddf2bce8126 (patch)
treeb61bd2c6faecb2181faeeef007411c861808579a /japanese/p5-Text-MeCab/Makefile
parent2d3e4190970d15cf70151643f3d924a58863f0f6 (diff)
downloadports-07c185425d7716af435136e41cde5ddf2bce8126.tar.gz
ports-07c185425d7716af435136e41cde5ddf2bce8126.zip
Notes
Diffstat (limited to 'japanese/p5-Text-MeCab/Makefile')
-rw-r--r--japanese/p5-Text-MeCab/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/japanese/p5-Text-MeCab/Makefile b/japanese/p5-Text-MeCab/Makefile
index eedd1ccf36e1..ea1e4ad1d35a 100644
--- a/japanese/p5-Text-MeCab/Makefile
+++ b/japanese/p5-Text-MeCab/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Text-MeCab
-PORTVERSION= 0.17
+PORTVERSION= 0.20004
CATEGORIES= japanese textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Text
@@ -17,25 +17,21 @@ COMMENT= Alternate Interface To libmecab
LIB_DEPENDS= mecab.1:${PORTSDIR}/japanese/mecab
MAN3= Text::MeCab.3 \
+ Text::MeCab::Dict.3 \
Text::MeCab::Node.3
PERL_CONFIGURE= yes
CONFIGURE_ARGS= </dev/null
-# dictionary encoding (euc-jp, shift_jis, utf8)
-ENCODING?= euc-jp
+# dictionary encoding (euc-jp, shift_jis, utf-8)
+ENCODING?= utf-8
post-patch:
-# To prevent CCFLAGS value from being overwritten by the ports system
- @${REINPLACE_CMD} -e 's|CCFLAGS|DEFINE|g' ${WRKSRC}/Makefile.PL
-
-.if ${ENCODING} == "shift_jis"
- @${REINPLACE_CMD} -e '/my \$$encoding = /s/euc-jp/shift_jis/' \
- ${WRKSRC}/tools/probe_mecab.pl
-.elif ${ENCODING} == "utf8"
- @${REINPLACE_CMD} -e '/my \$$encoding = /s/euc-jp/utf8/' \
+ @${REINPLACE_CMD} -e "/default_encoding = /s/utf-8/${ENCODING}/" \
${WRKSRC}/tools/probe_mecab.pl
-.endif
+
+ # To prevent CCFLAGS value from being overwritten by the ports system
+ @${REINPLACE_CMD} -e "s|CCFLAGS|INC|g" ${WRKSRC}/Makefile.PL
.include <bsd.port.pre.mk>