aboutsummaryrefslogtreecommitdiff
path: root/japanese/p5-Text-MeCab/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-31 03:23:19 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-31 03:23:19 +0000
commit4dc74a6a23ad94a91dc26a93563ced520a80f422 (patch)
treeca3fb9b383c48f621aba441a8ebb1a631481fbae /japanese/p5-Text-MeCab/Makefile
parent41215fdc2f89586e7fc14d72f018ef620693dfc7 (diff)
downloadports-4dc74a6a23ad94a91dc26a93563ced520a80f422.tar.gz
ports-4dc74a6a23ad94a91dc26a93563ced520a80f422.zip
Notes
Diffstat (limited to 'japanese/p5-Text-MeCab/Makefile')
-rw-r--r--japanese/p5-Text-MeCab/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/japanese/p5-Text-MeCab/Makefile b/japanese/p5-Text-MeCab/Makefile
new file mode 100644
index 000000000000..87da68aa54c9
--- /dev/null
+++ b/japanese/p5-Text-MeCab/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-TexT-MeCab
+# Date created: 30 July 2006
+# Whom: TAOKA Fumiyoshi <fmysh@iijmio-mail.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-MeCab
+PORTVERSION= 0.12
+CATEGORIES= japanese textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+
+MAINTAINER= fmysh@iijmio-mail.jp
+COMMENT= Alternate Interface To libmecab
+
+LIB_DEPENDS= mecab.1:${PORTSDIR}/japanese/mecab
+
+MAN3= Text::MeCab.3 \
+ Text::MeCab::Node.3
+
+PERL_CONFIGURE= yes
+
+post-patch:
+ # To prevent from overwriting CCFLAGS value by FreeBSD Ports system
+ @${REINPLACE_CMD} -e 's|CCFLAGS|DEFINE|g' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.pre.mk>
+
+PKGNAMEPREFIX:= ${PKGNAMEPREFIX}p5-
+
+.include <bsd.port.post.mk>