aboutsummaryrefslogtreecommitdiff
path: root/japanese/prime-el/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2005-05-10 15:39:17 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2005-05-10 15:39:17 +0000
commita02029fb82a9637087f7c584452282d77643dbb8 (patch)
tree19ea79fe730fa36e53e745f85ff22760cb69312b /japanese/prime-el/Makefile
parenteed3f4823b0dfca8ca6550dcd288a8336109746a (diff)
downloadports-a02029fb82a9637087f7c584452282d77643dbb8.tar.gz
ports-a02029fb82a9637087f7c584452282d77643dbb8.zip
Notes
Diffstat (limited to 'japanese/prime-el/Makefile')
-rw-r--r--japanese/prime-el/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/japanese/prime-el/Makefile b/japanese/prime-el/Makefile
new file mode 100644
index 000000000000..32c5162bf5f7
--- /dev/null
+++ b/japanese/prime-el/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: prime-el (for emacsen)
+# Date created: 16 Jun 2003
+# Whom: Gen Otsuji<otsuji@users.sourceforge.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= prime
+PORTVERSION= 1.5.1.3
+CATEGORIES= japanese
+MASTER_SITES= http://prime.sourceforge.jp/src/
+PKGNAMESUFFIX= -el
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
+
+MAINTAINER= otsuji@users.sourceforge.jp
+COMMENT= Emacs lisp set for the prime
+
+RUN_DEPENDS+= ${LOCALBASE}/share/emacs/site-lisp/init-mell.el:../mell \
+ ${LOCALBASE}/share/emacs/site-lisp/init-suikyo.el:../suikyo \
+ prime:../prime
+
+GNU_CONFIGURE= yes
+USE_AUTOMAKE_VER= 19
+USE_AUTOCONF_VER= 259
+
+pre-configure:
+ @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL})
+
+post-install:
+ cd ${WRKSRC}; ${MAKE} install-etc
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}/doc; ${MAKE} ${INSTALL_TARGET}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>