aboutsummaryrefslogtreecommitdiff
path: root/japanese/ptex
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /japanese/ptex
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'japanese/ptex')
-rw-r--r--japanese/ptex/Makefile6
-rw-r--r--japanese/ptex/files/patch-texk-pdftexdir-writepng.c19
-rw-r--r--japanese/ptex/files/patch-texk-web2c-pdftexdir-writeimg.c10
3 files changed, 32 insertions, 3 deletions
diff --git a/japanese/ptex/Makefile b/japanese/ptex/Makefile
index 967ab4f29b77..b35b50589c11 100644
--- a/japanese/ptex/Makefile
+++ b/japanese/ptex/Makefile
@@ -6,7 +6,7 @@
PORTNAME= ptex
PORTVERSION= 3.1.10
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= japanese print
MASTER_SITES= ${MASTER_SITE_TEX_CTAN} \
ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/tetex/:1 \
@@ -28,7 +28,7 @@ BUILD_DEPENDS= ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal \
RUN_DEPENDS= ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal \
${LOCALBASE}/${TEXMFDISTDIR}/LICENSE.texmf:${PORTSDIR}/print/teTeX-texmf \
mktexlsr:${PORTSDIR}/print/teTeX-base
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
wwwcore.1:${PORTSDIR}/www/libwww \
t1.5:${PORTSDIR}/devel/t1lib
@@ -120,7 +120,7 @@ pre-configure:
--with-system-wwwlib --with-libwww-libdir=${LIBWWW_PREFIX}/lib \
--with-libwww-include=${LIBWWW_PREFIX}/include/w3c-libwww \
--with-system-pnglib --with-pnglib-libdir=${LIBPNG_PREFIX}/lib \
- --with-pnglib-include=${LIBPNG_PREFIX}/include \
+ --with-pnglib-include=${LIBPNG_PREFIX}/include/libpng15 \
--with-system-t1lib --with-t1lib-libdir=${LIBT1_PREFIX}/lib \
--with-t1lib-include=${LIBT1_PREFIX}/include \
--without-xdvik --without-oxdvik \
diff --git a/japanese/ptex/files/patch-texk-pdftexdir-writepng.c b/japanese/ptex/files/patch-texk-pdftexdir-writepng.c
new file mode 100644
index 000000000000..1bc4ab625be7
--- /dev/null
+++ b/japanese/ptex/files/patch-texk-pdftexdir-writepng.c
@@ -0,0 +1,19 @@
+--- texk/web2c/pdftexdir/writepng.c.orig 2005-02-03 17:16:39.000000000 +0100
++++ texk/web2c/pdftexdir/writepng.c 2012-04-27 09:06:18.000000000 +0200
+@@ -22,6 +22,7 @@
+
+ #include "ptexlib.h"
+ #include "image.h"
++#include "pngpriv.h"
+
+ static const char perforce_id[] =
+ "$Id: //depot/Build/source.development/TeX/texk/web2c/pdftexdir/writepng.c#5 $";
+@@ -34,7 +35,7 @@
+ pdftex_fail("libpng: png_create_read_struct() failed");
+ if ((png_info(img) = png_create_info_struct(png_ptr(img))) == NULL)
+ pdftex_fail("libpng: png_create_info_struct() failed");
+- if (setjmp(png_ptr(img)->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr(img))))
+ pdftex_fail("libpng: internal error");
+ png_init_io(png_ptr(img), png_file);
+ png_read_info(png_ptr(img), png_info(img));
diff --git a/japanese/ptex/files/patch-texk-web2c-pdftexdir-writeimg.c b/japanese/ptex/files/patch-texk-web2c-pdftexdir-writeimg.c
new file mode 100644
index 000000000000..fa3b43fdc83e
--- /dev/null
+++ b/japanese/ptex/files/patch-texk-web2c-pdftexdir-writeimg.c
@@ -0,0 +1,10 @@
+--- texk/web2c/pdftexdir/writeimg.c.orig 2005-02-03 17:16:39.000000000 +0100
++++ texk/web2c/pdftexdir/writeimg.c 2012-04-27 09:30:39.000000000 +0200
+@@ -22,6 +22,7 @@
+
+ #include "ptexlib.h"
+ #include "image.h"
++#include "pngpriv.h"
+ #include <kpathsea/c-auto.h>
+ #include <kpathsea/c-memstr.h>
+