aboutsummaryrefslogtreecommitdiff
path: root/japanese/py-tegaki-gtk/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-05 10:24:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-05 10:24:37 +0000
commitea38f8656452de8035cec01a6e60e5ac3a97eb21 (patch)
tree4d41fa29c71c7f5ac76ba78470b864299a6aabf9 /japanese/py-tegaki-gtk/Makefile
parenta3ba7c6c9ebb6787d55b37e9d6e45696b479ae98 (diff)
downloadports-ea38f8656452de8035cec01a6e60e5ac3a97eb21.tar.gz
ports-ea38f8656452de8035cec01a6e60e5ac3a97eb21.zip
Notes
Diffstat (limited to 'japanese/py-tegaki-gtk/Makefile')
-rw-r--r--japanese/py-tegaki-gtk/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/japanese/py-tegaki-gtk/Makefile b/japanese/py-tegaki-gtk/Makefile
new file mode 100644
index 000000000000..890cb59fde15
--- /dev/null
+++ b/japanese/py-tegaki-gtk/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: py-tegaki-gtk
+
+# Date created: 15 Aug 2010
+# Whom: Timothy Beyer <beyert@cs.ucr.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tegaki
+PORTVERSION= 0.3.1
+CATEGORIES= japanese python
+MASTER_SITES= http://www.tegaki.org/releases/${PORTVERSION}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= -gtk
+DISTNAME= ${PORTNAME}-pygtk-${PORTVERSION}
+
+MAINTAINER= beyert@cs.ucr.edu
+COMMENT= Tegaki pygtk interface
+
+LIB_DEPENDS= zinnia.0:${PORTSDIR}/japanese/zinnia
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/tegaki/engine.py:${PORTSDIR}/japanese/py-tegaki
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= ${PORTNAME}_pygtk
+
+.include <bsd.port.mk>