aboutsummaryrefslogtreecommitdiff
path: root/japanese/ruby-usersguide/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-02-07 19:11:03 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-02-07 19:11:03 +0000
commit29e7b5e5c186e697671d7a6824e455f064bf972c (patch)
tree772794ff36b61d4866e1693d188c661345240941 /japanese/ruby-usersguide/Makefile
parent93277a0513f19bd80f3564cd9975b06486fd2dbc (diff)
Notes
Diffstat (limited to 'japanese/ruby-usersguide/Makefile')
-rw-r--r--japanese/ruby-usersguide/Makefile28
1 files changed, 18 insertions, 10 deletions
diff --git a/japanese/ruby-usersguide/Makefile b/japanese/ruby-usersguide/Makefile
index a597c126979f..ba42150681b2 100644
--- a/japanese/ruby-usersguide/Makefile
+++ b/japanese/ruby-usersguide/Makefile
@@ -5,21 +5,29 @@
# $FreeBSD$
#
-MASTERDIR= ${.CURDIR}/../../lang/ruby-usersguide
-
+PORTNAME= ruby-usersguide
+PORTVERSION= 980206
+CATEGORIES= japanese lang ruby
MASTER_SITES= ${MASTER_SITE_RUBY}
MASTER_SITE_SUBDIR= doc
-DISTNAME= ${SHORTNAME}-${VERSION}
-
-CATEGORIES= japanese
+DISTNAME= ${SHORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-VERSION= 980206
+USE_RUBY= yes
+RUBY_NO_BUILD_DEPENDS= yes
+RUBY_NO_RUN_DEPENDS= yes
+
+SHORTNAME= ${PORTNAME:S/usersguide/uguide/}
-MD5_FILE= ${.CURDIR}/distinfo
-PKGDIR= ${.CURDIR}
+WRKSRC= ${WRKDIR}/${SHORTNAME}
+NO_BUILD= yes
+DOCDIR= ${RUBY_DOCDIR}/${PORTNAME}-jp
-LANGSUFFIX= -jp
+do-install:
+ ${MKDIR} ${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/* ${DOCDIR}
+ ${LN} -fs uguide00.html ${DOCDIR}/index.html
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>