aboutsummaryrefslogtreecommitdiff
path: root/japanese/scim-anthy
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2005-03-02 11:40:06 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2005-03-02 11:40:06 +0000
commitcf267baf811c704d142e5766a30809b5f35daf67 (patch)
treea63c5719be0e938f39b5229db5abe323be398df5 /japanese/scim-anthy
parent31886f8b7899d2d8ef4cdfbc8a42c3811caaed44 (diff)
downloadports-cf267baf811c704d142e5766a30809b5f35daf67.tar.gz
ports-cf267baf811c704d142e5766a30809b5f35daf67.zip
Notes
Diffstat (limited to 'japanese/scim-anthy')
-rw-r--r--japanese/scim-anthy/Makefile48
-rw-r--r--japanese/scim-anthy/distinfo2
-rw-r--r--japanese/scim-anthy/pkg-descr3
-rw-r--r--japanese/scim-anthy/pkg-message11
-rw-r--r--japanese/scim-anthy/pkg-plist8
5 files changed, 72 insertions, 0 deletions
diff --git a/japanese/scim-anthy/Makefile b/japanese/scim-anthy/Makefile
new file mode 100644
index 000000000000..a7e907e107b0
--- /dev/null
+++ b/japanese/scim-anthy/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: ja-scim-anthy
+# Date created: 2 Mar 2005
+# Whom: Hajimu UMEMOTO <ume@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-anthy
+PORTVERSION= 0.3.1
+CATEGORIES= japanese
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
+MASTER_SITE_SUBDIR=scim-imengine/13188
+
+MAINTAINER= ume@FreeBSD.org
+COMMENT= SCIM IMEngine module using Anthy
+
+BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim
+LIB_DEPENDS= anthy.1:${PORTSDIR}/japanese/anthy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GNOME= lthack
+USE_X_PREFIX= yes
+USE_ICONV= yes
+USE_GMAKE= yes
+USE_LIBTOOL_VER=15
+
+CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
+ LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc ${PTHREAD_LIBS}"
+.else
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
+ @${ECHO} To display this message again, type \`pkg_info -D ${PKGNAME}\'
+ @${ECHO}
+
+.include <bsd.port.post.mk>
diff --git a/japanese/scim-anthy/distinfo b/japanese/scim-anthy/distinfo
new file mode 100644
index 000000000000..9af5e0217ac5
--- /dev/null
+++ b/japanese/scim-anthy/distinfo
@@ -0,0 +1,2 @@
+MD5 (scim-anthy-0.3.1.tar.gz) = 72b48b8f32d9bca1df93c5b3bfb02c91
+SIZE (scim-anthy-0.3.1.tar.gz) = 522662
diff --git a/japanese/scim-anthy/pkg-descr b/japanese/scim-anthy/pkg-descr
new file mode 100644
index 000000000000..1f5d9806df9a
--- /dev/null
+++ b/japanese/scim-anthy/pkg-descr
@@ -0,0 +1,3 @@
+scim-anthy is the SCIM IMEngine module using the Anthy input method.
+
+WWW: http://sourceforge.jp/projects/scim-imengine/
diff --git a/japanese/scim-anthy/pkg-message b/japanese/scim-anthy/pkg-message
new file mode 100644
index 000000000000..316515697de1
--- /dev/null
+++ b/japanese/scim-anthy/pkg-message
@@ -0,0 +1,11 @@
+--------------------------------------------------------------------
+Remember to set environment variables XMODIFIERS and LANG:
+
+ csh/tcsh: setenv XMODIFIERS @im=SCIM ; setenv LANG ja_JP.eucJP
+ sh/bash: export XMODIFIERS='@im=SCIM'; export LANG=ja_JP.eucJP
+
+To start the SCIM input method daemon, use command:
+
+ scim -d
+
+--------------------------------------------------------------------
diff --git a/japanese/scim-anthy/pkg-plist b/japanese/scim-anthy/pkg-plist
new file mode 100644
index 000000000000..74f2ec962eaa
--- /dev/null
+++ b/japanese/scim-anthy/pkg-plist
@@ -0,0 +1,8 @@
+lib/scim-1.0/IMEngine/anthy.so
+lib/scim-1.0/SetupUI/anthy-imengine-setup.so
+share/locale/ja/LC_MESSAGES/scim-anthy.mo
+share/scim/icons/scim-anthy.png
+share/scim/icons/scim-anthy-dict.png
+@unexec rmdir %D/lib/scim-1.0/IMEngine 2>/dev/null || true
+@unexec rmdir %D/lib/scim-1.0/SetupUI 2>/dev/null || true
+@unexec rmdir %D/lib/scim-1.0/icons 2>/dev/null || true