aboutsummaryrefslogtreecommitdiff
path: root/japanese/scim-honoka
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-03 23:41:56 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-03 23:41:56 +0000
commitb7718a26f7f65c4b4641cc467e464005ea5a8230 (patch)
treeb5f533dff98ecfa75bcf54f512ca67902498d956 /japanese/scim-honoka
parent21f9eace677f7fd18c8118e175961b300626b507 (diff)
downloadports-b7718a26f7f65c4b4641cc467e464005ea5a8230.tar.gz
ports-b7718a26f7f65c4b4641cc467e464005ea5a8230.zip
Notes
Diffstat (limited to 'japanese/scim-honoka')
-rw-r--r--japanese/scim-honoka/Makefile45
-rw-r--r--japanese/scim-honoka/distinfo3
-rw-r--r--japanese/scim-honoka/files/patch-configure10
-rw-r--r--japanese/scim-honoka/pkg-descr13
-rw-r--r--japanese/scim-honoka/pkg-message11
-rw-r--r--japanese/scim-honoka/pkg-plist28
6 files changed, 110 insertions, 0 deletions
diff --git a/japanese/scim-honoka/Makefile b/japanese/scim-honoka/Makefile
new file mode 100644
index 000000000000..8521d00cfaa5
--- /dev/null
+++ b/japanese/scim-honoka/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: ja-scim-honoka
+# Date created: 2 June 2006
+# Whom: Masashi CHIBA
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-honoka
+PORTVERSION= 0.9.0
+CATEGORIES= japanese
+MASTER_SITES= http://nop.net-p.org/files/honoka/
+DISTNAME= honoka-${PORTVERSION}
+
+MAINTAINER= chiba.masashi@gmail.com
+COMMENT= SCIM IMEngine module using various Imput Methods
+
+BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_LDCONFIG= yes
+USE_GETTEXT= yes
+USE_GNOME= lthack gnomehack
+USE_X_PREFIX= yes
+USE_ICONV= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+
+CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+IGNORE= does not build in FreeBSD < 5.x
+.else
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.post.mk>
diff --git a/japanese/scim-honoka/distinfo b/japanese/scim-honoka/distinfo
new file mode 100644
index 000000000000..63814bbbef94
--- /dev/null
+++ b/japanese/scim-honoka/distinfo
@@ -0,0 +1,3 @@
+MD5 (honoka-0.9.0.tar.gz) = 420ca35928460c87cacc8007f31544be
+SHA256 (honoka-0.9.0.tar.gz) = aa652713003794bddfd2c49806bd6816065cf9c11be3c41a14817041b0663507
+SIZE (honoka-0.9.0.tar.gz) = 570184
diff --git a/japanese/scim-honoka/files/patch-configure b/japanese/scim-honoka/files/patch-configure
new file mode 100644
index 000000000000..bad611f6644a
--- /dev/null
+++ b/japanese/scim-honoka/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Apr 5 20:32:29 2006
++++ configure Wed Apr 5 20:32:45 2006
+@@ -32446,6 +32446,7 @@
+ s,@CONVENIENCE_LTDL_FALSE@,$CONVENIENCE_LTDL_FALSE,;t t
+ s,@LIBADD_DL@,$LIBADD_DL,;t t
+ s,@LIBTOOL_DEPS@,$LIBTOOL_DEPS,;t t
++s,@LIBTOOL_EXPORT_OPTIONS@,$LIBTOOL_EXPORT_OPTIONS,;t t
+ s,@PKG_CONFIG@,$PKG_CONFIG,;t t
+ s,@SCIM_CFLAGS@,$SCIM_CFLAGS,;t t
+ s,@SCIM_LIBS@,$SCIM_LIBS,;t t
diff --git a/japanese/scim-honoka/pkg-descr b/japanese/scim-honoka/pkg-descr
new file mode 100644
index 000000000000..5bf359588b05
--- /dev/null
+++ b/japanese/scim-honoka/pkg-descr
@@ -0,0 +1,13 @@
+Honoka is the SCIM IMEngine module using various input method engines: Wnn,
+anthy,prime,skk and canna. Honoka can also use them simultaneously.
+
+WWW: http://nop.net-p.org/modules/pukiwiki/index.php?%5B%5Bhonoka%5D%5D
+(in Japanese)
+
+This port is honoka "core" library. You must be install honoka "input method"
+and "input" plugin.
+
+Smart Common Input Method platform, in short SCIM, is a development platform to
+make Input Method developers live easier.
+
+WWW: http://scim.freedesktop.org
diff --git a/japanese/scim-honoka/pkg-message b/japanese/scim-honoka/pkg-message
new file mode 100644
index 000000000000..316515697de1
--- /dev/null
+++ b/japanese/scim-honoka/pkg-message
@@ -0,0 +1,11 @@
+--------------------------------------------------------------------
+Remember to set environment variables XMODIFIERS and LANG:
+
+ csh/tcsh: setenv XMODIFIERS @im=SCIM ; setenv LANG ja_JP.eucJP
+ sh/bash: export XMODIFIERS='@im=SCIM'; export LANG=ja_JP.eucJP
+
+To start the SCIM input method daemon, use command:
+
+ scim -d
+
+--------------------------------------------------------------------
diff --git a/japanese/scim-honoka/pkg-plist b/japanese/scim-honoka/pkg-plist
new file mode 100644
index 000000000000..943ca03c4f1d
--- /dev/null
+++ b/japanese/scim-honoka/pkg-plist
@@ -0,0 +1,28 @@
+lib/libhonoka_plugin.a
+lib/libhonoka_plugin.la
+lib/libhonoka_plugin.so
+lib/libhonoka_plugin.so.0
+lib/scim-1.0/IMEngine/honoka.a
+lib/scim-1.0/IMEngine/honoka.la
+lib/scim-1.0/IMEngine/honoka.so
+lib/scim-1.0/SetupUI/honoka-imengine-setup.a
+lib/scim-1.0/SetupUI/honoka-imengine-setup.la
+lib/scim-1.0/SetupUI/honoka-imengine-setup.so
+share/scim/icons/honoka.png
+include/honoka/convertor.h
+include/honoka/honokapluginbase.h
+include/honoka/honokatimer.h
+include/honoka/resultlist.h
+include/honoka/honokakeyeventlist.h
+include/honoka/honokasetupcore.h
+include/honoka/predictor.h
+include/honoka/honokamultiplepluginbase.h
+include/honoka/honokastatus.h
+include/honoka/preeditor.h
+share/locale/ja/LC_MESSAGES/honoka.mo
+libdata/pkgconfig/honoka.pc
+@dirrmtry lib/scim-1.0/IMEngine
+@dirrmtry lib/scim-1.0/SetupUI
+@dirrmtry lib/scim-1.0/honoka
+@dirrmtry share/scim-1.0/icons
+@dirrmtry include/honoka